aboutsummaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python3-os-service-types_1.7.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python3-os-service-types_1.7.0.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python3-os-service-types_1.7.0.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python3-os-service-types_1.7.0.bb b/meta-openstack/recipes-devtools/python/python3-os-service-types_1.7.0.bb
new file mode 100644
index 00000000..71f756a6
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-os-service-types_1.7.0.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "Python library for consuming OpenStack sevice-types-authority data"
+HOMEPAGE = "https://pypi.org/project/os-service-types/"
+SECTION = "devel/python"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
+
+SRC_URI[sha256sum] = "31800299a82239363995b91f1ebf9106ac7758542a1e4ef6dc737a5932878c6c"
+
+inherit setuptools3 pypi
+
+DEPENDS += " \
+ python3-pbr-native \
+ "
+
+RDEPENDS:${PN} += " \
+ python3-pbr \
+ "