aboutsummaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python3-openstack-nose_0.11.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python3-openstack-nose_0.11.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python3-openstack-nose_0.11.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python3-openstack-nose_0.11.bb b/meta-openstack/recipes-devtools/python/python3-openstack-nose_0.11.bb
new file mode 100644
index 00000000..9dcbb7ff
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-openstack-nose_0.11.bb
@@ -0,0 +1,26 @@
+#
+# Copyright (C) 2014 Wind River Systems, Inc.
+#
+DESCRIPTION = "Openstack style output for nosetests"
+HOMEPAGE = "https://github.com/jkoelker/openstack-nose"
+SECTION = "devel/python"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+PYPI_PACKAGE = "openstack.nose_plugin"
+
+SRC_URI[md5sum] = "0c6547f413db8c66921b110f78132aac"
+SRC_URI[sha256sum] = "a28d44dc23de8164d7893da7020404c73c4325b46d5507911f0257c15f613b4f"
+
+inherit setuptools3 pypi
+
+DEPENDS += " \
+ python3-pip \
+ "
+
+RDEPENDS:${PN} += " \
+ python3-nose \
+ python3-colorama \
+ python3-termcolor \
+ "
+