aboutsummaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python3-memcached_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python3-memcached_git.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python3-memcached_git.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python3-memcached_git.bb b/meta-openstack/recipes-devtools/python/python3-memcached_git.bb
new file mode 100644
index 00000000..aaa5d686
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-memcached_git.bb
@@ -0,0 +1,24 @@
+SUMMARY = "Pure python memcached client"
+DESCRIPTION = "\
+ This software is a 100% Python interface to the memcached memory cache daemon. \
+ It is the client side software which allows storing values in one or more, possibly remote, \
+ memcached servers. Search google for memcached for more information."
+HOMEPAGE = "https://pypi.python.org/pypi/python-memcached/"
+SECTION = "devel/python"
+LICENSE = "PSF-2.0"
+LIC_FILES_CHKSUM = "file://PSF.LICENSE;md5=7dd786e8594f1e787da94a946557b40e"
+
+PV = "1.59+git${SRCPV}"
+SRCREV = "959e068fec8b4c956b0d82269336818e667726e7"
+
+SRC_URI = "git://github.com/linsomniac/python-memcached.git;branch=master;protocol=https"
+
+S = "${WORKDIR}/git"
+
+inherit setuptools3
+
+RDEPENDS:${PN} += " \
+ ${PYTHON_PN}-six \
+ ${PYTHON_PN}-pickle \
+ "
+