aboutsummaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python3-memcache_3.4.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python3-memcache_3.4.0.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python3-memcache_3.4.0.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python3-memcache_3.4.0.bb b/meta-openstack/recipes-devtools/python/python3-memcache_3.4.0.bb
new file mode 100644
index 00000000..cb7dadc4
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-memcache_3.4.0.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "A comprehensive, fast, pure Python memcached client"
+HOMEPAGE = "https://github.com/Pinterest/pymemcache"
+SECTION = "devel/python"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://PKG-INFO;md5=efde6ee9f51b69abbdca7d447b0d1488"
+
+PYPI_PACKAGE = "pymemcache"
+
+SRC_URI[md5sum] = "f0da0618d828f67ff3e0742c9ace3cd7"
+SRC_URI[sha256sum] = "47882ab1c7e5e1dea67df8aa9faf410ce82e606fd5f29501273a60ff61d7cc99"
+
+inherit setuptools3 pypi
+
+# DEPENDS_default: python-pip
+
+DEPENDS += " \
+ ${PYTHON_PN}-pip \
+ ${PYTHON_PN}-six-native \
+ "
+
+# RDEPENDS:default:
+RDEPENDS:${PN} += " \
+ ${PYTHON_PN}-io \
+ ${PYTHON_PN}-six \
+ ${PYTHON_PN}-logging \
+ "