aboutsummaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python3-lockfile_0.12.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python3-lockfile_0.12.2.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python3-lockfile_0.12.2.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python3-lockfile_0.12.2.bb b/meta-openstack/recipes-devtools/python/python3-lockfile_0.12.2.bb
new file mode 100644
index 00000000..ba446380
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-lockfile_0.12.2.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "Platform-independent file locking module"
+HOMEPAGE = "http://code.google.com/p/pylockfile/"
+SECTION = "devel/python"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=2340dffbbfea534b58f1349984eeef72"
+
+SRC_URI[md5sum] = "a6a1a82957a23afdf44cfdd039b65ff9"
+SRC_URI[sha256sum] = "6aed02de03cba24efabcd600b30540140634fc06cfa603822d508d5361e9f799"
+
+inherit setuptools3 pypi
+
+DEPENDS += "\
+ python3-pbr \
+ "
+
+# Satisfy setup.py 'setup_requires'
+DEPENDS += " \
+ python3-pbr-native \
+ "
+
+RDEPENDS:${PN} += "\
+ python3-pbr \
+ "