aboutsummaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python3-lesscpy_0.14.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python3-lesscpy_0.14.0.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python3-lesscpy_0.14.0.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python3-lesscpy_0.14.0.bb b/meta-openstack/recipes-devtools/python/python3-lesscpy_0.14.0.bb
new file mode 100644
index 00000000..74da06d5
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-lesscpy_0.14.0.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "Python lesscpy: Python LESS Compiler"
+HOMEPAGE = "https://pypi.python.org/pypi/lesscpy"
+SECTION = "devel/python"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=a01aae31681ac25b4c46f98d627b9b5d"
+
+DEPENDS += "${PYTHON_PN}-ply"
+RDEPENDS:${PN} += "${PYTHON_PN}-ply"
+
+SRC_URI[md5sum] = "efe82be479ddb7bdc48b2114dab94b20"
+SRC_URI[sha256sum] = "7b664f60818a16afa8cc9f1dd6d9b17f944e0ce94e50787d76f81bc7a8648cce"
+
+inherit setuptools3 pypi
+
+DISTUTILS_INSTALL_ARGS = "--root=${D} \
+ --prefix=${prefix} \
+ --install-lib=${PYTHON_SITEPACKAGES_DIR} \
+ --install-data=${datadir}"