aboutsummaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python3-kafka_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python3-kafka_git.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python3-kafka_git.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python3-kafka_git.bb b/meta-openstack/recipes-devtools/python/python3-kafka_git.bb
new file mode 100644
index 00000000..24b3220a
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-kafka_git.bb
@@ -0,0 +1,27 @@
+SUMMARY = "Python client for Apache Kafka"
+HOMEPAGE = "https://github.com/mumrah/kafka-python"
+SECTION = "devel/python"
+LICENSE = "Apache-2.0"
+
+PV = "2.0.2+git${SRCPV}"
+SRCREV = "5bb126bf20bbb5baeb4e9afc48008dbe411631bc"
+
+SRCNAME = "kafka-python"
+
+LIC_FILES_CHKSUM = "file://LICENSE;md5=22efebb1e053dcc946f4b9d17f3cbbea"
+SRC_URI = "git://github.com/mumrah/${SRCNAME}.git;branch=master;protocol=https"
+
+S = "${WORKDIR}/git"
+
+inherit setuptools3
+
+DEPENDS += " \
+ ${PYTHON_PN}-pbr \
+ "
+
+RDEPENDS:${PN} += " \
+ ${PYTHON_PN}-six \
+ ${PYTHON_PN}-logging \
+ ${PYTHON_PN}-compression \
+ "
+