aboutsummaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python3-kafka_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python3-kafka_git.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python3-kafka_git.bb26
1 files changed, 25 insertions, 1 deletions
diff --git a/meta-openstack/recipes-devtools/python/python3-kafka_git.bb b/meta-openstack/recipes-devtools/python/python3-kafka_git.bb
index 55c9fcbb..24b3220a 100644
--- a/meta-openstack/recipes-devtools/python/python3-kafka_git.bb
+++ b/meta-openstack/recipes-devtools/python/python3-kafka_git.bb
@@ -1,3 +1,27 @@
-require python-kafka.inc
+SUMMARY = "Python client for Apache Kafka"
+HOMEPAGE = "https://github.com/mumrah/kafka-python"
+SECTION = "devel/python"
+LICENSE = "Apache-2.0"
+
+PV = "2.0.2+git${SRCPV}"
+SRCREV = "5bb126bf20bbb5baeb4e9afc48008dbe411631bc"
+
+SRCNAME = "kafka-python"
+
+LIC_FILES_CHKSUM = "file://LICENSE;md5=22efebb1e053dcc946f4b9d17f3cbbea"
+SRC_URI = "git://github.com/mumrah/${SRCNAME}.git;branch=master;protocol=https"
+
+S = "${WORKDIR}/git"
+
inherit setuptools3
+DEPENDS += " \
+ ${PYTHON_PN}-pbr \
+ "
+
+RDEPENDS:${PN} += " \
+ ${PYTHON_PN}-six \
+ ${PYTHON_PN}-logging \
+ ${PYTHON_PN}-compression \
+ "
+