aboutsummaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python3-debtcollector_2.2.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python3-debtcollector_2.2.0.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python3-debtcollector_2.2.0.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python3-debtcollector_2.2.0.bb b/meta-openstack/recipes-devtools/python/python3-debtcollector_2.2.0.bb
new file mode 100644
index 00000000..e216c8b0
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-debtcollector_2.2.0.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "A collection of Python deprecation patterns and strategies that help you collect your technical debt in a non-destructive manner."
+HOMEPAGE = "http://docs.openstack.org/developer/debtcollector/"
+SECTION = "devel/python"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
+
+SRC_URI[md5sum] = "6ac3af37693e0f517e51593d9ea33f23"
+SRC_URI[sha256sum] = "787981f4d235841bf6eb0467e23057fb1ac7ee24047c32028a8498b9128b6829"
+
+inherit setuptools3 pypi
+
+DEPENDS += " \
+ ${PYTHON_PN}-pip \
+ ${PYTHON_PN}-pbr \
+ "
+
+# Satisfy setup.py 'setup_requires'
+DEPENDS += " \
+ ${PYTHON_PN}-pbr-native \
+ "
+
+# RDEPENDS:default:
+RDEPENDS:${PN} += " \
+ ${PYTHON_PN}-pbr \
+ ${PYTHON_PN}-wrapt \
+ ${PYTHON_PN}-six \
+ "