aboutsummaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-tox.inc
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-tox.inc')
-rw-r--r--meta-openstack/recipes-devtools/python/python-tox.inc29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-tox.inc b/meta-openstack/recipes-devtools/python/python-tox.inc
new file mode 100644
index 00000000..c483424a
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-tox.inc
@@ -0,0 +1,29 @@
+DESCRIPTION = "virtualenv-based automation of test activities"
+HOMEPAGE = "http://tox.testrun.org"
+SECTION = "devel/python"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=f24505dfbdd8c22c61de6383f2e74bf9"
+
+inherit pypi
+
+DEPENDS += " \
+ ${PYTHON_PN}-pip \
+ "
+
+RDEPENDS:${PN} += " \
+ ${PYTHON_PN}-virtualenv \
+ ${PYTHON_PN}-py \
+ ${PYTHON_PN}-pytest \
+ "
+
+do_install:append() {
+
+ install -d ${D}/${sysconfdir}/${SRCNAME}
+ cp ${S}/tox.ini ${D}/${sysconfdir}/${SRCNAME}
+ cp ${S}/setup.py ${D}/${sysconfdir}/${SRCNAME}
+ cp ${S}/README.md ${D}/${sysconfdir}/${SRCNAME}
+
+ ln -s ${PYTHON_SITEPACKAGES_DIR}/tox ${D}/${sysconfdir}/${SRCNAME}/tox
+}
+
+FILES:${PN} += "${sysconfdir}/${SRCNAME}/*"