aboutsummaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-openstackclient_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-openstackclient_git.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-openstackclient_git.bb11
1 files changed, 8 insertions, 3 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-openstackclient_git.bb b/meta-openstack/recipes-devtools/python/python-openstackclient_git.bb
index ce33f0cc..b345c396 100644
--- a/meta-openstack/recipes-devtools/python/python-openstackclient_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-openstackclient_git.bb
@@ -5,20 +5,25 @@ LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
SRC_URI = " \
- git://github.com/openstack/python-openstackclient.git;branch=stable/pike \
+ git://github.com/openstack/python-openstackclient.git;branch=stable/pike;protocol=https \
"
PV = "3.12.0+git${SRCPV}"
SRCREV = "ff4abb7d19829efa0209cb67faf01011d9c841c5"
S = "${WORKDIR}/git"
-inherit setuptools
+inherit setuptools3
DEPENDS += "\
python-pbr \
"
-RDEPENDS_${PN} += " \
+# Satisfy setup.py 'setup_requires'
+DEPENDS += " \
+ python-pbr-native \
+ "
+
+RDEPENDS:${PN} += " \
python-pbr \
python-six \
python-babel \