aboutsummaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-neutron-lib_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-neutron-lib_git.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-neutron-lib_git.bb9
1 files changed, 7 insertions, 2 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-neutron-lib_git.bb b/meta-openstack/recipes-devtools/python/python-neutron-lib_git.bb
index 1ac7dca1..343942f4 100644
--- a/meta-openstack/recipes-devtools/python/python-neutron-lib_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-neutron-lib_git.bb
@@ -12,13 +12,18 @@ PV="1.9.1+git${SRCPV}"
SRCREV="f0d7e470c2ef1702b2715ceb2fd8a00fce2a23be"
S = "${WORKDIR}/git"
-inherit setuptools
+inherit setuptools3
DEPENDS += " \
python-pbr \
"
-RDEPENDS_${PN} += " \
+# Satisfy setup.py 'setup_requires'
+DEPENDS += " \
+ python-pbr-native \
+ "
+
+RDEPENDS:${PN} += " \
python-pbr \
python-sqlalchemy \
python-debtcollector \