aboutsummaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-heatclient_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-heatclient_git.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-heatclient_git.bb12
1 files changed, 6 insertions, 6 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-heatclient_git.bb b/meta-openstack/recipes-devtools/python/python-heatclient_git.bb
index e0927f3c..0c153805 100644
--- a/meta-openstack/recipes-devtools/python/python-heatclient_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-heatclient_git.bb
@@ -14,7 +14,7 @@ DEPENDS += " \
python-pbr-native \
"
-RDEPENDS_${PN} +="python-cliff \
+RDEPENDS:${PN} +="python-cliff \
python-httplib2 \
python-iso8601 \
python-prettytable \
@@ -27,7 +27,7 @@ RDEPENDS_${PN} +="python-cliff \
PR = "r0"
SRCNAME = "heatclient"
-SRC_URI = "git://github.com/openstack/python-heatclient.git;branch=master"
+SRC_URI = "git://github.com/openstack/python-heatclient.git;branch=master;protocol=https"
PV = "1.17.0+git${SRCPV}"
SRCREV = "8af5deb458d51f4ec16e769d7fd6c94655f82f5f"
@@ -39,15 +39,15 @@ inherit setuptools3
PACKAGECONFIG ?= "bash-completion"
PACKAGECONFIG[bash-completion] = ",,bash-completion,bash-completion ${BPN}-bash-completion"
-do_install_append() {
+do_install:append() {
install -d ${D}/${sysconfdir}/bash_completion.d
install -m 664 ${S}/tools/heat.bash_completion ${D}/${sysconfdir}/bash_completion.d
}
PACKAGES =+ "${SRCNAME}-tests ${BPN}-bash-completion"
-FILES_${BPN}-bash-completion = "${sysconfdir}/bash_completion.d/*"
-ALLOW_EMPTY_${SRCNAME}-tests = "1"
+FILES:${BPN}-bash-completion = "${sysconfdir}/bash_completion.d/*"
+ALLOW_EMPTY:${SRCNAME}-tests = "1"
-RDEPENDS_${SRCNAME}-tests += "python-testscenarios \
+RDEPENDS:${SRCNAME}-tests += "python-testscenarios \
python-mox3 \
"