aboutsummaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-cinderclient_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-cinderclient_git.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-cinderclient_git.bb8
1 files changed, 4 insertions, 4 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-cinderclient_git.bb b/meta-openstack/recipes-devtools/python/python-cinderclient_git.bb
index bacb25f9..bd360edf 100644
--- a/meta-openstack/recipes-devtools/python/python-cinderclient_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-cinderclient_git.bb
@@ -8,7 +8,7 @@ DEPENDS = "python-setuptools3-git"
SRCNAME = "python-cinderclient"
SRC_URI = "\
- git://github.com/openstack/python-cinderclient.git;branch=stable/pike \
+ git://github.com/openstack/python-cinderclient.git;branch=stable/pike;protocol=https \
file://cinder-api-check.sh \
"
@@ -28,7 +28,7 @@ DEPENDS += " \
python-pbr-native \
"
-RDEPENDS_${PN} += " \
+RDEPENDS:${PN} += " \
python-pbr \
python-prettytable \
python-keystoneauth1 \
@@ -43,13 +43,13 @@ RDEPENDS_${PN} += " \
PACKAGECONFIG ?= "bash-completion"
PACKAGECONFIG[bash-completion] = ",,bash-completion,bash-completion ${BPN}-bash-completion"
-do_install_append() {
+do_install:append() {
install -d ${D}/${sysconfdir}/bash_completion.d
install -m 664 ${S}/tools/cinder.bash_completion ${D}/${sysconfdir}/bash_completion.d
}
PACKAGES =+ "${BPN}-bash-completion"
-FILES_${BPN}-bash-completion = "${sysconfdir}/bash_completion.d/*"
+FILES:${BPN}-bash-completion = "${sysconfdir}/bash_completion.d/*"
MONITOR_CHECKS_${PN} += "\
cinder-api-check.sh \