aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-openstack/recipes-devtools/python/python-kafka.inc23
-rw-r--r--meta-openstack/recipes-devtools/python/python-kafka_git.bb24
-rw-r--r--meta-openstack/recipes-devtools/python/python3-kafka_git.bb3
3 files changed, 27 insertions, 23 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-kafka.inc b/meta-openstack/recipes-devtools/python/python-kafka.inc
new file mode 100644
index 00000000..0b360c1a
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-kafka.inc
@@ -0,0 +1,23 @@
+SUMMARY = "Python client for Apache Kafka"
+HOMEPAGE = "https://github.com/mumrah/kafka-python"
+SECTION = "devel/python"
+LICENSE = "Apache-2.0"
+
+PV = "1.4.7+git${SRCPV}"
+SRCREV = "0552b04326c73be29f209c12920ef4cbaceb9818"
+
+SRCNAME = "kafka-python"
+
+LIC_FILES_CHKSUM = "file://LICENSE;md5=22efebb1e053dcc946f4b9d17f3cbbea"
+SRC_URI = "git://github.com/mumrah/${SRCNAME}.git"
+
+S = "${WORKDIR}/git"
+
+DEPENDS += " \
+ ${PYTHON_PN}-pbr \
+ "
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-six \
+ "
+
diff --git a/meta-openstack/recipes-devtools/python/python-kafka_git.bb b/meta-openstack/recipes-devtools/python/python-kafka_git.bb
index 7fbb8262..8a474c85 100644
--- a/meta-openstack/recipes-devtools/python/python-kafka_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-kafka_git.bb
@@ -1,25 +1,3 @@
-SUMMARY = "Python client for Apache Kafka"
-HOMEPAGE = "https://github.com/mumrah/kafka-python"
-SECTION = "devel/python"
-LICENSE = "Apache-2.0"
-
-PV = "0.9.4+git${SRCPV}"
-SRCREV = "4955582be1443b75c23f700268b7abbef0fde0ad"
-
-SRCNAME = "kafka-python"
-
-LIC_FILES_CHKSUM = "file://LICENSE;md5=22efebb1e053dcc946f4b9d17f3cbbea"
-SRC_URI = "git://github.com/mumrah/${SRCNAME}.git"
-
-S = "${WORKDIR}/git"
-
+require python-kafka.inc
inherit setuptools
-DEPENDS += " \
- python-pbr \
- "
-
-RDEPENDS_${PN} += " \
- python-six \
- "
-
diff --git a/meta-openstack/recipes-devtools/python/python3-kafka_git.bb b/meta-openstack/recipes-devtools/python/python3-kafka_git.bb
new file mode 100644
index 00000000..55c9fcbb
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-kafka_git.bb
@@ -0,0 +1,3 @@
+require python-kafka.inc
+inherit setuptools3
+