aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-installer/anaconda/files/0057-do-not-customize-window-theme.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-installer/anaconda/files/0057-do-not-customize-window-theme.patch')
-rw-r--r--recipes-installer/anaconda/files/0057-do-not-customize-window-theme.patch48
1 files changed, 37 insertions, 11 deletions
diff --git a/recipes-installer/anaconda/files/0057-do-not-customize-window-theme.patch b/recipes-installer/anaconda/files/0057-do-not-customize-window-theme.patch
index 817aa26..2762def 100644
--- a/recipes-installer/anaconda/files/0057-do-not-customize-window-theme.patch
+++ b/recipes-installer/anaconda/files/0057-do-not-customize-window-theme.patch
@@ -14,23 +14,39 @@ Also remove install-data-hook, which caused host contamination
Upstream-Status: Inappropriate [oe specific]
Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
+
+Rebase for anaconda 34.
+
+Signed-off-by: Kai Kang <kai.kang@windriver.com>
+
+Rebase for anaconda 37. And it replaces metacity with gnome-kiosk in
+upstream. Revert it and turn back to metacity.
+
+Signed-off-by: Kai Kang <kai.kang@windriver.com>
+
+Rebase for anaconda 38 on 20231107.
+
+Signed-off-by: Kai Kang <kai.kang@windriver.com>
+
+Rebase for anaconda 39 on 20240304.
+
+Signed-off-by: Kai Kang <kai.kang@windriver.com>
---
- data/window-manager/config/Makefile.am | 7 +------
- pyanaconda/display.py | 2 +-
- 2 files changed, 2 insertions(+), 7 deletions(-)
+ data/window-manager/config/Makefile.am | 6 +-----
+ pyanaconda/display.py | 6 +++---
+ 2 files changed, 4 insertions(+), 8 deletions(-)
diff --git a/data/window-manager/config/Makefile.am b/data/window-manager/config/Makefile.am
-index 6d78347..f17ab6a 100644
+index 90e71d9161..5d7a2b80e1 100644
--- a/data/window-manager/config/Makefile.am
+++ b/data/window-manager/config/Makefile.am
-@@ -27,12 +27,7 @@ dist_schema_DATA = org.gnome.desktop.wm.keybindings.gschema.override \
+@@ -26,11 +26,7 @@ dist_schema_DATA = org.gnome.desktop.wm.keybindings.gschema.override \
# schemas they modify, so pretend that this is the case with symlinks and
# create the compiled schema.
install-data-hook:
- $(MKDIR_P) $(DESTDIR)$(schemadir)
- $(LN_S) -f /usr/share/glib-2.0/schemas/org.gnome.desktop.wm.keybindings.gschema.xml $(DESTDIR)$(schemadir)
- $(LN_S) -f /usr/share/glib-2.0/schemas/org.gnome.desktop.wm.preferences.gschema.xml $(DESTDIR)$(schemadir)
-- $(LN_S) -f /usr/share/glib-2.0/schemas/org.gnome.metacity.gschema.xml $(DESTDIR)$(schemadir)
- $(LN_S) -f /usr/share/glib-2.0/schemas/org.gnome.desktop.enums.xml $(DESTDIR)$(schemadir)
- glib-compile-schemas --strict $(DESTDIR)$(schemadir)
+ echo "pass"
@@ -38,18 +54,28 @@ index 6d78347..f17ab6a 100644
uninstall-local:
rm -f $(DESTDIR)$(schemadir)/*.xml
diff --git a/pyanaconda/display.py b/pyanaconda/display.py
-index f76bc30..afa03a6 100644
+index a00431c6c0..2c41a6c4cc 100644
--- a/pyanaconda/display.py
+++ b/pyanaconda/display.py
-@@ -172,7 +172,7 @@ def do_startup_x11_actions():
+@@ -204,16 +204,16 @@ def do_startup_x11_actions():
if 'XDG_DATA_DIRS' in os.environ:
xdg_data_dirs = datadir + '/window-manager:' + os.environ['XDG_DATA_DIRS']
else:
- xdg_data_dirs = datadir + '/window-manager:/usr/share'
+ xdg_data_dirs = '/usr/share'
- childproc = util.startProgram(["metacity", "--display", ":1", "--sm-disable"],
- env_add={'XDG_DATA_DIRS': xdg_data_dirs})
+ def x11_preexec():
+ # to set GUI subprocess SIGINT handler
+ signal.signal(signal.SIGINT, signal.SIG_IGN)
+
+- childproc = util.startProgram(["gnome-kiosk", "--display", ":1", "--sm-disable", "--x11"],
++ childproc = util.startProgram(["metacity", "--display", ":1", "--sm-disable"],
+ env_add={'XDG_DATA_DIRS': xdg_data_dirs},
+ preexec_fn=x11_preexec)
+- WatchProcesses.watch_process(childproc, "gnome-kiosk")
++ WatchProcesses.watch_process(childproc, "metacity")
+
+
+ def set_x_resolution(runres):
--
2.7.4
-