aboutsummaryrefslogtreecommitdiffstats
path: root/meta-v1000
diff options
context:
space:
mode:
Diffstat (limited to 'meta-v1000')
-rw-r--r--meta-v1000/recipes-graphics/drm/libdrm/amdgpu.ids2
-rw-r--r--meta-v1000/recipes-graphics/lunarg-sdk/vulkan-tools_1.0.65.bb2
-rw-r--r--meta-v1000/recipes-kernel/linux/files/disable-bluetooth.cfg1
-rw-r--r--meta-v1000/recipes-kernel/linux/files/disable-kgdb.cfg1
-rw-r--r--meta-v1000/recipes-kernel/linux/files/enable-bluetooth.cfg13
-rw-r--r--meta-v1000/recipes-kernel/linux/files/enable-kgdb.cfg3
-rw-r--r--meta-v1000/recipes-kernel/linux/files/hid.cfg5
-rw-r--r--meta-v1000/recipes-kernel/linux/files/v1000-extra-config.cfg18
-rw-r--r--meta-v1000/recipes-kernel/linux/files/wifi-drivers.cfg9
-rw-r--r--meta-v1000/recipes-kernel/linux/linux-yocto-v1000_4.9.inc4
-rw-r--r--meta-v1000/recipes-multimedia/ffmpeg/ffmpeg_3.2.2.bb142
-rw-r--r--meta-v1000/recipes-multimedia/mpv/mpv_0.24.0.bb60
12 files changed, 241 insertions, 19 deletions
diff --git a/meta-v1000/recipes-graphics/drm/libdrm/amdgpu.ids b/meta-v1000/recipes-graphics/drm/libdrm/amdgpu.ids
index cab91992..35994e2a 100644
--- a/meta-v1000/recipes-graphics/drm/libdrm/amdgpu.ids
+++ b/meta-v1000/recipes-graphics/drm/libdrm/amdgpu.ids
@@ -194,3 +194,5 @@
9874, 87, AMD Radeon R5 Graphics
9874, 85, AMD Radeon R6 Graphics
9874, 84, AMD Radeon R7 Graphics
+15DD, C0, AMD Radeon (TM) Vega Graphics
+15DD, C1, AMD Radeon (TM) Vega Graphics
diff --git a/meta-v1000/recipes-graphics/lunarg-sdk/vulkan-tools_1.0.65.bb b/meta-v1000/recipes-graphics/lunarg-sdk/vulkan-tools_1.0.65.bb
index 295d4c8d..d26d7862 100644
--- a/meta-v1000/recipes-graphics/lunarg-sdk/vulkan-tools_1.0.65.bb
+++ b/meta-v1000/recipes-graphics/lunarg-sdk/vulkan-tools_1.0.65.bb
@@ -48,7 +48,7 @@ INSANE_SKIP_${PN}-layer-libs = "ldflags"
# Conditional building of vktraceviewer
QTBITS ?= "${@bb.utils.contains('BBFILE_COLLECTIONS', 'qt5-layer', 'cmake_qt5', '',d)}"
inherit ${QTBITS}
-DEPENDS += "${@base_conditional('QTBITS', '', '', 'libxcb', d)}"
+DEPENDS += "${@base_conditional('QTBITS', '', '', 'libxcb qtsvg', d)}"
RDEPENDS_${PN}_append = " ${@base_conditional('QTBITS', '', '', 'qtsvg', d)}"
do_install_append() {
if [ "${QTBITS}" != "" ]
diff --git a/meta-v1000/recipes-kernel/linux/files/disable-bluetooth.cfg b/meta-v1000/recipes-kernel/linux/files/disable-bluetooth.cfg
new file mode 100644
index 00000000..ce6ddb43
--- /dev/null
+++ b/meta-v1000/recipes-kernel/linux/files/disable-bluetooth.cfg
@@ -0,0 +1 @@
+# CONFIG_BT is not set
diff --git a/meta-v1000/recipes-kernel/linux/files/disable-kgdb.cfg b/meta-v1000/recipes-kernel/linux/files/disable-kgdb.cfg
new file mode 100644
index 00000000..b8a2218b
--- /dev/null
+++ b/meta-v1000/recipes-kernel/linux/files/disable-kgdb.cfg
@@ -0,0 +1 @@
+# CONFIG_KGDB is not set
diff --git a/meta-v1000/recipes-kernel/linux/files/enable-bluetooth.cfg b/meta-v1000/recipes-kernel/linux/files/enable-bluetooth.cfg
new file mode 100644
index 00000000..581830f0
--- /dev/null
+++ b/meta-v1000/recipes-kernel/linux/files/enable-bluetooth.cfg
@@ -0,0 +1,13 @@
+CONFIG_BT=m
+CONFIG_BT_RFCOMM=m
+CONFIG_BT_BNEP=m
+CONFIG_BT_HIDP=m
+CONFIG_BT_HCIBFUSB=m
+CONFIG_BT_HCIBTUSB=m
+CONFIG_BT_HCIBTSDIO=m
+CONFIG_BT_HCIUART=m
+CONFIG_BT_HCIBCM203X=m
+CONFIG_BT_HCIBPA10X=m
+CONFIG_BT_HCIVHCI=m
+CONFIG_BT_MRVL=m
+CONFIG_BT_ATH3K=m
diff --git a/meta-v1000/recipes-kernel/linux/files/enable-kgdb.cfg b/meta-v1000/recipes-kernel/linux/files/enable-kgdb.cfg
new file mode 100644
index 00000000..55f296b2
--- /dev/null
+++ b/meta-v1000/recipes-kernel/linux/files/enable-kgdb.cfg
@@ -0,0 +1,3 @@
+CONFIG_KGDB=y
+CONFIG_KGDB_LOW_LEVEL_TRAP=y
+CONFIG_KGDB_KDB=y
diff --git a/meta-v1000/recipes-kernel/linux/files/hid.cfg b/meta-v1000/recipes-kernel/linux/files/hid.cfg
new file mode 100644
index 00000000..cbab0fa7
--- /dev/null
+++ b/meta-v1000/recipes-kernel/linux/files/hid.cfg
@@ -0,0 +1,5 @@
+CONFIG_HID_A4TECH=m
+CONFIG_HID_LOGITECH=m
+CONFIG_HID_LOGITECH_DJ=m
+CONFIG_HID_MICROSOFT=m
+CONFIG_HID_MULTITOUCH=m
diff --git a/meta-v1000/recipes-kernel/linux/files/v1000-extra-config.cfg b/meta-v1000/recipes-kernel/linux/files/v1000-extra-config.cfg
index 92584a04..784b6821 100644
--- a/meta-v1000/recipes-kernel/linux/files/v1000-extra-config.cfg
+++ b/meta-v1000/recipes-kernel/linux/files/v1000-extra-config.cfg
@@ -80,15 +80,6 @@ CONFIG_TIPC_MEDIA_UDP=y
# CONFIG_NET_ACT_CONNMARK is not set
# CONFIG_MPLS is not set
# CONFIG_NET_SWITCHDEV is not set
-CONFIG_BT_BREDR=y
-CONFIG_BT_LE=y
-# CONFIG_BT_SELFTEST is not set
-CONFIG_BT_DEBUGFS=y
-CONFIG_BT_INTEL=m
-CONFIG_BT_BCM=m
-CONFIG_BT_HCIBTUSB_BCM=y
-# CONFIG_BT_HCIUART_INTEL is not set
-# CONFIG_BT_HCIUART_BCM is not set
# CONFIG_MAC80211_RC_MINSTREL_VHT is not set
CONFIG_UEVENT_HELPER=y
# CONFIG_FW_LOADER_USER_HELPER_FALLBACK is not set
@@ -126,7 +117,6 @@ CONFIG_USB_NET_DRIVERS=y
CONFIG_ATH9K_PCOEM=y
CONFIG_BRCMFMAC_PROTO_BCDC=y
# CONFIG_BRCMFMAC_PCIE is not set
-CONFIG_IWLWIFI_LEDS=y
# CONFIG_RTL8723BE is not set
# CONFIG_RTL8192EE is not set
# CONFIG_RTL8821AE is not set
@@ -307,14 +297,6 @@ CONFIG_SND_SOC_GENERIC_DMAENGINE_PCM=y
# CONFIG_SND_SOC_WM8962 is not set
# CONFIG_SND_SOC_WM8978 is not set
# CONFIG_SND_SOC_TPA6130A2 is not set
-# CONFIG_HID_BETOP_FF is not set
-# CONFIG_HID_CP2112 is not set
-# CONFIG_HID_GT683R is not set
-# CONFIG_HID_LENOVO is not set
-# CONFIG_HID_LOGITECH_HIDPP is not set
-# CONFIG_HID_PENMOUNT is not set
-# CONFIG_HID_PLANTRONICS is not set
-# CONFIG_HID_RMI is not set
# CONFIG_USB_OTG_FSM is not set
CONFIG_USB_XHCI_PCI=y
# CONFIG_USB_MAX3421_HCD is not set
diff --git a/meta-v1000/recipes-kernel/linux/files/wifi-drivers.cfg b/meta-v1000/recipes-kernel/linux/files/wifi-drivers.cfg
new file mode 100644
index 00000000..8b407303
--- /dev/null
+++ b/meta-v1000/recipes-kernel/linux/files/wifi-drivers.cfg
@@ -0,0 +1,9 @@
+CONFIG_CFG80211_WEXT=y
+CONFIG_WEXT_CORE=y
+CONFIG_WEXT_PROC=y
+CONFIG_IWLWIFI=m
+CONFIG_IWLDVM=m
+CONFIG_IWLWIFI_OPMODE_MODULAR=y
+CONFIG_CARL9170=m
+CONFIG_CARL9170_LEDS=y
+CONFIG_CARL9170_WPC=y
diff --git a/meta-v1000/recipes-kernel/linux/linux-yocto-v1000_4.9.inc b/meta-v1000/recipes-kernel/linux/linux-yocto-v1000_4.9.inc
index fe733f91..228b8dc5 100644
--- a/meta-v1000/recipes-kernel/linux/linux-yocto-v1000_4.9.inc
+++ b/meta-v1000/recipes-kernel/linux/linux-yocto-v1000_4.9.inc
@@ -12,6 +12,10 @@ SRC_URI_append_v1000 += "file://v1000-user-features.scc \
file://v1000-user-config.cfg \
file://v1000-gpu-config.cfg \
file://v1000-extra-config.cfg \
+ file://hid.cfg \
+ file://wifi-drivers.cfg \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', 'file://enable-bluetooth.cfg', 'file://disable-bluetooth.cfg', d)} \
+ ${@bb.utils.contains('DISTRO', 'mel', 'file://enable-kgdb.cfg', 'file://disable-kgdb.cfg', d)} \
"
KERNEL_FEATURES_append_v1000 = " cfg/smp.scc cfg/sound.scc"
diff --git a/meta-v1000/recipes-multimedia/ffmpeg/ffmpeg_3.2.2.bb b/meta-v1000/recipes-multimedia/ffmpeg/ffmpeg_3.2.2.bb
new file mode 100644
index 00000000..6afdee27
--- /dev/null
+++ b/meta-v1000/recipes-multimedia/ffmpeg/ffmpeg_3.2.2.bb
@@ -0,0 +1,142 @@
+SUMMARY = "A complete, cross-platform solution to record, convert and stream audio and video."
+DESCRIPTION = "FFmpeg is the leading multimedia framework, able to decode, encode, transcode, \
+ mux, demux, stream, filter and play pretty much anything that humans and machines \
+ have created. It supports the most obscure ancient formats up to the cutting edge."
+HOMEPAGE = "https://www.ffmpeg.org/"
+SECTION = "libs"
+
+LICENSE = "GPLv2+"
+LICENSE_FLAGS = "commercial"
+
+LIC_FILES_CHKSUM = "file://COPYING.GPLv2;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
+ file://COPYING.GPLv3;md5=d32239bcb673463ab874e80d47fae504 \
+ file://COPYING.LGPLv2.1;md5=bd7a443320af8c812e4c18d1b79df004 \
+ file://COPYING.LGPLv3;md5=e6a600fd5e1d9cbde2d983680233ad02"
+
+SRC_URI = "https://www.ffmpeg.org/releases/${BP}.tar.xz \
+ "
+SRC_URI[md5sum] = "e34d1b92c5d844f2a3611c741a6dba18"
+SRC_URI[sha256sum] = "3f01bd1fe1a17a277f8c84869e5d9192b4b978cb660872aa2b54c3cc8a2fedfc"
+
+# Build fails when thumb is enabled: https://bugzilla.yoctoproject.org/show_bug.cgi?id=7717
+ARM_INSTRUCTION_SET = "arm"
+
+# Should be API compatible with libav (which was a fork of ffmpeg)
+# libpostproc was previously packaged from a separate recipe
+PROVIDES = "libav libpostproc"
+
+DEPENDS = "alsa-lib zlib libogg yasm-native"
+
+inherit autotools pkgconfig
+
+PACKAGECONFIG ??= "avdevice avfilter avcodec avformat swresample swscale postproc \
+ bzlib gpl lzma theora x264 \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11 xv', '', d)}"
+
+# libraries to build in addition to avutil
+PACKAGECONFIG[avdevice] = "--enable-avdevice,--disable-avdevice"
+PACKAGECONFIG[avfilter] = "--enable-avfilter,--disable-avfilter"
+PACKAGECONFIG[avcodec] = "--enable-avcodec,--disable-avcodec"
+PACKAGECONFIG[avformat] = "--enable-avformat,--disable-avformat"
+PACKAGECONFIG[swresample] = "--enable-swresample,--disable-swresample"
+PACKAGECONFIG[swscale] = "--enable-swscale,--disable-swscale"
+PACKAGECONFIG[postproc] = "--enable-postproc,--disable-postproc"
+PACKAGECONFIG[avresample] = "--enable-avresample,--disable-avresample"
+
+# features to support
+PACKAGECONFIG[bzlib] = "--enable-bzlib,--disable-bzlib,bzip2"
+PACKAGECONFIG[gpl] = "--enable-gpl,--disable-gpl"
+PACKAGECONFIG[gsm] = "--enable-libgsm,--disable-libgsm,libgsm"
+PACKAGECONFIG[jack] = "--enable-indev=jack,--disable-indev=jack,jack"
+PACKAGECONFIG[libvorbis] = "--enable-libvorbis,--disable-libvorbis,libvorbis"
+PACKAGECONFIG[lzma] = "--enable-lzma,--disable-lzma,xz"
+PACKAGECONFIG[mp3lame] = "--enable-libmp3lame,--disable-libmp3lame,lame"
+PACKAGECONFIG[openssl] = "--enable-openssl,--disable-openssl,openssl"
+PACKAGECONFIG[schroedinger] = "--enable-libschroedinger,--disable-libschroedinger,schroedinger"
+PACKAGECONFIG[speex] = "--enable-libspeex,--disable-libspeex,speex"
+PACKAGECONFIG[theora] = "--enable-libtheora,--disable-libtheora,libtheora"
+PACKAGECONFIG[vaapi] = "--enable-vaapi,--disable-vaapi,libva"
+PACKAGECONFIG[vdpau] = "--enable-vdpau,--disable-vdpau,libvdpau"
+PACKAGECONFIG[vpx] = "--enable-libvpx,--disable-libvpx,libvpx"
+PACKAGECONFIG[x11] = "--enable-x11grab,--disable-x11grab,virtual/libx11 libxfixes libxext xproto virtual/libsdl"
+PACKAGECONFIG[x264] = "--enable-libx264,--disable-libx264,x264"
+PACKAGECONFIG[xv] = "--enable-outdev=xv,--disable-outdev=xv,libxv"
+
+# Check codecs that require --enable-nonfree
+USE_NONFREE = "${@bb.utils.contains_any('PACKAGECONFIG', [ 'openssl' ], 'yes', '', d)}"
+
+EXTRA_OECONF = " \
+ --disable-stripping \
+ --enable-pic \
+ --enable-shared \
+ --enable-pthreads \
+ ${@bb.utils.contains('USE_NONFREE', 'yes', '--enable-nonfree', '', d)} \
+ \
+ --cross-prefix=${TARGET_PREFIX} \
+ \
+ --ld="${CCLD}" \
+ --cc="${CC}" \
+ --cxx="${CXX}" \
+ --arch=${TARGET_ARCH} \
+ --target-os="linux" \
+ --enable-cross-compile \
+ --extra-cflags="${TARGET_CFLAGS} ${HOST_CC_ARCH}${TOOLCHAIN_OPTIONS}" \
+ --extra-ldflags="${TARGET_LDFLAGS}" \
+ --sysroot="${STAGING_DIR_TARGET}" \
+ --enable-hardcoded-tables \
+ ${EXTRA_FFCONF} \
+ --libdir=${libdir} \
+ --shlibdir=${libdir} \
+ --datadir=${datadir}/ffmpeg \
+ ${@bb.utils.contains('AVAILTUNES', 'mips32r2', '', '--disable-mipsdsp --disable-mipsdspr2', d)} \
+"
+
+do_configure() {
+ ${S}/configure ${EXTRA_OECONF}
+}
+
+PACKAGES_DYNAMIC += "^lib(av(codec|device|filter|format|util|resample)|swscale|swresample|postproc).*"
+
+# ffmpeg disables PIC on some platforms (e.g. x86-32)
+INSANE_SKIP_${MLPREFIX}libavcodec = "textrel"
+INSANE_SKIP_${MLPREFIX}libavdevice = "textrel"
+INSANE_SKIP_${MLPREFIX}libavfilter = "textrel"
+INSANE_SKIP_${MLPREFIX}libavformat = "textrel"
+INSANE_SKIP_${MLPREFIX}libavutil = "textrel"
+INSANE_SKIP_${MLPREFIX}libavresample = "textrel"
+INSANE_SKIP_${MLPREFIX}libswscale = "textrel"
+INSANE_SKIP_${MLPREFIX}libswresample = "textrel"
+INSANE_SKIP_${MLPREFIX}libpostproc = "textrel"
+
+python populate_packages_prepend() {
+ av_libdir = d.expand('${libdir}')
+ av_pkgconfig = d.expand('${libdir}/pkgconfig')
+
+ # Runtime package
+ do_split_packages(d, av_libdir, '^lib(.*)\.so\..*',
+ output_pattern='lib%s',
+ description='libav %s library',
+ extra_depends='',
+ prepend=True,
+ allow_links=True)
+
+ # Development packages (-dev, -staticdev)
+ do_split_packages(d, av_libdir, '^lib(.*)\.so$',
+ output_pattern='lib%s-dev',
+ description='libav %s development package',
+ extra_depends='${PN}-dev',
+ prepend=True,
+ allow_links=True)
+ do_split_packages(d, av_pkgconfig, '^lib(.*)\.pc$',
+ output_pattern='lib%s-dev',
+ description='libav %s development package',
+ extra_depends='${PN}-dev',
+ prepend=True)
+ do_split_packages(d, av_libdir, '^lib(.*)\.a$',
+ output_pattern='lib%s-staticdev',
+ description='libav %s development package - static library',
+ extra_depends='${PN}-dev',
+ prepend=True,
+ allow_links=True)
+
+}
diff --git a/meta-v1000/recipes-multimedia/mpv/mpv_0.24.0.bb b/meta-v1000/recipes-multimedia/mpv/mpv_0.24.0.bb
new file mode 100644
index 00000000..bb10eec7
--- /dev/null
+++ b/meta-v1000/recipes-multimedia/mpv/mpv_0.24.0.bb
@@ -0,0 +1,60 @@
+SUMMARY = "Open Source multimedia player"
+DESCRIPTION = "mpv is a fork of mplayer2 and MPlayer. It shares some features with the former projects while introducing many more."
+SECTION = "multimedia"
+HOMEPAGE = "http://www.mpv.io/"
+DEPENDS = "zlib ffmpeg jpeg virtual/libx11 xsp libxv \
+ libxscrnsaver libv4l libxinerama libvdpau \
+"
+
+REQUIRED_DISTRO_FEATURES = "x11"
+
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=91f1cb870c1cc2d31351a4d2595441cb"
+
+SRC_URI = " \
+ https://github.com/mpv-player/mpv/archive/v${PV}.tar.gz;name=mpv \
+ http://www.freehackers.org/~tnagy/release/waf-1.8.12;name=waf;subdir=${BPN}-${PV} \
+"
+SRC_URI[mpv.md5sum] = "5c85d1163911e49315a5bf1ca1fae13d"
+SRC_URI[mpv.sha256sum] = "a41854fa0ac35b9c309ad692aaee67c8d4495c3546f11cb4cdd0a124195d3f15"
+SRC_URI[waf.md5sum] = "cef4ee82206b1843db082d0b0506bf71"
+SRC_URI[waf.sha256sum] = "01bf2beab2106d1558800c8709bc2c8e496d3da4a2ca343fe091f22fca60c98b"
+
+inherit waf pkgconfig pythonnative distro_features_check
+
+# Note: both lua and libass are required to get on-screen-display (controls)
+PACKAGECONFIG ??= "lua libass"
+PACKAGECONFIG[lua] = "--enable-lua,--disable-lua,lua luajit"
+PACKAGECONFIG[libass] = "--enable-libass,--disable-libass,libass"
+PACKAGECONFIG[libarchive] = "--enable-libarchive,--disable-libarchive,libarchive"
+PACKAGECONFIG[jack] = "--enable-jack, --disable-jack, jack"
+
+SIMPLE_TARGET_SYS = "${@'${TARGET_SYS}'.replace('${TARGET_VENDOR}', '')}"
+EXTRA_OECONF = " \
+ --prefix=${prefix} \
+ --target=${SIMPLE_TARGET_SYS} \
+ --confdir=${sysconfdir} \
+ --datadir=${datadir} \
+ --disable-manpage-build \
+ --disable-gl \
+ --disable-libsmbclient \
+ --disable-encoding \
+ --disable-libbluray \
+ --disable-dvdread \
+ --disable-dvdnav \
+ --disable-cdda \
+ --disable-uchardet \
+ --disable-rubberband \
+ --disable-lcms2 \
+ --disable-vapoursynth \
+ --disable-vapoursynth-lazy \
+ ${PACKAGECONFIG_CONFARGS} \
+"
+
+do_configure_prepend () {
+ ln -sf waf-1.8.12 ${S}/waf
+ chmod +x ${S}/waf
+}
+
+FILES_${PN} += "${datadir}/icons"
+