aboutsummaryrefslogtreecommitdiffstats
path: root/meta-amdfalconx86/recipes-kernel/linux/files/0074-drm-amdgpu-powerplay-implement-thermal-control-for-t.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-amdfalconx86/recipes-kernel/linux/files/0074-drm-amdgpu-powerplay-implement-thermal-control-for-t.patch')
-rw-r--r--meta-amdfalconx86/recipes-kernel/linux/files/0074-drm-amdgpu-powerplay-implement-thermal-control-for-t.patch904
1 files changed, 904 insertions, 0 deletions
diff --git a/meta-amdfalconx86/recipes-kernel/linux/files/0074-drm-amdgpu-powerplay-implement-thermal-control-for-t.patch b/meta-amdfalconx86/recipes-kernel/linux/files/0074-drm-amdgpu-powerplay-implement-thermal-control-for-t.patch
new file mode 100644
index 00000000..da32eabd
--- /dev/null
+++ b/meta-amdfalconx86/recipes-kernel/linux/files/0074-drm-amdgpu-powerplay-implement-thermal-control-for-t.patch
@@ -0,0 +1,904 @@
+From 6b510abe48de659a306ac314d102b11aa2c336c2 Mon Sep 17 00:00:00 2001
+From: Rex Zhu <Rex.Zhu@amd.com>
+Date: Tue, 20 Oct 2015 18:06:23 +0800
+Subject: [PATCH 0074/1110] drm/amdgpu/powerplay: implement thermal control for
+ tonga.
+
+Implement thermal and fan control for tonga.
+
+Signed-off-by: Rex Zhu <Rex.Zhu@amd.com>
+Reviewed-by: Jammy Zhou <Jammy.Zhou@amd.com>
+Reviewed-by: Alex Deucher <alexander.deucher@amd.com>
+---
+ drivers/gpu/drm/amd/powerplay/hwmgr/Makefile | 2 +-
+ drivers/gpu/drm/amd/powerplay/hwmgr/tonga_hwmgr.c | 150 +++++-
+ drivers/gpu/drm/amd/powerplay/hwmgr/tonga_hwmgr.h | 1 +
+ .../gpu/drm/amd/powerplay/hwmgr/tonga_thermal.c | 587 +++++++++++++++++++++
+ .../gpu/drm/amd/powerplay/hwmgr/tonga_thermal.h | 60 +++
+ 5 files changed, 798 insertions(+), 2 deletions(-)
+ create mode 100644 drivers/gpu/drm/amd/powerplay/hwmgr/tonga_thermal.c
+ create mode 100644 drivers/gpu/drm/amd/powerplay/hwmgr/tonga_thermal.h
+
+diff --git a/drivers/gpu/drm/amd/powerplay/hwmgr/Makefile b/drivers/gpu/drm/amd/powerplay/hwmgr/Makefile
+index 6f38811..cea032c 100644
+--- a/drivers/gpu/drm/amd/powerplay/hwmgr/Makefile
++++ b/drivers/gpu/drm/amd/powerplay/hwmgr/Makefile
+@@ -6,7 +6,7 @@ HARDWARE_MGR = hwmgr.o processpptables.o functiontables.o \
+ hardwaremanager.o pp_acpi.o cz_hwmgr.o \
+ cz_clockpowergating.o \
+ tonga_processpptables.o ppatomctrl.o \
+- tonga_hwmgr.o pppcielanes.o \
++ tonga_hwmgr.o pppcielanes.o tonga_thermal.o\
+ fiji_powertune.o fiji_hwmgr.o tonga_clockpowergating.o
+
+ AMD_PP_HWMGR = $(addprefix $(AMD_PP_PATH)/hwmgr/,$(HARDWARE_MGR))
+diff --git a/drivers/gpu/drm/amd/powerplay/hwmgr/tonga_hwmgr.c b/drivers/gpu/drm/amd/powerplay/hwmgr/tonga_hwmgr.c
+index 9a7de1f..088b5bf 100644
+--- a/drivers/gpu/drm/amd/powerplay/hwmgr/tonga_hwmgr.c
++++ b/drivers/gpu/drm/amd/powerplay/hwmgr/tonga_hwmgr.c
+@@ -40,6 +40,7 @@
+ #include "smumgr.h"
+ #include "tonga_smumgr.h"
+ #include "tonga_clockpowergating.h"
++#include "tonga_thermal.h"
+
+ #include "smu/smu_7_1_2_d.h"
+ #include "smu/smu_7_1_2_sh_mask.h"
+@@ -50,6 +51,9 @@
+ #include "bif/bif_5_0_d.h"
+ #include "bif/bif_5_0_sh_mask.h"
+
++#include "cgs_linux.h"
++#include "eventmgr.h"
++
+ #define MC_CG_ARB_FREQ_F0 0x0a
+ #define MC_CG_ARB_FREQ_F1 0x0b
+ #define MC_CG_ARB_FREQ_F2 0x0c
+@@ -5721,6 +5725,22 @@ static int tonga_set_power_state_tasks(struct pp_hwmgr *hwmgr, const void *input
+ return result;
+ }
+
++/**
++* Set maximum target operating fan output PWM
++*
++* @param pHwMgr: the address of the powerplay hardware manager.
++* @param usMaxFanPwm: max operating fan PWM in percents
++* @return The response that came from the SMC.
++*/
++static int tonga_set_max_fan_pwm_output(struct pp_hwmgr *hwmgr, uint16_t us_max_fan_pwm)
++{
++ hwmgr->thermal_controller.advanceFanControlParameters.usMaxFanPWM = us_max_fan_pwm;
++
++ if (phm_is_hw_access_blocked(hwmgr))
++ return 0;
++
++ return (0 == smum_send_msg_to_smc_with_parameter(hwmgr->smumgr, PPSMC_MSG_SetFanPwmMax, us_max_fan_pwm) ? 0 : -EINVAL);
++}
+
+ int tonga_notify_smc_display_config_after_ps_adjustment(struct pp_hwmgr *hwmgr)
+ {
+@@ -5799,6 +5819,122 @@ int tonga_display_configuration_changed_task(struct pp_hwmgr *hwmgr)
+ return 0;
+ }
+
++/**
++* Set maximum target operating fan output RPM
++*
++* @param pHwMgr: the address of the powerplay hardware manager.
++* @param usMaxFanRpm: max operating fan RPM value.
++* @return The response that came from the SMC.
++*/
++static int tonga_set_max_fan_rpm_output(struct pp_hwmgr *hwmgr, uint16_t us_max_fan_pwm)
++{
++ hwmgr->thermal_controller.advanceFanControlParameters.usMaxFanRPM = us_max_fan_pwm;
++
++ if (phm_is_hw_access_blocked(hwmgr))
++ return 0;
++
++ return (0 == smum_send_msg_to_smc_with_parameter(hwmgr->smumgr, PPSMC_MSG_SetFanRpmMax, us_max_fan_pwm) ? 0 : -EINVAL);
++}
++
++uint32_t tonga_get_xclk(struct pp_hwmgr *hwmgr)
++{
++ uint32_t reference_clock;
++ uint32_t tc;
++ uint32_t divide;
++
++ ATOM_FIRMWARE_INFO *fw_info;
++ uint16_t size;
++ uint8_t frev, crev;
++ int index = GetIndexIntoMasterTable(DATA, FirmwareInfo);
++
++ tc = PHM_READ_VFPF_INDIRECT_FIELD(hwmgr->device, CGS_IND_REG__SMC, CG_CLKPIN_CNTL_2, MUX_TCLK_TO_XCLK);
++
++ if (tc)
++ return TCLK;
++
++ fw_info = (ATOM_FIRMWARE_INFO *)cgs_atom_get_data_table(hwmgr->device, index,
++ &size, &frev, &crev);
++
++ if (!fw_info)
++ return 0;
++
++ reference_clock = le16_to_cpu(fw_info->usMinPixelClockPLL_Output);
++
++ divide = PHM_READ_VFPF_INDIRECT_FIELD(hwmgr->device, CGS_IND_REG__SMC, CG_CLKPIN_CNTL, XTALIN_DIVIDE);
++
++ if (0 != divide)
++ return reference_clock / 4;
++
++ return reference_clock;
++}
++
++int tonga_dpm_set_interrupt_state(void *private_data,
++ unsigned src_id, unsigned type,
++ int enabled)
++{
++ uint32_t cg_thermal_int;
++ struct pp_hwmgr *hwmgr = ((struct pp_eventmgr *)private_data)->hwmgr;
++
++ if (hwmgr == NULL)
++ return -EINVAL;
++
++ switch (type) {
++ case AMD_THERMAL_IRQ_LOW_TO_HIGH:
++ if (enabled) {
++ cg_thermal_int = cgs_read_ind_register(hwmgr->device, CGS_IND_REG__SMC, ixCG_THERMAL_INT);
++ cg_thermal_int |= CG_THERMAL_INT_CTRL__THERM_INTH_MASK_MASK;
++ cgs_write_ind_register(hwmgr->device, CGS_IND_REG__SMC, ixCG_THERMAL_INT, cg_thermal_int);
++ } else {
++ cg_thermal_int = cgs_read_ind_register(hwmgr->device, CGS_IND_REG__SMC, ixCG_THERMAL_INT);
++ cg_thermal_int &= ~CG_THERMAL_INT_CTRL__THERM_INTH_MASK_MASK;
++ cgs_write_ind_register(hwmgr->device, CGS_IND_REG__SMC, ixCG_THERMAL_INT, cg_thermal_int);
++ }
++ break;
++
++ case AMD_THERMAL_IRQ_HIGH_TO_LOW:
++ if (enabled) {
++ cg_thermal_int = cgs_read_ind_register(hwmgr->device, CGS_IND_REG__SMC, ixCG_THERMAL_INT);
++ cg_thermal_int |= CG_THERMAL_INT_CTRL__THERM_INTL_MASK_MASK;
++ cgs_write_ind_register(hwmgr->device, CGS_IND_REG__SMC, ixCG_THERMAL_INT, cg_thermal_int);
++ } else {
++ cg_thermal_int = cgs_read_ind_register(hwmgr->device, CGS_IND_REG__SMC, ixCG_THERMAL_INT);
++ cg_thermal_int &= ~CG_THERMAL_INT_CTRL__THERM_INTL_MASK_MASK;
++ cgs_write_ind_register(hwmgr->device, CGS_IND_REG__SMC, ixCG_THERMAL_INT, cg_thermal_int);
++ }
++ break;
++ default:
++ break;
++ }
++ return 0;
++}
++
++int tonga_register_internal_thermal_interrupt(struct pp_hwmgr *hwmgr,
++ const void *thermal_interrupt_info)
++{
++ int result;
++ const struct pp_interrupt_registration_info *info =
++ (const struct pp_interrupt_registration_info *)thermal_interrupt_info;
++
++ if (info == NULL)
++ return -EINVAL;
++
++ result = cgs_add_irq_source(hwmgr->device, 230, AMD_THERMAL_IRQ_LAST,
++ tonga_dpm_set_interrupt_state,
++ info->call_back, info->context);
++
++ if (result)
++ return -EINVAL;
++
++ result = cgs_add_irq_source(hwmgr->device, 231, AMD_THERMAL_IRQ_LAST,
++ tonga_dpm_set_interrupt_state,
++ info->call_back, info->context);
++
++ if (result)
++ return -EINVAL;
++
++ return 0;
++}
++
+ static const struct pp_hwmgr_func tonga_hwmgr_funcs = {
+ .backend_init = &tonga_hwmgr_backend_init,
+ .backend_fini = &tonga_hwmgr_backend_fini,
+@@ -5820,6 +5956,18 @@ static const struct pp_hwmgr_func tonga_hwmgr_funcs = {
+ .disable_clock_power_gating = tonga_phm_disable_clock_power_gating,
+ .notify_smc_display_config_after_ps_adjustment = tonga_notify_smc_display_config_after_ps_adjustment,
+ .display_config_changed = tonga_display_configuration_changed_task,
++ .set_max_fan_pwm_output = tonga_set_max_fan_pwm_output,
++ .set_max_fan_rpm_output = tonga_set_max_fan_rpm_output,
++ .get_temperature = tonga_thermal_get_temperature,
++ .stop_thermal_controller = tonga_thermal_stop_thermal_controller,
++ .get_fan_speed_info = tonga_fan_ctrl_get_fan_speed_info,
++ .get_fan_speed_percent = tonga_fan_ctrl_get_fan_speed_percent,
++ .set_fan_speed_percent = tonga_fan_ctrl_set_fan_speed_percent,
++ .reset_fan_speed_to_default = tonga_fan_ctrl_reset_fan_speed_to_default,
++ .get_fan_speed_rpm = tonga_fan_ctrl_get_fan_speed_rpm,
++ .set_fan_speed_rpm = tonga_fan_ctrl_set_fan_speed_rpm,
++ .uninitialize_thermal_controller = tonga_thermal_ctrl_uninitialize_thermal_controller,
++ .register_internal_thermal_interrupt = tonga_register_internal_thermal_interrupt,
+ };
+
+ int tonga_hwmgr_init(struct pp_hwmgr *hwmgr)
+@@ -5834,7 +5982,7 @@ int tonga_hwmgr_init(struct pp_hwmgr *hwmgr)
+ hwmgr->backend = data;
+ hwmgr->hwmgr_func = &tonga_hwmgr_funcs;
+ hwmgr->pptable_func = &tonga_pptable_funcs;
+-
++ pp_tonga_thermal_initialize(hwmgr);
+ return 0;
+ }
+
+diff --git a/drivers/gpu/drm/amd/powerplay/hwmgr/tonga_hwmgr.h b/drivers/gpu/drm/amd/powerplay/hwmgr/tonga_hwmgr.h
+index d773d12..44b985a 100644
+--- a/drivers/gpu/drm/amd/powerplay/hwmgr/tonga_hwmgr.h
++++ b/drivers/gpu/drm/amd/powerplay/hwmgr/tonga_hwmgr.h
+@@ -426,6 +426,7 @@ int tonga_update_vce_dpm(struct pp_hwmgr *hwmgr, const void *input);
+ int tonga_update_uvd_dpm(struct pp_hwmgr *hwmgr, bool bgate);
+ int tonga_enable_disable_uvd_dpm(struct pp_hwmgr *hwmgr, bool enable);
+ int tonga_enable_disable_vce_dpm(struct pp_hwmgr *hwmgr, bool enable);
++uint32_t tonga_get_xclk(struct pp_hwmgr *hwmgr);
+
+ #endif
+
+diff --git a/drivers/gpu/drm/amd/powerplay/hwmgr/tonga_thermal.c b/drivers/gpu/drm/amd/powerplay/hwmgr/tonga_thermal.c
+new file mode 100644
+index 0000000..a315507
+--- /dev/null
++++ b/drivers/gpu/drm/amd/powerplay/hwmgr/tonga_thermal.c
+@@ -0,0 +1,587 @@
++/*
++ * Copyright 2015 Advanced Micro Devices, Inc.
++ *
++ * Permission is hereby granted, free of charge, to any person obtaining a
++ * copy of this software and associated documentation files (the "Software"),
++ * to deal in the Software without restriction, including without limitation
++ * the rights to use, copy, modify, merge, publish, distribute, sublicense,
++ * and/or sell copies of the Software, and to permit persons to whom the
++ * Software is furnished to do so, subject to the following conditions:
++ *
++ * The above copyright notice and this permission notice shall be included in
++ * all copies or substantial portions of the Software.
++ *
++ * THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
++ * IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
++ * FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL
++ * THE COPYRIGHT HOLDER(S) OR AUTHOR(S) BE LIABLE FOR ANY CLAIM, DAMAGES OR
++ * OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE,
++ * ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
++ * OTHER DEALINGS IN THE SOFTWARE.
++ *
++ */
++
++#include "tonga_thermal.h"
++#include "tonga_hwmgr.h"
++#include "tonga_smumgr.h"
++#include "tonga_ppsmc.h"
++#include "smu/smu_7_1_2_d.h"
++#include "smu/smu_7_1_2_sh_mask.h"
++
++/**
++* Get Fan Speed Control Parameters.
++* @param hwmgr the address of the powerplay hardware manager.
++* @param pSpeed is the address of the structure where the result is to be placed.
++* @exception Always succeeds except if we cannot zero out the output structure.
++*/
++int tonga_fan_ctrl_get_fan_speed_info(struct pp_hwmgr *hwmgr, struct phm_fan_speed_info *fan_speed_info)
++{
++
++ if (hwmgr->thermal_controller.fanInfo.bNoFan)
++ return 0;
++
++ fan_speed_info->supports_percent_read = true;
++ fan_speed_info->supports_percent_write = true;
++ fan_speed_info->min_percent = 0;
++ fan_speed_info->max_percent = 100;
++
++ if (0 != hwmgr->thermal_controller.fanInfo.ucTachometerPulsesPerRevolution) {
++ fan_speed_info->supports_rpm_read = true;
++ fan_speed_info->supports_rpm_write = true;
++ fan_speed_info->min_rpm = hwmgr->thermal_controller.fanInfo.ulMinRPM;
++ fan_speed_info->max_rpm = hwmgr->thermal_controller.fanInfo.ulMaxRPM;
++ } else {
++ fan_speed_info->min_rpm = 0;
++ fan_speed_info->max_rpm = 0;
++ }
++
++ return 0;
++}
++
++/**
++* Get Fan Speed in percent.
++* @param hwmgr the address of the powerplay hardware manager.
++* @param pSpeed is the address of the structure where the result is to be placed.
++* @exception Fails is the 100% setting appears to be 0.
++*/
++int tonga_fan_ctrl_get_fan_speed_percent(struct pp_hwmgr *hwmgr, uint32_t *speed)
++{
++ uint32_t duty100;
++ uint32_t duty;
++ uint64_t tmp64;
++
++ if (hwmgr->thermal_controller.fanInfo.bNoFan)
++ return 0;
++
++ duty100 = PHM_READ_VFPF_INDIRECT_FIELD(hwmgr->device, CGS_IND_REG__SMC, CG_FDO_CTRL1, FMAX_DUTY100);
++ duty = PHM_READ_VFPF_INDIRECT_FIELD(hwmgr->device, CGS_IND_REG__SMC, CG_THERMAL_STATUS, FDO_PWM_DUTY);
++
++ if (0 == duty100)
++ return -EINVAL;
++
++
++ tmp64 = (uint64_t)duty * 100;
++ do_div(tmp64, duty100);
++ *speed = (uint32_t)tmp64;
++
++ if (*speed > 100)
++ *speed = 100;
++
++ return 0;
++}
++
++/**
++* Get Fan Speed in RPM.
++* @param hwmgr the address of the powerplay hardware manager.
++* @param speed is the address of the structure where the result is to be placed.
++* @exception Returns not supported if no fan is found or if pulses per revolution are not set
++*/
++int tonga_fan_ctrl_get_fan_speed_rpm(struct pp_hwmgr *hwmgr, uint32_t *speed)
++{
++ return 0;
++}
++
++/**
++* Set Fan Speed Control to static mode, so that the user can decide what speed to use.
++* @param hwmgr the address of the powerplay hardware manager.
++* mode the fan control mode, 0 default, 1 by percent, 5, by RPM
++* @exception Should always succeed.
++*/
++int tonga_fan_ctrl_set_static_mode(struct pp_hwmgr *hwmgr, uint32_t mode)
++{
++
++ if (hwmgr->fan_ctrl_is_in_default_mode) {
++ hwmgr->fan_ctrl_default_mode = PHM_READ_VFPF_INDIRECT_FIELD(hwmgr->device, CGS_IND_REG__SMC, CG_FDO_CTRL2, FDO_PWM_MODE);
++ hwmgr->tmin = PHM_READ_VFPF_INDIRECT_FIELD(hwmgr->device, CGS_IND_REG__SMC, CG_FDO_CTRL2, TMIN);
++ hwmgr->fan_ctrl_is_in_default_mode = false;
++ }
++
++ PHM_WRITE_VFPF_INDIRECT_FIELD(hwmgr->device, CGS_IND_REG__SMC, CG_FDO_CTRL2, TMIN, 0);
++ PHM_WRITE_VFPF_INDIRECT_FIELD(hwmgr->device, CGS_IND_REG__SMC, CG_FDO_CTRL2, FDO_PWM_MODE, mode);
++
++ return 0;
++}
++
++/**
++* Reset Fan Speed Control to default mode.
++* @param hwmgr the address of the powerplay hardware manager.
++* @exception Should always succeed.
++*/
++int tonga_fan_ctrl_set_default_mode(struct pp_hwmgr *hwmgr)
++{
++ if (hwmgr->fan_ctrl_is_in_default_mode) {
++ PHM_WRITE_VFPF_INDIRECT_FIELD(hwmgr->device, CGS_IND_REG__SMC, CG_FDO_CTRL2, FDO_PWM_MODE, hwmgr->fan_ctrl_default_mode);
++ PHM_WRITE_VFPF_INDIRECT_FIELD(hwmgr->device, CGS_IND_REG__SMC, CG_FDO_CTRL2, TMIN, hwmgr->tmin);
++ hwmgr->fan_ctrl_is_in_default_mode = true;
++ }
++
++ return 0;
++}
++
++int tonga_fan_ctrl_start_smc_fan_control(struct pp_hwmgr *hwmgr)
++{
++ int result;
++
++ if (phm_cap_enabled(hwmgr->platform_descriptor.platformCaps, PHM_PlatformCaps_ODFuzzyFanControlSupport)) {
++ cgs_write_register(hwmgr->device, mmSMC_MSG_ARG_0, FAN_CONTROL_FUZZY);
++ result = (smum_send_msg_to_smc(hwmgr->smumgr, PPSMC_StartFanControl) == 0) ? 0 : -EINVAL;
++/*
++ if (phm_cap_enabled(hwmgr->platform_descriptor.platformCaps, PHM_PlatformCaps_FanSpeedInTableIsRPM))
++ hwmgr->set_max_fan_rpm_output(hwmgr, hwmgr->thermal_controller.advanceFanControlParameters.usMaxFanRPM);
++ else
++ hwmgr->set_max_fan_pwm_output(hwmgr, hwmgr->thermal_controller.advanceFanControlParameters.usMaxFanPWM);
++*/
++ } else {
++ cgs_write_register(hwmgr->device, mmSMC_MSG_ARG_0, FAN_CONTROL_TABLE);
++ result = (smum_send_msg_to_smc(hwmgr->smumgr, PPSMC_StartFanControl) == 0) ? 0 : -EINVAL;
++ }
++/* TO DO FOR SOME DEVICE ID 0X692b, send this msg return invalid command.
++ if (result == 0 && hwmgr->thermal_controller.advanceFanControlParameters.ucTargetTemperature != 0)
++ result = (0 == smum_send_msg_to_smc_with_parameter(hwmgr->smumgr, PPSMC_MSG_SetFanTemperatureTarget, \
++ hwmgr->thermal_controller.advanceFanControlParameters.ucTargetTemperature) ? 0 : -EINVAL);
++*/
++ return result;
++}
++
++
++int tonga_fan_ctrl_stop_smc_fan_control(struct pp_hwmgr *hwmgr)
++{
++ return (smum_send_msg_to_smc(hwmgr->smumgr, PPSMC_StopFanControl) == 0) ? 0 : -EINVAL;
++}
++
++/**
++* Set Fan Speed in percent.
++* @param hwmgr the address of the powerplay hardware manager.
++* @param speed is the percentage value (0% - 100%) to be set.
++* @exception Fails is the 100% setting appears to be 0.
++*/
++int tonga_fan_ctrl_set_fan_speed_percent(struct pp_hwmgr *hwmgr, uint32_t speed)
++{
++ uint32_t duty100;
++ uint32_t duty;
++ uint64_t tmp64;
++
++ if (hwmgr->thermal_controller.fanInfo.bNoFan)
++ return -EINVAL;
++
++ if (speed > 100)
++ speed = 100;
++
++ if (phm_cap_enabled(hwmgr->platform_descriptor.platformCaps, PHM_PlatformCaps_MicrocodeFanControl))
++ tonga_fan_ctrl_stop_smc_fan_control(hwmgr);
++
++ duty100 = PHM_READ_VFPF_INDIRECT_FIELD(hwmgr->device, CGS_IND_REG__SMC, CG_FDO_CTRL1, FMAX_DUTY100);
++
++ if (0 == duty100)
++ return -EINVAL;
++
++ tmp64 = (uint64_t)speed * 100;
++ do_div(tmp64, duty100);
++ duty = (uint32_t)tmp64;
++
++ PHM_WRITE_VFPF_INDIRECT_FIELD(hwmgr->device, CGS_IND_REG__SMC, CG_FDO_CTRL0, FDO_STATIC_DUTY, duty);
++
++ return tonga_fan_ctrl_set_static_mode(hwmgr, FDO_PWM_MODE_STATIC);
++}
++
++/**
++* Reset Fan Speed to default.
++* @param hwmgr the address of the powerplay hardware manager.
++* @exception Always succeeds.
++*/
++int tonga_fan_ctrl_reset_fan_speed_to_default(struct pp_hwmgr *hwmgr)
++{
++ int result;
++
++ if (hwmgr->thermal_controller.fanInfo.bNoFan)
++ return 0;
++
++ if (phm_cap_enabled(hwmgr->platform_descriptor.platformCaps, PHM_PlatformCaps_MicrocodeFanControl)) {
++ result = tonga_fan_ctrl_set_static_mode(hwmgr, FDO_PWM_MODE_STATIC);
++ if (0 == result)
++ result = tonga_fan_ctrl_start_smc_fan_control(hwmgr);
++ } else
++ result = tonga_fan_ctrl_set_default_mode(hwmgr);
++
++ return result;
++}
++
++/**
++* Set Fan Speed in RPM.
++* @param hwmgr the address of the powerplay hardware manager.
++* @param speed is the percentage value (min - max) to be set.
++* @exception Fails is the speed not lie between min and max.
++*/
++int tonga_fan_ctrl_set_fan_speed_rpm(struct pp_hwmgr *hwmgr, uint32_t speed)
++{
++ return 0;
++}
++
++/**
++* Reads the remote temperature from the SIslands thermal controller.
++*
++* @param hwmgr The address of the hardware manager.
++*/
++int tonga_thermal_get_temperature(struct pp_hwmgr *hwmgr)
++{
++ int temp;
++
++ temp = PHM_READ_VFPF_INDIRECT_FIELD(hwmgr->device, CGS_IND_REG__SMC, CG_MULT_THERMAL_STATUS, CTF_TEMP);
++
++/* Bit 9 means the reading is lower than the lowest usable value. */
++ if (0 != (0x200 & temp))
++ temp = TONGA_THERMAL_MAXIMUM_TEMP_READING;
++ else
++ temp = (temp & 0x1ff);
++
++ temp = temp * PP_TEMPERATURE_UNITS_PER_CENTIGRADES;
++
++ return temp;
++}
++
++/**
++* Set the requested temperature range for high and low alert signals
++*
++* @param hwmgr The address of the hardware manager.
++* @param range Temperature range to be programmed for high and low alert signals
++* @exception PP_Result_BadInput if the input data is not valid.
++*/
++static int tonga_thermal_set_temperature_range(struct pp_hwmgr *hwmgr, uint32_t low_temp, uint32_t high_temp)
++{
++ uint32_t low = TONGA_THERMAL_MINIMUM_ALERT_TEMP * PP_TEMPERATURE_UNITS_PER_CENTIGRADES;
++ uint32_t high = TONGA_THERMAL_MAXIMUM_ALERT_TEMP * PP_TEMPERATURE_UNITS_PER_CENTIGRADES;
++
++ if (low < low_temp)
++ low = low_temp;
++ if (high > high_temp)
++ high = high_temp;
++
++ if (low > high)
++ return -EINVAL;
++
++ PHM_WRITE_VFPF_INDIRECT_FIELD(hwmgr->device, CGS_IND_REG__SMC, CG_THERMAL_INT, DIG_THERM_INTH, (high / PP_TEMPERATURE_UNITS_PER_CENTIGRADES));
++ PHM_WRITE_VFPF_INDIRECT_FIELD(hwmgr->device, CGS_IND_REG__SMC, CG_THERMAL_INT, DIG_THERM_INTL, (low / PP_TEMPERATURE_UNITS_PER_CENTIGRADES));
++ PHM_WRITE_VFPF_INDIRECT_FIELD(hwmgr->device, CGS_IND_REG__SMC, CG_THERMAL_CTRL, DIG_THERM_DPM, (high / PP_TEMPERATURE_UNITS_PER_CENTIGRADES));
++
++ return 0;
++}
++
++/**
++* Programs thermal controller one-time setting registers
++*
++* @param hwmgr The address of the hardware manager.
++*/
++static int tonga_thermal_initialize(struct pp_hwmgr *hwmgr)
++{
++ if (0 != hwmgr->thermal_controller.fanInfo.ucTachometerPulsesPerRevolution)
++ PHM_WRITE_VFPF_INDIRECT_FIELD(hwmgr->device, CGS_IND_REG__SMC,
++ CG_TACH_CTRL, EDGE_PER_REV,
++ hwmgr->thermal_controller.fanInfo.ucTachometerPulsesPerRevolution - 1);
++
++ PHM_WRITE_VFPF_INDIRECT_FIELD(hwmgr->device, CGS_IND_REG__SMC, CG_FDO_CTRL2, TACH_PWM_RESP_RATE, 0x28);
++
++ return 0;
++}
++
++/**
++* Enable thermal alerts on the RV770 thermal controller.
++*
++* @param hwmgr The address of the hardware manager.
++*/
++static int tonga_thermal_enable_alert(struct pp_hwmgr *hwmgr)
++{
++ uint32_t alert;
++
++ alert = PHM_READ_VFPF_INDIRECT_FIELD(hwmgr->device, CGS_IND_REG__SMC, CG_THERMAL_INT, THERM_INT_MASK);
++ alert &= ~(TONGA_THERMAL_HIGH_ALERT_MASK | TONGA_THERMAL_LOW_ALERT_MASK);
++ PHM_WRITE_VFPF_INDIRECT_FIELD(hwmgr->device, CGS_IND_REG__SMC, CG_THERMAL_INT, THERM_INT_MASK, alert);
++
++ /* send message to SMU to enable internal thermal interrupts */
++ return (smum_send_msg_to_smc(hwmgr->smumgr, PPSMC_MSG_Thermal_Cntl_Enable) == 0) ? 0 : -1;
++}
++
++/**
++* Disable thermal alerts on the RV770 thermal controller.
++* @param hwmgr The address of the hardware manager.
++*/
++static int tonga_thermal_disable_alert(struct pp_hwmgr *hwmgr)
++{
++ uint32_t alert;
++
++ alert = PHM_READ_VFPF_INDIRECT_FIELD(hwmgr->device, CGS_IND_REG__SMC, CG_THERMAL_INT, THERM_INT_MASK);
++ alert |= (TONGA_THERMAL_HIGH_ALERT_MASK | TONGA_THERMAL_LOW_ALERT_MASK);
++ PHM_WRITE_VFPF_INDIRECT_FIELD(hwmgr->device, CGS_IND_REG__SMC, CG_THERMAL_INT, THERM_INT_MASK, alert);
++
++ /* send message to SMU to disable internal thermal interrupts */
++ return (smum_send_msg_to_smc(hwmgr->smumgr, PPSMC_MSG_Thermal_Cntl_Disable) == 0) ? 0 : -1;
++}
++
++/**
++* Uninitialize the thermal controller.
++* Currently just disables alerts.
++* @param hwmgr The address of the hardware manager.
++*/
++int tonga_thermal_stop_thermal_controller(struct pp_hwmgr *hwmgr)
++{
++ int result = tonga_thermal_disable_alert(hwmgr);
++
++ if (hwmgr->thermal_controller.fanInfo.bNoFan)
++ tonga_fan_ctrl_set_default_mode(hwmgr);
++
++ return result;
++}
++
++/**
++* Set up the fan table to control the fan using the SMC.
++* @param hwmgr the address of the powerplay hardware manager.
++* @param pInput the pointer to input data
++* @param pOutput the pointer to output data
++* @param pStorage the pointer to temporary storage
++* @param Result the last failure code
++* @return result from set temperature range routine
++*/
++int tf_tonga_thermal_setup_fan_table(struct pp_hwmgr *hwmgr, void *input, void *output, void *storage, int result)
++{
++ struct tonga_hwmgr *data = (struct tonga_hwmgr *)(hwmgr->backend);
++ SMU72_Discrete_FanTable fan_table = { FDO_MODE_HARDWARE };
++ uint32_t duty100;
++ uint32_t t_diff1, t_diff2, pwm_diff1, pwm_diff2;
++ uint16_t fdo_min, slope1, slope2;
++ uint32_t reference_clock;
++ int res;
++ uint64_t tmp64;
++
++ if (0 == data->fan_table_start) {
++ phm_cap_unset(hwmgr->platform_descriptor.platformCaps, PHM_PlatformCaps_MicrocodeFanControl);
++ return 0;
++ }
++
++ duty100 = PHM_READ_VFPF_INDIRECT_FIELD(hwmgr->device, CGS_IND_REG__SMC, CG_FDO_CTRL1, FMAX_DUTY100);
++
++ if (0 == duty100) {
++ phm_cap_unset(hwmgr->platform_descriptor.platformCaps, PHM_PlatformCaps_MicrocodeFanControl);
++ return 0;
++ }
++
++ tmp64 = hwmgr->thermal_controller.advanceFanControlParameters.usPWMMin * duty100;
++ do_div(tmp64, 10000);
++ fdo_min = (uint16_t)tmp64;
++
++ t_diff1 = hwmgr->thermal_controller.advanceFanControlParameters.usTMed - hwmgr->thermal_controller.advanceFanControlParameters.usTMin;
++ t_diff2 = hwmgr->thermal_controller.advanceFanControlParameters.usTHigh - hwmgr->thermal_controller.advanceFanControlParameters.usTMed;
++
++ pwm_diff1 = hwmgr->thermal_controller.advanceFanControlParameters.usPWMMed - hwmgr->thermal_controller.advanceFanControlParameters.usPWMMin;
++ pwm_diff2 = hwmgr->thermal_controller.advanceFanControlParameters.usPWMHigh - hwmgr->thermal_controller.advanceFanControlParameters.usPWMMed;
++
++ slope1 = (uint16_t)((50 + ((16 * duty100 * pwm_diff1) / t_diff1)) / 100);
++ slope2 = (uint16_t)((50 + ((16 * duty100 * pwm_diff2) / t_diff2)) / 100);
++
++ fan_table.TempMin = cpu_to_be16((50 + hwmgr->thermal_controller.advanceFanControlParameters.usTMin) / 100);
++ fan_table.TempMed = cpu_to_be16((50 + hwmgr->thermal_controller.advanceFanControlParameters.usTMed) / 100);
++ fan_table.TempMax = cpu_to_be16((50 + hwmgr->thermal_controller.advanceFanControlParameters.usTMax) / 100);
++
++ fan_table.Slope1 = cpu_to_be16(slope1);
++ fan_table.Slope2 = cpu_to_be16(slope2);
++
++ fan_table.FdoMin = cpu_to_be16(fdo_min);
++
++ fan_table.HystDown = cpu_to_be16(hwmgr->thermal_controller.advanceFanControlParameters.ucTHyst);
++
++ fan_table.HystUp = cpu_to_be16(1);
++
++ fan_table.HystSlope = cpu_to_be16(1);
++
++ fan_table.TempRespLim = cpu_to_be16(5);
++
++ reference_clock = tonga_get_xclk(hwmgr);
++
++ fan_table.RefreshPeriod = cpu_to_be32((hwmgr->thermal_controller.advanceFanControlParameters.ulCycleDelay * reference_clock) / 1600);
++
++ fan_table.FdoMax = cpu_to_be16((uint16_t)duty100);
++
++ fan_table.TempSrc = (uint8_t)PHM_READ_VFPF_INDIRECT_FIELD(hwmgr->device, CGS_IND_REG__SMC, CG_MULT_THERMAL_CTRL, TEMP_SEL);
++
++ fan_table.FanControl_GL_Flag = 1;
++
++ res = tonga_copy_bytes_to_smc(hwmgr->smumgr, data->fan_table_start, (uint8_t *)&fan_table, (uint32_t)sizeof(fan_table), data->sram_end);
++/* TO DO FOR SOME DEVICE ID 0X692b, send this msg return invalid command.
++ if (res == 0 && hwmgr->thermal_controller.advanceFanControlParameters.ucMinimumPWMLimit != 0)
++ res = (0 == smum_send_msg_to_smc_with_parameter(hwmgr->smumgr, PPSMC_MSG_SetFanMinPwm, \
++ hwmgr->thermal_controller.advanceFanControlParameters.ucMinimumPWMLimit) ? 0 : -1);
++
++ if (res == 0 && hwmgr->thermal_controller.advanceFanControlParameters.ulMinFanSCLKAcousticLimit != 0)
++ res = (0 == smum_send_msg_to_smc_with_parameter(hwmgr->smumgr, PPSMC_MSG_SetFanSclkTarget, \
++ hwmgr->thermal_controller.advanceFanControlParameters.ulMinFanSCLKAcousticLimit) ? 0 : -1);
++
++ if (0 != res)
++ phm_cap_unset(hwmgr->platform_descriptor.platformCaps, PHM_PlatformCaps_MicrocodeFanControl);
++*/
++ return 0;
++}
++
++/**
++* Start the fan control on the SMC.
++* @param hwmgr the address of the powerplay hardware manager.
++* @param pInput the pointer to input data
++* @param pOutput the pointer to output data
++* @param pStorage the pointer to temporary storage
++* @param Result the last failure code
++* @return result from set temperature range routine
++*/
++int tf_tonga_thermal_start_smc_fan_control(struct pp_hwmgr *hwmgr, void *input, void *output, void *storage, int result)
++{
++/* If the fantable setup has failed we could have disabled PHM_PlatformCaps_MicrocodeFanControl even after this function was included in the table.
++ * Make sure that we still think controlling the fan is OK.
++*/
++ if (phm_cap_enabled(hwmgr->platform_descriptor.platformCaps, PHM_PlatformCaps_MicrocodeFanControl)) {
++ tonga_fan_ctrl_start_smc_fan_control(hwmgr);
++ tonga_fan_ctrl_set_static_mode(hwmgr, FDO_PWM_MODE_STATIC);
++ }
++
++ return 0;
++}
++
++/**
++* Set temperature range for high and low alerts
++* @param hwmgr the address of the powerplay hardware manager.
++* @param pInput the pointer to input data
++* @param pOutput the pointer to output data
++* @param pStorage the pointer to temporary storage
++* @param Result the last failure code
++* @return result from set temperature range routine
++*/
++int tf_tonga_thermal_set_temperature_range(struct pp_hwmgr *hwmgr, void *input, void *output, void *storage, int result)
++{
++ struct PP_TemperatureRange *range = (struct PP_TemperatureRange *)input;
++
++ if (range == NULL)
++ return -EINVAL;
++
++ return tonga_thermal_set_temperature_range(hwmgr, range->min, range->max);
++}
++
++/**
++* Programs one-time setting registers
++* @param hwmgr the address of the powerplay hardware manager.
++* @param pInput the pointer to input data
++* @param pOutput the pointer to output data
++* @param pStorage the pointer to temporary storage
++* @param Result the last failure code
++* @return result from initialize thermal controller routine
++*/
++int tf_tonga_thermal_initialize(struct pp_hwmgr *hwmgr, void *input, void *output, void *storage, int result)
++{
++ return tonga_thermal_initialize(hwmgr);
++}
++
++/**
++* Enable high and low alerts
++* @param hwmgr the address of the powerplay hardware manager.
++* @param pInput the pointer to input data
++* @param pOutput the pointer to output data
++* @param pStorage the pointer to temporary storage
++* @param Result the last failure code
++* @return result from enable alert routine
++*/
++int tf_tonga_thermal_enable_alert(struct pp_hwmgr *hwmgr, void *input, void *output, void *storage, int result)
++{
++ return tonga_thermal_enable_alert(hwmgr);
++}
++
++/**
++* Disable high and low alerts
++* @param hwmgr the address of the powerplay hardware manager.
++* @param pInput the pointer to input data
++* @param pOutput the pointer to output data
++* @param pStorage the pointer to temporary storage
++* @param Result the last failure code
++* @return result from disable alert routine
++*/
++static int tf_tonga_thermal_disable_alert(struct pp_hwmgr *hwmgr, void *input, void *output, void *storage, int result)
++{
++ return tonga_thermal_disable_alert(hwmgr);
++}
++
++static struct phm_master_table_item tonga_thermal_start_thermal_controller_master_list[] = {
++ { NULL, tf_tonga_thermal_initialize },
++ { NULL, tf_tonga_thermal_set_temperature_range },
++ { NULL, tf_tonga_thermal_enable_alert },
++/* We should restrict performance levels to low before we halt the SMC.
++ * On the other hand we are still in boot state when we do this so it would be pointless.
++ * If this assumption changes we have to revisit this table.
++ */
++ { NULL, tf_tonga_thermal_setup_fan_table},
++ { NULL, tf_tonga_thermal_start_smc_fan_control},
++ { NULL, NULL }
++};
++
++static struct phm_master_table_header tonga_thermal_start_thermal_controller_master = {
++ 0,
++ PHM_MasterTableFlag_None,
++ tonga_thermal_start_thermal_controller_master_list
++};
++
++static struct phm_master_table_item tonga_thermal_set_temperature_range_master_list[] = {
++ { NULL, tf_tonga_thermal_disable_alert},
++ { NULL, tf_tonga_thermal_set_temperature_range},
++ { NULL, tf_tonga_thermal_enable_alert},
++ { NULL, NULL }
++};
++
++struct phm_master_table_header tonga_thermal_set_temperature_range_master = {
++ 0,
++ PHM_MasterTableFlag_None,
++ tonga_thermal_set_temperature_range_master_list
++};
++
++int tonga_thermal_ctrl_uninitialize_thermal_controller(struct pp_hwmgr *hwmgr)
++{
++ if (!hwmgr->thermal_controller.fanInfo.bNoFan)
++ tonga_fan_ctrl_set_default_mode(hwmgr);
++ return 0;
++}
++
++/**
++* Initializes the thermal controller related functions in the Hardware Manager structure.
++* @param hwmgr The address of the hardware manager.
++* @exception Any error code from the low-level communication.
++*/
++int pp_tonga_thermal_initialize(struct pp_hwmgr *hwmgr)
++{
++ int result;
++
++ result = phm_construct_table(hwmgr, &tonga_thermal_set_temperature_range_master, &(hwmgr->set_temperature_range));
++
++ if (0 == result) {
++ result = phm_construct_table(hwmgr,
++ &tonga_thermal_start_thermal_controller_master,
++ &(hwmgr->start_thermal_controller));
++ if (0 != result)
++ phm_destroy_table(hwmgr, &(hwmgr->set_temperature_range));
++ }
++
++ if (0 == result)
++ hwmgr->fan_ctrl_is_in_default_mode = true;
++ return result;
++}
++
+diff --git a/drivers/gpu/drm/amd/powerplay/hwmgr/tonga_thermal.h b/drivers/gpu/drm/amd/powerplay/hwmgr/tonga_thermal.h
+new file mode 100644
+index 0000000..07680a7
+--- /dev/null
++++ b/drivers/gpu/drm/amd/powerplay/hwmgr/tonga_thermal.h
+@@ -0,0 +1,60 @@
++/*
++ * Copyright 2015 Advanced Micro Devices, Inc.
++ *
++ * Permission is hereby granted, free of charge, to any person obtaining a
++ * copy of this software and associated documentation files (the "Software"),
++ * to deal in the Software without restriction, including without limitation
++ * the rights to use, copy, modify, merge, publish, distribute, sublicense,
++ * and/or sell copies of the Software, and to permit persons to whom the
++ * Software is furnished to do so, subject to the following conditions:
++ *
++ * The above copyright notice and this permission notice shall be included in
++ * all copies or substantial portions of the Software.
++ *
++ * THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
++ * IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
++ * FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL
++ * THE COPYRIGHT HOLDER(S) OR AUTHOR(S) BE LIABLE FOR ANY CLAIM, DAMAGES OR
++ * OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE,
++ * ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
++ * OTHER DEALINGS IN THE SOFTWARE.
++ *
++ */
++
++#ifndef TONGA_THERMAL_H
++#define TONGA_THERMAL_H
++
++#include "hwmgr.h"
++
++#define TONGA_THERMAL_HIGH_ALERT_MASK 0x1
++#define TONGA_THERMAL_LOW_ALERT_MASK 0x2
++
++#define TONGA_THERMAL_MINIMUM_TEMP_READING -256
++#define TONGA_THERMAL_MAXIMUM_TEMP_READING 255
++
++#define TONGA_THERMAL_MINIMUM_ALERT_TEMP 0
++#define TONGA_THERMAL_MAXIMUM_ALERT_TEMP 255
++
++#define FDO_PWM_MODE_STATIC 1
++#define FDO_PWM_MODE_STATIC_RPM 5
++
++
++extern int tf_tonga_thermal_initialize(struct pp_hwmgr *hwmgr, void *input, void *output, void *storage, int result);
++extern int tf_tonga_thermal_set_temperature_range(struct pp_hwmgr *hwmgr, void *input, void *output, void *storage, int result);
++extern int tf_tonga_thermal_enable_alert(struct pp_hwmgr *hwmgr, void *input, void *output, void *storage, int result);
++
++extern int tonga_thermal_get_temperature(struct pp_hwmgr *hwmgr);
++extern int tonga_thermal_stop_thermal_controller(struct pp_hwmgr *hwmgr);
++extern int tonga_fan_ctrl_get_fan_speed_info(struct pp_hwmgr *hwmgr, struct phm_fan_speed_info *fan_speed_info);
++extern int tonga_fan_ctrl_get_fan_speed_percent(struct pp_hwmgr *hwmgr, uint32_t *speed);
++extern int tonga_fan_ctrl_set_default_mode(struct pp_hwmgr *hwmgr);
++extern int tonga_fan_ctrl_set_static_mode(struct pp_hwmgr *hwmgr, uint32_t mode);
++extern int tonga_fan_ctrl_set_fan_speed_percent(struct pp_hwmgr *hwmgr, uint32_t speed);
++extern int tonga_fan_ctrl_reset_fan_speed_to_default(struct pp_hwmgr *hwmgr);
++extern int pp_tonga_thermal_initialize(struct pp_hwmgr *hwmgr);
++extern int tonga_thermal_ctrl_uninitialize_thermal_controller(struct pp_hwmgr *hwmgr);
++extern int tonga_fan_ctrl_set_fan_speed_rpm(struct pp_hwmgr *hwmgr, uint32_t speed);
++extern int tonga_fan_ctrl_get_fan_speed_rpm(struct pp_hwmgr *hwmgr, uint32_t *speed);
++
++#endif
++
+--
+2.7.4
+