aboutsummaryrefslogtreecommitdiffstats
path: root/meta-amdfalconx86/recipes-graphics/lunarg-sdk/vulkan-samples
diff options
context:
space:
mode:
Diffstat (limited to 'meta-amdfalconx86/recipes-graphics/lunarg-sdk/vulkan-samples')
-rw-r--r--meta-amdfalconx86/recipes-graphics/lunarg-sdk/vulkan-samples/0001-Layer-Samples-fix-build-without-BUILD_LAYERS.patch41
-rw-r--r--meta-amdfalconx86/recipes-graphics/lunarg-sdk/vulkan-samples/0002-install-samples.patch63
2 files changed, 0 insertions, 104 deletions
diff --git a/meta-amdfalconx86/recipes-graphics/lunarg-sdk/vulkan-samples/0001-Layer-Samples-fix-build-without-BUILD_LAYERS.patch b/meta-amdfalconx86/recipes-graphics/lunarg-sdk/vulkan-samples/0001-Layer-Samples-fix-build-without-BUILD_LAYERS.patch
deleted file mode 100644
index d9b59309..00000000
--- a/meta-amdfalconx86/recipes-graphics/lunarg-sdk/vulkan-samples/0001-Layer-Samples-fix-build-without-BUILD_LAYERS.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-From 6488c60f7bb9a8d0f956e51a9f7657db9027c5fe Mon Sep 17 00:00:00 2001
-From: Awais Belal <awais_belal@mentor.com>
-Date: Wed, 31 Aug 2016 11:36:38 +0500
-Subject: [PATCH] Layer-Samples: fix build without BUILD_LAYERS
-
-Some of the layer samples require layer utils to be
-built and these fail when BUILD_LAYERS is disabled.
-We fix this by providing the required dependencies
-even when the BUILD_LAYERS is disabled.
-
-Signed-off-by: Awais Belal <awais_belal@mentor.com>
----
- Layer-Samples/Overlay/CMakeLists.txt | 12 ++++++++++++
- 1 file changed, 12 insertions(+)
-
-diff --git a/Layer-Samples/Overlay/CMakeLists.txt b/Layer-Samples/Overlay/CMakeLists.txt
-index 26f9b3a..a26664c 100644
---- a/Layer-Samples/Overlay/CMakeLists.txt
-+++ b/Layer-Samples/Overlay/CMakeLists.txt
-@@ -40,6 +40,18 @@ add_library(VKLayer_overlay SHARED overlay.cpp
- ${SHADER_DIR}/overlay-frag.spv
- overlay.json)
-
-+if(NOT BUILD_LAYERS)
-+add_custom_command(OUTPUT vk_dispatch_table_helper.h
-+ COMMAND ${PYTHON_CMD} ${PROJECT_SOURCE_DIR}/vk-generate.py ${DisplayServer} dispatch-table-ops layer > ${LAYERS_LOC}/layers/vk_dispatch_table_helper.h
-+ DEPENDS ${PROJECT_SOURCE_DIR}/vk-generate.py ${PROJECT_SOURCE_DIR}/vulkan.py)
-+
-+add_custom_target(generate_vk_layer_helpers DEPENDS
-+ vk_dispatch_table_helper.h
-+)
-+
-+add_dependencies(VKLayer_overlay generate_vk_layer_helpers)
-+endif()
-+
- if (WIN32)
- set (CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -D_CRT_SECURE_NO_WARNINGS")
- set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -D_CRT_SECURE_NO_WARNINGS")
---
-1.9.1
-
diff --git a/meta-amdfalconx86/recipes-graphics/lunarg-sdk/vulkan-samples/0002-install-samples.patch b/meta-amdfalconx86/recipes-graphics/lunarg-sdk/vulkan-samples/0002-install-samples.patch
deleted file mode 100644
index 4b6c01cb..00000000
--- a/meta-amdfalconx86/recipes-graphics/lunarg-sdk/vulkan-samples/0002-install-samples.patch
+++ /dev/null
@@ -1,63 +0,0 @@
-From 66ccfc283f7d3bf4cf065c18a25e4edd8b981c0b Mon Sep 17 00:00:00 2001
-From: Awais Belal <awais_belal@mentor.com>
-Date: Wed, 31 Aug 2016 13:11:09 +0500
-Subject: [PATCH] install samples
-
-The samples are built but not installed correctly. This
-fixes the issues and deploys all the built samples as
-necessary.
-
-Signed-off-by: Awais Belal <awais_belal@mentor.com>
----
- API-Samples/CMakeLists.txt | 4 ++++
- Sample-Programs/Hologram/CMakeLists.txt | 1 +
- 2 files changed, 5 insertions(+)
-
-diff --git a/API-Samples/CMakeLists.txt b/API-Samples/CMakeLists.txt
-index fedad5d..73916e0 100644
---- a/API-Samples/CMakeLists.txt
-+++ b/API-Samples/CMakeLists.txt
-@@ -31,6 +31,7 @@ function(sampleExtGLSLShaders SNAME)
- endforeach(SFILE)
- add_executable(${SAMPLE_NAME} ${SAMPLE_NAME}/${SAMPLE_NAME}.cpp ${SHADER_FILES})
- target_link_libraries(${SAMPLE_NAME} ${VULKAN_LOADER} ${UTILS_NAME} ${GLSLANG_LIBRARIES} ${PTHREAD})
-+ install(TARGETS ${SAMPLE_NAME} DESTINATION ${CMAKE_INSTALL_BINDIR})
- endfunction(sampleExtGLSLShaders)
-
- # function to build a single-source-file sample that uses spirv shaders
-@@ -44,6 +45,7 @@ function(sampleExtSPIRVShaders SNAME)
- endforeach(SFILE)
- add_executable(${SAMPLE_NAME} ${SAMPLE_NAME}/${SAMPLE_NAME}.cpp ${SHADER_FILES})
- target_link_libraries(${SAMPLE_NAME} ${VULKAN_LOADER} ${UTILS_NAME} ${GLSLANG_LIBRARIES} ${PTHREAD})
-+ install(TARGETS ${SAMPLE_NAME} DESTINATION ${CMAKE_INSTALL_BINDIR})
- endfunction(sampleExtSPIRVShaders)
-
- # function to build a simple single-source-file sample
-@@ -127,6 +129,7 @@ function(sampleWithSingleFile)
- elseif(UNIX)
- add_executable(${SAMPLE_NAME} ${SAMPLE_NAME}/${SAMPLE_NAME}.cpp)
- target_link_libraries(${SAMPLE_NAME} ${UTILS_NAME} ${GLSLANG_LIBRARIES} ${XCB_LIBRARIES} ${VULKAN_LOADER} ${PTHREAD} ${SPIRV_TOOLS_LIBRARIES})
-+ install(TARGETS ${SAMPLE_NAME} DESTINATION ${CMAKE_INSTALL_BINDIR})
- else()
- add_executable(${SAMPLE_NAME} WIN32 ${SAMPLE_NAME}/${SAMPLE_NAME}.cpp)
- target_link_libraries(${SAMPLE_NAME} ${UTILS_NAME} ${GLSLANG_LIBRARIES} ${VULKAN_LOADER} ${WINLIBS} ${SPIRV_TOOLS_LIBRARIES})
-@@ -148,6 +151,7 @@ function(sampleInlineGLSLShaders)
- if(UNIX)
- add_executable(${SAMPLE_NAME} ${SAMPLE_NAME}/${SAMPLE_NAME}.cpp)
- target_link_libraries(${SAMPLE_NAME} ${GLSLANG_LIBRARIES} ${XCB_LIBRARIES} ${VULKAN_LOADER} ${PTHREAD})
-+ install(TARGETS ${SAMPLE_NAME} DESTINATION ${CMAKE_INSTALL_BINDIR})
- else()
- add_executable(${SAMPLE_NAME} WIN32 ${SAMPLE_NAME}/${SAMPLE_NAME}.cpp)
- target_link_libraries(${SAMPLE_NAME} ${GLSLANG_LIBRARIES} ${VULKAN_LOADER} ${WINLIBS})
-diff --git a/Sample-Programs/Hologram/CMakeLists.txt b/Sample-Programs/Hologram/CMakeLists.txt
-index 779ecb8..ab04b44 100644
---- a/Sample-Programs/Hologram/CMakeLists.txt
-+++ b/Sample-Programs/Hologram/CMakeLists.txt
-@@ -83,3 +83,4 @@ add_executable(Hologram ${sources})
- target_compile_definitions(Hologram ${definitions})
- target_include_directories(Hologram ${includes})
- target_link_libraries(Hologram ${libraries})
-+install(TARGETS Hologram DESTINATION ${CMAKE_INSTALL_BINDIR})
---
-1.9.1
-