aboutsummaryrefslogtreecommitdiffstats
path: root/meta-amdfalconx86/recipes-devtools/spirv
diff options
context:
space:
mode:
Diffstat (limited to 'meta-amdfalconx86/recipes-devtools/spirv')
-rw-r--r--meta-amdfalconx86/recipes-devtools/spirv/spirv-tools/0001-obey-CMAKE_INSTALL_LIBDIR.patch28
-rw-r--r--meta-amdfalconx86/recipes-devtools/spirv/spirv-tools/0002-spirv-lesspipe.sh-allow-using-generic-shells.patch27
-rw-r--r--meta-amdfalconx86/recipes-devtools/spirv/spirv-tools_git.bb29
3 files changed, 84 insertions, 0 deletions
diff --git a/meta-amdfalconx86/recipes-devtools/spirv/spirv-tools/0001-obey-CMAKE_INSTALL_LIBDIR.patch b/meta-amdfalconx86/recipes-devtools/spirv/spirv-tools/0001-obey-CMAKE_INSTALL_LIBDIR.patch
new file mode 100644
index 00000000..d1f0f3b1
--- /dev/null
+++ b/meta-amdfalconx86/recipes-devtools/spirv/spirv-tools/0001-obey-CMAKE_INSTALL_LIBDIR.patch
@@ -0,0 +1,28 @@
+From a6b250054e5bc27b87414c860c9b808a4beef552 Mon Sep 17 00:00:00 2001
+From: Awais Belal <awais_belal@mentor.com>
+Date: Tue, 16 Aug 2016 16:07:45 +0500
+Subject: [PATCH] obey CMAKE_INSTALL_LIBDIR
+
+If the path to CMAKE_INSTALL_LIBDIR is not followed appropriately
+the installation will not work correctly on a multilib platofrm.
+
+Signed-off-by: Awais Belal <awais_belal@mentor.com>
+---
+ source/CMakeLists.txt | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/source/CMakeLists.txt b/source/CMakeLists.txt
+index de227d6..73672a1 100644
+--- a/source/CMakeLists.txt
++++ b/source/CMakeLists.txt
+@@ -198,5 +198,5 @@ target_include_directories(${SPIRV_TOOLS}
+
+ install(TARGETS ${SPIRV_TOOLS}
+ RUNTIME DESTINATION bin
+- LIBRARY DESTINATION lib
+- ARCHIVE DESTINATION lib)
++ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
++ ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR})
+--
+1.9.1
+
diff --git a/meta-amdfalconx86/recipes-devtools/spirv/spirv-tools/0002-spirv-lesspipe.sh-allow-using-generic-shells.patch b/meta-amdfalconx86/recipes-devtools/spirv/spirv-tools/0002-spirv-lesspipe.sh-allow-using-generic-shells.patch
new file mode 100644
index 00000000..2d51f2fd
--- /dev/null
+++ b/meta-amdfalconx86/recipes-devtools/spirv/spirv-tools/0002-spirv-lesspipe.sh-allow-using-generic-shells.patch
@@ -0,0 +1,27 @@
+From 93a770330aa21c91a9b7fce798b73d31cad8f16a Mon Sep 17 00:00:00 2001
+From: Awais Belal <awais_belal@mentor.com>
+Date: Tue, 25 Oct 2016 16:12:08 +0500
+Subject: [PATCH] spirv-lesspipe.sh: allow using generic shells
+
+The script is harmless for any type of shell and
+shouldn't be tied with bash to allow catering
+more possibilities.
+
+Signed-off-by: Awais Belal <awais_belal@mentor.com>
+---
+ tools/lesspipe/spirv-lesspipe.sh | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/tools/lesspipe/spirv-lesspipe.sh b/tools/lesspipe/spirv-lesspipe.sh
+index 05831d1..4e98fee 100644
+--- a/tools/lesspipe/spirv-lesspipe.sh
++++ b/tools/lesspipe/spirv-lesspipe.sh
+@@ -1,4 +1,4 @@
+-#!/bin/bash
++#!/bin/sh
+
+ # Copyright (c) 2016 The Khronos Group Inc.
+ #
+--
+1.9.1
+
diff --git a/meta-amdfalconx86/recipes-devtools/spirv/spirv-tools_git.bb b/meta-amdfalconx86/recipes-devtools/spirv/spirv-tools_git.bb
new file mode 100644
index 00000000..f9563366
--- /dev/null
+++ b/meta-amdfalconx86/recipes-devtools/spirv/spirv-tools_git.bb
@@ -0,0 +1,29 @@
+SUMMARY = "SPIR-V Tools"
+DESCRIPTION = "SPIR-V is a binary intermediate language for representing \
+ graphical-shader stages and compute kernels for multiple \
+ Khronos APIs, such as OpenCL, OpenGL, and Vulkan."
+SECTION = "graphics"
+HOMEPAGE = "https://www.khronos.org/registry/spir-v"
+
+inherit cmake python3native
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ce523927d7bcd789d6c3af579d03ad73"
+
+S = "${WORKDIR}/git"
+SPIRV_HEADERS_LOCATION = "${S}/external/spirv-headers"
+HEADERS_VERSION = "1.1"
+
+SRCREV_spirv-tools = "923a4596b44831a07060df45caacb522613730c9"
+SRCREV_spirv-headers = "33d41376d378761ed3a4c791fc4b647761897f26"
+SRC_URI = "git://github.com/KhronosGroup/SPIRV-Tools;protocol=http;name=spirv-tools \
+ git://github.com/KhronosGroup/SPIRV-Headers;name=spirv-headers;destsuffix=${SPIRV_HEADERS_LOCATION} \
+ file://0001-obey-CMAKE_INSTALL_LIBDIR.patch \
+ file://0002-spirv-lesspipe.sh-allow-using-generic-shells.patch"
+
+do_install_append() {
+ if test -d ${SPIRV_HEADERS_LOCATION}/include/spirv/${HEADERS_VERSION}; then
+ install -d ${D}/${includedir}/SPIRV
+ install -m 0644 ${SPIRV_HEADERS_LOCATION}/include/spirv/${HEADERS_VERSION}/* ${D}/${includedir}/SPIRV
+ fi
+}