aboutsummaryrefslogtreecommitdiffstats
path: root/meta-amd-distro/recipes-devtools/dpkg/dpkg_%.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'meta-amd-distro/recipes-devtools/dpkg/dpkg_%.bbappend')
-rw-r--r--meta-amd-distro/recipes-devtools/dpkg/dpkg_%.bbappend8
1 files changed, 4 insertions, 4 deletions
diff --git a/meta-amd-distro/recipes-devtools/dpkg/dpkg_%.bbappend b/meta-amd-distro/recipes-devtools/dpkg/dpkg_%.bbappend
index 099292ab..2bbf6e17 100644
--- a/meta-amd-distro/recipes-devtools/dpkg/dpkg_%.bbappend
+++ b/meta-amd-distro/recipes-devtools/dpkg/dpkg_%.bbappend
@@ -1,8 +1,8 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/files:"
inherit systemd
-SYSTEMD_SERVICE_${PN} = "dpkg-configure-pending.service"
+SYSTEMD_SERVICE:${PN} = "dpkg-configure-pending.service"
SYSTEMD_AUTO_ENABLE = "enable"
SRC_URI += " \
@@ -10,13 +10,13 @@ SRC_URI += " \
file://dpkg-configure-pending \
"
-do_install_append () {
+do_install:append () {
install -d ${D}${systemd_unitdir}/system
install -m 644 ${WORKDIR}/dpkg-configure-pending.service ${D}${systemd_unitdir}/system/
install -m 755 ${WORKDIR}/dpkg-configure-pending ${D}${sbindir}/dpkg-configure-pending
}
-FILES_${PN} += " \
+FILES:${PN} += " \
${systemd_unitdir}/system/dpkg-configure-pending.service \
${sbindir}/dpkg-configure-pending \
"