aboutsummaryrefslogtreecommitdiffstats
path: root/meta-amd-bsp/recipes-multimedia/libomxil/libomxil_0.9.3.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'meta-amd-bsp/recipes-multimedia/libomxil/libomxil_0.9.3.bbappend')
-rw-r--r--meta-amd-bsp/recipes-multimedia/libomxil/libomxil_0.9.3.bbappend35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta-amd-bsp/recipes-multimedia/libomxil/libomxil_0.9.3.bbappend b/meta-amd-bsp/recipes-multimedia/libomxil/libomxil_0.9.3.bbappend
new file mode 100644
index 00000000..aadab2cd
--- /dev/null
+++ b/meta-amd-bsp/recipes-multimedia/libomxil/libomxil_0.9.3.bbappend
@@ -0,0 +1,35 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+SRC_URI_append_amd = " file://0001-test-components-fix-linking-issue.patch"
+
+RDEPENDS_${PN}_append_amd = " libomx-mesa"
+RDEPENDS_${PN}-test_append_amd = " bash"
+
+#
+# This package should not have commercial license flags.
+# There is discussion in the OE community about fixing this
+# but in the meantime we'll explicitly remove it here.
+#
+LICENSE_FLAGS_remove = "commercial"
+
+SRC_URI_append_amd = " file://0001-Added-NULL-pointer-check-for-failure-scenario.patch"
+
+#
+# The upstream sources expect that "make check" is run
+# after "make install" and we have to jump through some
+# extra hoops since we are cross building to avoid RPATH
+# issues.
+#
+do_install_append_amd () {
+ oe_runmake includedir=${D}${includedir} LDFLAGS="${LDFLAGS}" check
+ install test/components/audio_effects/omxvolcontroltest ${D}${bindir}
+ install test/components/audio_effects/omxaudiomixertest ${D}${bindir}
+ install test/components/resource_manager/omxrmtest ${D}${bindir}
+}
+
+PACKAGES_prepend_amd = "${PN}-test "
+FILES_${PN}-test_amd = "${bindir}/omxvolcontroltest ${bindir}/omxaudiomixertest ${bindir}/omxrmtest"
+
+pkg_postinst_ontarget_${PN}_amd () {
+ OMX_BELLAGIO_REGISTRY=${ROOT_HOME}/.omxregister ${bindir}/omxregister-bellagio -v
+}