aboutsummaryrefslogtreecommitdiffstats
path: root/meta-amd-bsp/recipes-multimedia/gstreamer
diff options
context:
space:
mode:
Diffstat (limited to 'meta-amd-bsp/recipes-multimedia/gstreamer')
-rw-r--r--meta-amd-bsp/recipes-multimedia/gstreamer/gstreamer1.0-meta-base.bbappend8
-rw-r--r--meta-amd-bsp/recipes-multimedia/gstreamer/gstreamer1.0-omx/0001-gstomx.conf-add-mesa-omx-bellagio-encoder-avc-decode.patch37
-rw-r--r--meta-amd-bsp/recipes-multimedia/gstreamer/gstreamer1.0-omx_1.14.4.bbappend16
-rw-r--r--meta-amd-bsp/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_%.bbappend7
-rw-r--r--meta-amd-bsp/recipes-multimedia/gstreamer/gstreamer1.0-plugins-ugly_%.bbappend3
-rw-r--r--meta-amd-bsp/recipes-multimedia/gstreamer/gstreamer1.0-vaapi_%.bbappend1
6 files changed, 72 insertions, 0 deletions
diff --git a/meta-amd-bsp/recipes-multimedia/gstreamer/gstreamer1.0-meta-base.bbappend b/meta-amd-bsp/recipes-multimedia/gstreamer/gstreamer1.0-meta-base.bbappend
new file mode 100644
index 00000000..d2975992
--- /dev/null
+++ b/meta-amd-bsp/recipes-multimedia/gstreamer/gstreamer1.0-meta-base.bbappend
@@ -0,0 +1,8 @@
+RDEPENDS_gstreamer1.0-meta-video_append_amd = " \
+ gstreamer1.0-plugins-good-video4linux2 \
+ gstreamer1.0-plugins-good-isomp4 \
+ gstreamer1.0-plugins-good-deinterlace \
+ gstreamer1.0-plugins-good-audioparsers \
+ gstreamer1.0-plugins-good-id3demux \
+ gstreamer1.0-plugins-good-videomixer \
+"
diff --git a/meta-amd-bsp/recipes-multimedia/gstreamer/gstreamer1.0-omx/0001-gstomx.conf-add-mesa-omx-bellagio-encoder-avc-decode.patch b/meta-amd-bsp/recipes-multimedia/gstreamer/gstreamer1.0-omx/0001-gstomx.conf-add-mesa-omx-bellagio-encoder-avc-decode.patch
new file mode 100644
index 00000000..cf82c3d6
--- /dev/null
+++ b/meta-amd-bsp/recipes-multimedia/gstreamer/gstreamer1.0-omx/0001-gstomx.conf-add-mesa-omx-bellagio-encoder-avc-decode.patch
@@ -0,0 +1,37 @@
+From 39a94d69833508a351376456dad08ea5facf9362 Mon Sep 17 00:00:00 2001
+From: "Arsalan H. Awan" <Arsalan_Awan@mentor.com>
+Date: Wed, 4 Sep 2019 22:12:59 +0500
+Subject: [PATCH] gstomx.conf add mesa omx bellagio encoder avc & decoder hevc
+
+Signed-off-by: Arsalan H. Awan <Arsalan_Awan@mentor.com>
+---
+ config/bellagio/gstomx.conf | 16 ++++++++++++++++
+ 1 file changed, 16 insertions(+)
+
+diff --git a/config/bellagio/gstomx.conf b/config/bellagio/gstomx.conf
+index 0e856be..3e43011 100644
+--- a/config/bellagio/gstomx.conf
++++ b/config/bellagio/gstomx.conf
+@@ -58,3 +58,19 @@ component-name=OMX.mesa.video_decoder.mpeg2
+ rank=0
+ in-port-index=0
+ out-port-index=1
++
++[omxh265dec]
++type-name=GstOMXH265Dec
++core-name=/usr/lib/libomxil-bellagio.so.0
++component-name=OMX.mesa.video_decoder.hevc
++rank=0
++in-port-index=0
++out-port-index=1
++
++[omxh264enc]
++type-name=GstOMXH264Enc
++core-name=/usr/lib/libomxil-bellagio.so.0
++component-name=OMX.mesa.video_encoder.avc
++rank=256
++in-port-index=0
++out-port-index=1
+--
+2.11.1
+
diff --git a/meta-amd-bsp/recipes-multimedia/gstreamer/gstreamer1.0-omx_1.14.4.bbappend b/meta-amd-bsp/recipes-multimedia/gstreamer/gstreamer1.0-omx_1.14.4.bbappend
new file mode 100644
index 00000000..f10ce33b
--- /dev/null
+++ b/meta-amd-bsp/recipes-multimedia/gstreamer/gstreamer1.0-omx_1.14.4.bbappend
@@ -0,0 +1,16 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+#
+# Remove plugins-bad from DEPENDS as it is
+# not strictly needed.
+#
+DEPENDS_remove_amd = "gstreamer1.0-plugins-bad"
+
+SRC_URI += "file://0001-gstomx.conf-add-mesa-omx-bellagio-encoder-avc-decode.patch"
+
+#
+# This package should not have commercial license flags.
+# There is discussion in the OE community about fixing this
+# but in the meantime we'll explicitly remove it here.
+#
+LICENSE_FLAGS_remove = "commercial"
diff --git a/meta-amd-bsp/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_%.bbappend b/meta-amd-bsp/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_%.bbappend
new file mode 100644
index 00000000..646a2cea
--- /dev/null
+++ b/meta-amd-bsp/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_%.bbappend
@@ -0,0 +1,7 @@
+PACKAGECONFIG_append_amd = " faad"
+
+EXTRA_OECONF_remove_amd = " --disable-vdpau"
+EXTRA_OECONF_append_amd = " --enable-vdpau"
+
+# we do not support wayland
+PACKAGECONFIG_remove_amd = "wayland"
diff --git a/meta-amd-bsp/recipes-multimedia/gstreamer/gstreamer1.0-plugins-ugly_%.bbappend b/meta-amd-bsp/recipes-multimedia/gstreamer/gstreamer1.0-plugins-ugly_%.bbappend
new file mode 100644
index 00000000..8ce382ed
--- /dev/null
+++ b/meta-amd-bsp/recipes-multimedia/gstreamer/gstreamer1.0-plugins-ugly_%.bbappend
@@ -0,0 +1,3 @@
+PACKAGECONFIG_append_amd = " x264"
+
+FILES_${PN}-x264_append_amd = " ${datadir}/gstreamer-1.0/presets/GstX264Enc.prs"
diff --git a/meta-amd-bsp/recipes-multimedia/gstreamer/gstreamer1.0-vaapi_%.bbappend b/meta-amd-bsp/recipes-multimedia/gstreamer/gstreamer1.0-vaapi_%.bbappend
new file mode 100644
index 00000000..08c41975
--- /dev/null
+++ b/meta-amd-bsp/recipes-multimedia/gstreamer/gstreamer1.0-vaapi_%.bbappend
@@ -0,0 +1 @@
+DEPENDS_append_amd = " libva-x11"