aboutsummaryrefslogtreecommitdiffstats
path: root/common/recipes-graphics/mesa
diff options
context:
space:
mode:
Diffstat (limited to 'common/recipes-graphics/mesa')
-rw-r--r--common/recipes-graphics/mesa/mesa/0001-configure.ac-adjust-usage-of-LLVM-flags.patch37
-rw-r--r--common/recipes-graphics/mesa/mesa/0001-configure.ac-obey-llvm_prefix-if-available.patch30
-rw-r--r--common/recipes-graphics/mesa/mesa/0001-gallium-add-missing-PIPE_CAP_SURFACE_SAMPLE_COUNT-de.patch33
-rw-r--r--common/recipes-graphics/mesa/mesa_git.bb78
4 files changed, 0 insertions, 178 deletions
diff --git a/common/recipes-graphics/mesa/mesa/0001-configure.ac-adjust-usage-of-LLVM-flags.patch b/common/recipes-graphics/mesa/mesa/0001-configure.ac-adjust-usage-of-LLVM-flags.patch
deleted file mode 100644
index a6599648..00000000
--- a/common/recipes-graphics/mesa/mesa/0001-configure.ac-adjust-usage-of-LLVM-flags.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-From 223ffdb659ceb8628e38003495b5c6550833b673 Mon Sep 17 00:00:00 2001
-From: Awais Belal <awais_belal@mentor.com>
-Date: Thu, 26 Jul 2018 17:13:32 +0500
-Subject: [PATCH] configure.ac: adjust usage of LLVM flags
-
-The llvm-config is provided through a native build
-so using flags from there creates conflicts between
-mesa and llvm on the target.
-
-Signed-off-by: Awais Belal <awais_belal@mentor.com>
----
- configure.ac | 3 ++-
- 1 file changed, 2 insertions(+), 1 deletion(-)
-
-diff --git a/configure.ac b/configure.ac
-index d1c8bb82da..290cc5f9f8 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -1064,6 +1064,7 @@ strip_unwanted_llvm_flags() {
- -e 's/[[[:space:]]]+-pedantic[[[:space:]]]/ /g' \
- -e 's/[[[:space:]]]+-W[[^[:space:]]]*//g' \
- -e 's/[[[:space:]]]+-O[[^[:space:]]]*//g' \
-+ -e 's/[[[:space:]]]+-D_GLIBCXX_USE_CXX11_ABI[[^[:space:]]]*//g' \
- -e 's/[[[:space:]]]+-g[[^[:space:]]]*//g' \
- -e 's/-fno-rtti[[[:space:]]]/-Fno-rtti /g' \
- -e 's/[[[:space:]]]+-f[[^[:space:]]]*//g' \
-@@ -2808,7 +2809,7 @@ dnl
- if test "x$enable_llvm" = xyes; then
- DEFINES="${DEFINES} -DHAVE_LLVM=0x0$LLVM_VERSION_INT -DMESA_LLVM_VERSION_PATCH=$LLVM_VERSION_PATCH"
-
-- LLVM_LDFLAGS=`$LLVM_CONFIG --ldflags`
-+ LLVM_LDFLAGS=
- LLVM_CFLAGS=$LLVM_CPPFLAGS # CPPFLAGS seem to be sufficient
- LLVM_CXXFLAGS=`strip_unwanted_llvm_flags "$LLVM_CONFIG --cxxflags"`
-
---
-2.11.1
diff --git a/common/recipes-graphics/mesa/mesa/0001-configure.ac-obey-llvm_prefix-if-available.patch b/common/recipes-graphics/mesa/mesa/0001-configure.ac-obey-llvm_prefix-if-available.patch
deleted file mode 100644
index 76e152e7..00000000
--- a/common/recipes-graphics/mesa/mesa/0001-configure.ac-obey-llvm_prefix-if-available.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-From 8dc29db401030725ca0201ba03feb6238ec258f7 Mon Sep 17 00:00:00 2001
-From: Awais Belal <awais_belal@mentor.com>
-Date: Fri, 20 Jul 2018 17:58:45 +0500
-Subject: [PATCH] configure.ac: obey llvm_prefix if available
-
-Signed-off-by: Awais Belal <awais_belal@mentor.com>
----
- configure.ac | 6 +++++-
- 1 file changed, 5 insertions(+), 1 deletion(-)
-
-diff --git a/configure.ac b/configure.ac
-index d1c8bb82da..92a83fec4a 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -2821,7 +2821,11 @@ if test "x$enable_llvm" = xyes; then
-
- if test $LLVM_VERSION_MAJOR -ge 4 -o $LLVM_VERSION_MAJOR -eq 3 -a $LLVM_VERSION_MINOR -ge 9; then
- if test "x$enable_llvm_shared_libs" = xyes; then
-- LLVM_LIBS="`$LLVM_CONFIG --link-shared --libs ${LLVM_COMPONENTS}`"
-+ if test "x${llvm_prefix}" == "x"; then
-+ LLVM_LIBS="`$LLVM_CONFIG --link-shared --libs ${LLVM_COMPONENTS}`"
-+ else
-+ LLVM_LIBS="`$LLVM_CONFIG --link-shared --libs ${LLVM_COMPONENTS} --tgtlibdir ${llvm_prefix}`"
-+ fi
- else
- dnl Invoking llvm-config with both -libs and --system-libs produces the
- dnl two separate lines - each for the set of libraries.
---
-2.11.1
-
diff --git a/common/recipes-graphics/mesa/mesa/0001-gallium-add-missing-PIPE_CAP_SURFACE_SAMPLE_COUNT-de.patch b/common/recipes-graphics/mesa/mesa/0001-gallium-add-missing-PIPE_CAP_SURFACE_SAMPLE_COUNT-de.patch
deleted file mode 100644
index d40aaa98..00000000
--- a/common/recipes-graphics/mesa/mesa/0001-gallium-add-missing-PIPE_CAP_SURFACE_SAMPLE_COUNT-de.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-From ad0ef93a61be1ccd00e3b48bf6913bc2bffb3143 Mon Sep 17 00:00:00 2001
-From: Samuel Pitoiset <samuel.pitoiset@gmail.com>
-Date: Fri, 7 Dec 2018 10:08:38 +0100
-Subject: [PATCH] gallium: add missing PIPE_CAP_SURFACE_SAMPLE_COUNT default
- value
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-Fixes: 2710c40e3c8 ("gallium: Add new PIPE_CAP_SURFACE_SAMPLE_COUNT")
-Signed-off-by: Samuel Pitoiset <samuel.pitoiset@gmail.com>
-Tested-by: Michel Dänzer <michel.daenzer@amd.com>
----
- src/gallium/auxiliary/util/u_screen.c | 3 +++
- 1 file changed, 3 insertions(+)
-
-diff --git a/src/gallium/auxiliary/util/u_screen.c b/src/gallium/auxiliary/util/u_screen.c
-index 95d2a7d5701..6ca3992ecd1 100644
---- a/src/gallium/auxiliary/util/u_screen.c
-+++ b/src/gallium/auxiliary/util/u_screen.c
-@@ -328,6 +328,9 @@ u_pipe_screen_get_param_defaults(struct pipe_screen *pscreen,
- case PIPE_CAP_MAX_VERTEX_ELEMENT_SRC_OFFSET:
- return 2047;
-
-+ case PIPE_CAP_SURFACE_SAMPLE_COUNT:
-+ return 0;
-+
- default:
- unreachable("bad PIPE_CAP_*");
- }
---
-2.11.1
-
diff --git a/common/recipes-graphics/mesa/mesa_git.bb b/common/recipes-graphics/mesa/mesa_git.bb
deleted file mode 100644
index 048ce06d..00000000
--- a/common/recipes-graphics/mesa/mesa_git.bb
+++ /dev/null
@@ -1,78 +0,0 @@
-require recipes-graphics/mesa/${BPN}.inc
-
-S = "${WORKDIR}/git"
-
-DEPENDS_append = " python-mako-native"
-inherit pythonnative
-
-SRCREV_amd = "0144bbdb98f515cce31688fce57d769e7fd82d52"
-LIC_FILES_CHKSUM_amd = "file://docs/license.html;md5=725f991a1cc322aa7a0cd3a2016621c4"
-PV_amd = "19.0.0+git${SRCPV}"
-
-DEPENDS_append_amd = " libvdpau libomxil"
-
-PACKAGECONFIG[va] = "--enable-va,--disable-va,libva"
-PACKAGECONFIG_append_amd = " xvmc gallium r600 gallium-llvm xa"
-PACKAGECONFIG_append_radeon = " va"
-PACKAGECONFIG_append_amdgpu = " va"
-
-PACKAGECONFIG_remove_amd = "vulkan"
-PACKAGECONFIG_remove_amdfalconx86 = "xvmc"
-
-LIBVA_PLATFORMS = "libva"
-LIBVA_PLATFORMS .= "${@bb.utils.contains('DISTRO_FEATURES', 'x11', ' libva-x11', '', d)}"
-LIBVA_PLATFORMS .= "${@bb.utils.contains('DISTRO_FEATURES', 'wayland', ' libva-wayland', '', d)}"
-RDEPENDS_mesa-megadriver += "${@bb.utils.contains('PACKAGECONFIG', 'va', '${LIBVA_PLATFORMS}', '', d)}"
-
-SRC_URI_amd = "git://anongit.freedesktop.org/mesa/mesa;branch=master \
- file://0001-configure.ac-obey-llvm_prefix-if-available.patch \
- file://0001-configure.ac-adjust-usage-of-LLVM-flags.patch \
- file://0001-gallium-add-missing-PIPE_CAP_SURFACE_SAMPLE_COUNT-de.patch"
-
-EXTRA_OECONF_append_amd = " \
- --enable-vdpau \
- --enable-osmesa \
- --enable-glx \
- --enable-omx-bellagio \
- --with-omx-bellagio-libdir=${libdir}/bellagio"
-EXTRA_OECONF_remove_amd = "--enable-texture-float"
-
-# Package all the libXvMC gallium extensions together
-# they provide the shared lib libXvMCGallium and splitting
-# them up creates trouble in rpm packaging
-PACKAGES =+ "libxvmcgallium-${PN} libxvmcgallium-${PN}-dev"
-FILES_libxvmcgallium-${PN} = "${libdir}/libXvMC*${SOLIBS}"
-FILES_libxvmcgallium-${PN}-dev = "${libdir}/libXvMC*${SOLIBSDEV} \
- ${libdir}/libXvMC*.la"
-
-PACKAGES =+ "libvdpau-${PN} libvdpau-${PN}-dev"
-FILES_libvdpau-${PN} = "${libdir}/vdpau/libvdpau*${SOLIBS}"
-FILES_libvdpau-${PN}-dev = "${libdir}/vdpau/libvdpau*${SOLIBSDEV} \
- ${libdir}/vdpau/libvdpau*.la"
-FILES_${PN}-dbg += "${libdir}/vdpau/.debug"
-
-#
-# libomx files are non-versioned so we put *.so directly in the
-# main package as opposed to the -dev package.
-#
-PACKAGES =+ "libomx-${PN} libomx-${PN}-dev ${PN}-driconfigs"
-FILES_libomx-${PN} = "${libdir}/bellagio/libomx_*.so"
-FILES_libomx-${PN}-dev = "${libdir}/bellagio/libomx_*.la"
-FILES_${PN}-driconfigs = "${datadir}/drirc.d/*"
-FILES_${PN}-dbg += "${libdir}/bellagio/.debug"
-
-# Set DRIDRIVERS with anonymous python so we can effectively
-# override the _append_x86-64 assignement from mesa.inc.
-python () {
- d.setVar("DRIDRIVERS", "swrast,radeon")
- d.setVar("GALLIUMDRIVERS", "swrast,r300,r600,radeonsi")
-}
-
-#because we cannot rely on the fact that all apps will use pkgconfig,
-#make eglplatform.h independent of MESA_EGL_NO_X11_HEADER
-do_install_append() {
- if ${@bb.utils.contains('PACKAGECONFIG', 'egl', 'true', 'false', d)}; then
- sed -i -e 's/^#if defined(MESA_EGL_NO_X11_HEADERS)$/#if defined(MESA_EGL_NO_X11_HEADERS) || ${@bb.utils.contains('PACKAGECONFIG', 'x11', '0', '1', d)}/' ${D}${includedir}/EGL/eglplatform.h
- fi
-}
-