aboutsummaryrefslogtreecommitdiffstats
path: root/common/recipes-graphics/mesa/mesa_git.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'common/recipes-graphics/mesa/mesa_git.bbappend')
-rw-r--r--common/recipes-graphics/mesa/mesa_git.bbappend44
1 files changed, 10 insertions, 34 deletions
diff --git a/common/recipes-graphics/mesa/mesa_git.bbappend b/common/recipes-graphics/mesa/mesa_git.bbappend
index 34b66e6b..ca506af5 100644
--- a/common/recipes-graphics/mesa/mesa_git.bbappend
+++ b/common/recipes-graphics/mesa/mesa_git.bbappend
@@ -1,8 +1,8 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
-SRCREV_amd = "b9b19162ee3f8d68be76b71adf2a290cbb675660"
-LIC_FILES_CHKSUM_amd = "file://docs/license.html;md5=6a23445982a7a972ac198e93cc1cb3de"
-PV_amd = "11.0.8+git${SRCPV}"
-DEPENDS_append_amd = " libvdpau libomxil python-mako-native"
+SRCREV_amd = "09460b8cf7ddac4abb46eb6439314b29954c76a6"
+LIC_FILES_CHKSUM_amd = "file://docs/license.html;md5=899fbe7e42d494c7c8c159c7001693d5"
+PV_amd = "12.0.3+git${SRCPV}"
+DEPENDS_append_amd = " libvdpau libomxil"
PACKAGECONFIG[va] = "--enable-va,--disable-va,libva"
PACKAGECONFIG_append_amd = " xvmc gallium r600 gallium-llvm xa"
@@ -17,17 +17,10 @@ LIBVA_PLATFORMS .= "${@bb.utils.contains('DISTRO_FEATURES', 'wayland', ' libva-w
LIBVA_PLATFORMS .= "${@bb.utils.contains('DISTRO_FEATURES', 'opengl', ' libva-gl', '', d)}"
RDEPENDS_mesa-megadriver += "${@bb.utils.contains('PACKAGECONFIG', 'va', '${LIBVA_PLATFORMS}', '', d)}"
-MESA_LLVM_RELEASE_amd = "3.7.1"
+MESA_LLVM_RELEASE_amd = "3.9.1"
SRC_URI_amd = "\
- git://anongit.freedesktop.org/git/mesa/mesa;branch=11.0 \
- file://0001-st-omx-h264-fix-corruption-when-scaling-matrix-prese.patch \
- file://0002-st-omx-Remove-trailing-spaces.patch \
- file://0003-st-omx-dec-Correct-the-timestamping.patch \
- file://0004-st-omx-Avoid-segfault-in-deconstructor-if-constructo.patch \
- file://0005-st-omx-enc-Correct-the-timestamping.patch \
- file://0006-st-omx-enc-Modularize-the-Encoding-task.patch \
- file://0007-st-omx-enc-Support-framerate-conversion.patch \
+ git://anongit.freedesktop.org/git/mesa/mesa;branch=12.0 \
"
EXTRA_OECONF_append_amd = " \
@@ -35,7 +28,6 @@ EXTRA_OECONF_append_amd = " \
--enable-osmesa \
--enable-glx \
--enable-omx \
- --enable-r600-llvm-compiler \
--with-omx-libdir=${libdir}/bellagio \
"
@@ -73,23 +65,7 @@ python () {
d.setVar("GALLIUMDRIVERS", "swrast,r300,r600,radeonsi")
}
-# We'll need to setup some symlinks for the va enabled
-# video driver to work properly in case va is enabled
-# so skip the .so symlink checks.
-INSANE_SKIP_${PN}-megadriver += "${@bb.utils.contains('PACKAGECONFIG', 'va', 'dev-so', '', d)}"
-
-# Mesa 11.1 onwards provides options for crypto functions
-# this is not supported in the version we are using currently
-# and generates warnings so disable it.
-MESA_CRYPTO = ""
-
-do_install_append_amd() {
- # Create symlinks for the gallium drivers to be able to play
- # through the va enabled driver by default.
- if ${@bb.utils.contains('PACKAGECONFIG','va','true','false',d)}; then
- gallium_drivers=$(echo ${GALLIUMDRIVERS} | sed 's/,/ /g')
- for gdriver in ${gallium_drivers}; do
- ln -sf ${libdir}/dri/gallium_drv_video.so ${D}${libdir}/dri/${gdriver}_drv_video.so
- done
- fi
-}
+# We're using components like vdpau which depend
+# on nettle so lets just use it as the default for
+# crypto as well.
+MESA_CRYPTO ?= "nettle"