aboutsummaryrefslogtreecommitdiffstats
path: root/common/recipes-graphics/mesa/mesa_19.1.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'common/recipes-graphics/mesa/mesa_19.1.3.bb')
-rw-r--r--common/recipes-graphics/mesa/mesa_19.1.3.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/common/recipes-graphics/mesa/mesa_19.1.3.bb b/common/recipes-graphics/mesa/mesa_19.1.3.bb
new file mode 100644
index 00000000..b5b8bc18
--- /dev/null
+++ b/common/recipes-graphics/mesa/mesa_19.1.3.bb
@@ -0,0 +1,18 @@
+require ${BPN}.inc
+
+SRC_URI = "https://mesa.freedesktop.org/archive/mesa-${PV}.tar.xz \
+ file://0001-meson.build-check-for-all-linux-host_os-combinations.patch \
+ file://0002-meson.build-make-TLS-GLX-optional-again.patch \
+ file://0003-Allow-enable-DRI-without-DRI-drivers.patch \
+ "
+
+SRC_URI[md5sum] = "9772ebf9ac40289a62a02c046904c8af"
+SRC_URI[sha256sum] = "845460b2225d15c15d4a9743dec798ff0b7396b533011d43e774e67f7825b7e0"
+
+#because we cannot rely on the fact that all apps will use pkgconfig,
+#make eglplatform.h independent of MESA_EGL_NO_X11_HEADER
+do_install_append() {
+ if ${@bb.utils.contains('PACKAGECONFIG', 'egl', 'true', 'false', d)}; then
+ sed -i -e 's/^#if defined(MESA_EGL_NO_X11_HEADERS)$/#if defined(MESA_EGL_NO_X11_HEADERS) || ${@bb.utils.contains('PACKAGECONFIG', 'x11', '0', '1', d)}/' ${D}${includedir}/EGL/eglplatform.h
+ fi
+}