aboutsummaryrefslogtreecommitdiffstats
path: root/common/mentor-swupdate/recipes-support
diff options
context:
space:
mode:
Diffstat (limited to 'common/mentor-swupdate/recipes-support')
-rw-r--r--common/mentor-swupdate/recipes-support/swupdate/files/bl-kernels2
-rw-r--r--common/mentor-swupdate/recipes-support/swupdate/files/grub.cfg2
-rw-r--r--common/mentor-swupdate/recipes-support/swupdate/swupdate_2018.03.bbappend9
3 files changed, 13 insertions, 0 deletions
diff --git a/common/mentor-swupdate/recipes-support/swupdate/files/bl-kernels b/common/mentor-swupdate/recipes-support/swupdate/files/bl-kernels
new file mode 100644
index 00000000..a214b543
--- /dev/null
+++ b/common/mentor-swupdate/recipes-support/swupdate/files/bl-kernels
@@ -0,0 +1,2 @@
+bzImageA
+bzImageB
diff --git a/common/mentor-swupdate/recipes-support/swupdate/files/grub.cfg b/common/mentor-swupdate/recipes-support/swupdate/files/grub.cfg
new file mode 100644
index 00000000..97216fd0
--- /dev/null
+++ b/common/mentor-swupdate/recipes-support/swupdate/files/grub.cfg
@@ -0,0 +1,2 @@
+CONFIG_BOOTLOADER_GRUB=y
+CONFIG_GRUBENV_PATH="/boot/EFI/BOOT/grub.env"
diff --git a/common/mentor-swupdate/recipes-support/swupdate/swupdate_2018.03.bbappend b/common/mentor-swupdate/recipes-support/swupdate/swupdate_2018.03.bbappend
new file mode 100644
index 00000000..ce3ecf6b
--- /dev/null
+++ b/common/mentor-swupdate/recipes-support/swupdate/swupdate_2018.03.bbappend
@@ -0,0 +1,9 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+SRC_URI += "file://grub.cfg \
+ file://bl-kernels"
+
+do_install_append() {
+ install -d ${D}${sysconfdir}
+ install -d ${D}${sysconfdir}/swupdate
+ install -m 644 ${WORKDIR}/bl-kernels ${D}${sysconfdir}/swupdate
+}