aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--common/conf/machine/include/amd-common.inc4
-rwxr-xr-xmeta-snowyowl/conf/machine/snowyowl.conf6
-rw-r--r--meta-snowyowl/recipes-kernel/linux/linux-yocto_4.9.bbappend10
3 files changed, 14 insertions, 6 deletions
diff --git a/common/conf/machine/include/amd-common.inc b/common/conf/machine/include/amd-common.inc
index e9b3941b..16518cee 100644
--- a/common/conf/machine/include/amd-common.inc
+++ b/common/conf/machine/include/amd-common.inc
@@ -3,12 +3,12 @@ IMAGE_INSTALL_append += " \
"
GST_PACKAGES = " \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'x11',' \
gstreamer1.0-meta-x11-base \
gstreamer1.0-meta-audio \
gstreamer1.0-meta-debug \
gstreamer1.0-meta-video \
gstreamer1.0-omx \
- gstreamer1.0-vaapi \
-"
+ gstreamer1.0-vaapi', '', d)}"
IMAGE_INSTALL_append_mel += " ${@bb.utils.contains("DISTRO", "mel", "${GST_PACKAGES}", "", d)}"
diff --git a/meta-snowyowl/conf/machine/snowyowl.conf b/meta-snowyowl/conf/machine/snowyowl.conf
index 92daae9d..3ed0c916 100755
--- a/meta-snowyowl/conf/machine/snowyowl.conf
+++ b/meta-snowyowl/conf/machine/snowyowl.conf
@@ -12,7 +12,8 @@ require conf/machine/include/tune-snowyowl.inc
include conf/machine/include/amd-common-configurations.inc
include conf/machine/include/amd-customer-configurations.inc
-MACHINE_EXTRA_RRECOMMENDS_remove = "vdpauinfo rtc-test"
+MACHINE_FEATURES_remove = "alsa"
+MACHINE_EXTRA_RRECOMMENDS_remove = "vdpauinfo rtc-test alsa-utils"
XSERVER ?= "${XSERVER_X86_BASE} \
${XSERVER_X86_EXT} \
@@ -29,6 +30,9 @@ KERNEL_SERIAL_CONSOLE ?= "console=ttyS4,115200n8"
# this allows the serial console to be used for installation
APPEND_remove="console=tty0"
+# Drop features we do not need
+DISTRO_FEATURES_remove="opengl x11 alsa pulseaudio"
+
MACHINEOVERRIDES =. "amd:amdx86:"
# Metadata used by CodeBench for the ADE
diff --git a/meta-snowyowl/recipes-kernel/linux/linux-yocto_4.9.bbappend b/meta-snowyowl/recipes-kernel/linux/linux-yocto_4.9.bbappend
index 77d4c6fe..05a934ca 100644
--- a/meta-snowyowl/recipes-kernel/linux/linux-yocto_4.9.bbappend
+++ b/meta-snowyowl/recipes-kernel/linux/linux-yocto_4.9.bbappend
@@ -1,14 +1,18 @@
require linux-yocto-snowyowl_4.9.inc
-MACHINE_FEATURES_remove = "alsa"
-MACHINE_EXTRA_RRECOMMENDS_remove = "alsa-utils"
-
SRC_URI_append_snowyowl += "file://snowyowl-standard-only.cfg"
SRC_URI_append_snowyowl += "file://disable-graphics.cfg"
KBRANCH_snowyowl ?= "standard/base"
SRCREV_machine_snowyowl ?= "81055b89bd32414ecaf95156ce9a5fa6643e530a"
+# openssl-dev is required for features such as module signing
+DEPENDS_append = " openssl-native"
+
+# backported from OE-core so things such as openssl-native listed
+# above can be picked up from the native sysroot
+EXTRA_OEMAKE = " HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" HOSTCPP="${BUILD_CPP}""
+
do_validate_branches_append() {
# Droping configs related to sound generating spurious warnings
sed -i '/kconf hardware snd_hda_intel.cfg/d' ${WORKDIR}/${KMETA}/features/sound/snd_hda_intel.scc