aboutsummaryrefslogtreecommitdiffstats
path: root/matchbox/theme-engines/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'matchbox/theme-engines/Makefile.am')
-rw-r--r--matchbox/theme-engines/Makefile.am29
1 files changed, 29 insertions, 0 deletions
diff --git a/matchbox/theme-engines/Makefile.am b/matchbox/theme-engines/Makefile.am
new file mode 100644
index 0000000..2fe0dac
--- /dev/null
+++ b/matchbox/theme-engines/Makefile.am
@@ -0,0 +1,29 @@
+if THEME_CAIRO
+CAIRO_SRC = mb-wm-theme-cairo.c mb-wm-theme-cairo.h
+endif
+
+if THEME_SIMPLE
+SIMPLE_SRC = mb-wm-theme-simple.c mb-wm-theme-simple.h
+endif
+
+if THEME_PNG
+PNG_SRC = mb-wm-theme-png.c mb-wm-theme-png.h
+endif
+
+COMMON_SRC = mb-wm-theme.h mb-wm-theme.c mb-wm-theme-xml.h mb-wm-theme-xml.c
+
+pkgincludedir = $(includedir)/@MBWM2_INCDIR@/theme-engines
+
+if ENABLE_LIBMATCHBOX
+pkginclude_HEADERS = *.h
+noinst_LTLIBRARIES = libmb-theme.la
+libmb_theme_la_SOURCES = $(COMMON_SRC) $(CAIRO_SRC) $(SIMPLE_SRC) $(PNG_SRC)
+libmb_theme_la_CFLAGS =
+else
+noinst_LIBRARIES = libmb-theme.a
+libmb_theme_a_SOURCES = $(COMMON_SRC) $(CAIRO_SRC) $(SIMPLE_SRC) $(PNG_SRC)
+endif
+
+INCLUDES = @MBWM_INCS@ @MBWM_CFLAGS@ -DDATADIR=\"$(datadir)\"
+
+MAINTAINERCLEANFILES = config.h.in Makefile.in