summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/go-examples/go-helloworld_0.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/go-examples/go-helloworld_0.1.bb')
-rw-r--r--meta/recipes-extended/go-examples/go-helloworld_0.1.bb24
1 files changed, 15 insertions, 9 deletions
diff --git a/meta/recipes-extended/go-examples/go-helloworld_0.1.bb b/meta/recipes-extended/go-examples/go-helloworld_0.1.bb
index 930c57df95..222fc9d349 100644
--- a/meta/recipes-extended/go-examples/go-helloworld_0.1.bb
+++ b/meta/recipes-extended/go-examples/go-helloworld_0.1.bb
@@ -1,13 +1,19 @@
-require go-examples.inc
+DESCRIPTION = "This is a simple example recipe that cross-compiles a Go program."
+SECTION = "examples"
+HOMEPAGE = "https://golang.org/"
-SRC_URI += " \
- file://helloworld.go \
-"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
-do_compile() {
- go build helloworld.go
-}
+SRC_URI = "git://${GO_IMPORT}"
+SRCREV = "46695d81d1fae905a270fb7db8a4d11a334562fe"
+
+GO_IMPORT = "github.com/golang/example"
+GO_INSTALL = "${GO_IMPORT}/hello"
+
+inherit go
-do_install() {
- install -D -m 0755 ${S}/helloworld ${D}${bindir}/helloworld
+# This is just to make clear where this example is
+do_install_append() {
+ mv ${D}${bindir}/hello ${D}${bindir}/${BPN}
}