summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/go-examples/go-helloworld_0.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/go-examples/go-helloworld_0.1.bb')
-rw-r--r--meta/recipes-extended/go-examples/go-helloworld_0.1.bb13
1 files changed, 13 insertions, 0 deletions
diff --git a/meta/recipes-extended/go-examples/go-helloworld_0.1.bb b/meta/recipes-extended/go-examples/go-helloworld_0.1.bb
new file mode 100644
index 0000000000..930c57df95
--- /dev/null
+++ b/meta/recipes-extended/go-examples/go-helloworld_0.1.bb
@@ -0,0 +1,13 @@
+require go-examples.inc
+
+SRC_URI += " \
+ file://helloworld.go \
+"
+
+do_compile() {
+ go build helloworld.go
+}
+
+do_install() {
+ install -D -m 0755 ${S}/helloworld ${D}${bindir}/helloworld
+}