summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/rust/rust_1.55.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/rust/rust_1.55.0.bb')
-rw-r--r--meta/recipes-devtools/rust/rust_1.55.0.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta/recipes-devtools/rust/rust_1.55.0.bb b/meta/recipes-devtools/rust/rust_1.55.0.bb
new file mode 100644
index 0000000000..036fb43334
--- /dev/null
+++ b/meta/recipes-devtools/rust/rust_1.55.0.bb
@@ -0,0 +1,20 @@
+require rust-target.inc
+require rust-source.inc
+require rust-snapshot.inc
+
+INSANE_SKIP:${PN}:class-native = "already-stripped"
+
+do_compile () {
+ rust_runx build --stage 2
+}
+
+rust_do_install() {
+ rust_runx install
+}
+
+python () {
+ pn = d.getVar('PN')
+
+ if not pn.endswith("-native"):
+ raise bb.parse.SkipRecipe("Rust recipe doesn't work for target builds at this time. Fixes welcome.")
+}