aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/mklibs/mklibs-native_0.1.33.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/mklibs/mklibs-native_0.1.33.bb')
-rw-r--r--meta/recipes-devtools/mklibs/mklibs-native_0.1.33.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta/recipes-devtools/mklibs/mklibs-native_0.1.33.bb b/meta/recipes-devtools/mklibs/mklibs-native_0.1.33.bb
new file mode 100644
index 0000000000..d288c77afb
--- /dev/null
+++ b/meta/recipes-devtools/mklibs/mklibs-native_0.1.33.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "mklibs produces cut-down shared libraries that contain only the routines required by a particular set of executables."
+HOMEPAGE = "https://code.launchpad.net/mklibs"
+SECTION = "devel"
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://debian/copyright;md5=98d31037b13d896e33890738ef01af64"
+DEPENDS = "python-native"
+
+PR = "r0"
+
+SRC_URI = "http://ftp.de.debian.org/debian/pool/main/m/mklibs/${BPN}_${PV}.tar.gz \
+ file://ac_init_fix.patch\
+ file://fix_STT_GNU_IFUNC.patch\
+"
+
+SRC_URI[md5sum] = "a462d9b802164993d247c1193116d78b"
+SRC_URI[sha256sum] = "706aa22ec979bc54adaf9616d278cecc2f1e8cd5faa656269c9760e8669fcc1e"
+
+S = "${WORKDIR}/${BPN}"
+
+inherit autotools gettext native
+
+do_configure_prepend() {
+ sed "s+MKLIBS_VERSION+${PV}+" ${S}/configure.ac
+}