summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/automake/automake_1.11.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/automake/automake_1.11.2.bb')
-rw-r--r--meta/recipes-devtools/automake/automake_1.11.2.bb20
1 files changed, 17 insertions, 3 deletions
diff --git a/meta/recipes-devtools/automake/automake_1.11.2.bb b/meta/recipes-devtools/automake/automake_1.11.2.bb
index 4271336070..66589fe9af 100644
--- a/meta/recipes-devtools/automake/automake_1.11.2.bb
+++ b/meta/recipes-devtools/automake/automake_1.11.2.bb
@@ -34,19 +34,33 @@ PATHFIXPATCH = "file://path_prog_fixes.patch"
PATHFIXPATCH_virtclass-native = ""
PATHFIXPATCH_virtclass-nativesdk = ""
+PERLPATH = "${bindir}/perl"
+PERLPATH_virtclass-native = "/usr/bin/perl"
+PERLPATH_virtclass-nativesdk = "/usr/bin/perl"
+
SRC_URI += "${PATHFIXPATCH} \
file://prefer-cpio-over-pax-for-ustar-archives.patch \
file://python-libdir.patch \
file://automake_1.11.2_fix_for_pkglibexec_SCRIPTS.patch \
file://py-compile-compile-only-optimized-byte-code.patch"
-PR = "r2"
+PR = "r3"
SRC_URI[md5sum] = "18194e804d415767bae8f703c963d456"
SRC_URI[sha256sum] = "4f46d1f9380c8a3506280750f630e9fc915cb1a435b724be56b499d016368718"
do_install () {
- oe_runmake 'DESTDIR=${D}' install
- install -d ${D}${datadir}
+ oe_runmake 'DESTDIR=${D}' install
+ install -d ${D}${datadir}
+
+ # Some distros have both /bin/perl and /usr/bin/perl, but we set perl location
+ # for target as /usr/bin/perl, so fix it to /usr/bin/perl.
+ for i in aclocal aclocal-1.11 automake automake-1.11; do
+ if [ -f ${D}${bindir}/$i ]; then
+ sed -i -e '1s,#!.*perl,#! ${PERLPATH},' \
+ -e 's,exec .*/bin/perl \(.*\) exec .*/bin/perl \(.*\),exec ${PERLPATH} \1 exec ${PERLPATH} \2,' \
+ ${D}${bindir}/$i
+ fi
+ done
}
BBCLASSEXTEND = "native nativesdk"