summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2015-04-20 14:37:34 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-04-20 15:31:42 +0100
commitd098f7ed0543f491bf8d183aef265e1ab1d07266 (patch)
treee807d033a94de4f71438967be646643d2758f627
parent192a9e1031763943719b603acc52967525f67ebe (diff)
downloadpoky-d098f7ed0543f491bf8d183aef265e1ab1d07266.tar.gz
poky-d098f7ed0543f491bf8d183aef265e1ab1d07266.tar.bz2
poky-d098f7ed0543f491bf8d183aef265e1ab1d07266.zip
valgrind: enable building on 4.x kernel
(From OE-Core rev: 7351c03e3bd674fcad4cb805bba3f34ef20d7003) Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/valgrind/valgrind/enable.building.on.4.x.kernel.patch36
-rw-r--r--meta/recipes-devtools/valgrind/valgrind_3.9.0.bb1
2 files changed, 37 insertions, 0 deletions
diff --git a/meta/recipes-devtools/valgrind/valgrind/enable.building.on.4.x.kernel.patch b/meta/recipes-devtools/valgrind/valgrind/enable.building.on.4.x.kernel.patch
new file mode 100644
index 0000000000..a90fcc510c
--- /dev/null
+++ b/meta/recipes-devtools/valgrind/valgrind/enable.building.on.4.x.kernel.patch
@@ -0,0 +1,36 @@
+Enable building valgrind on host with 4.x kernel.
+
+For OpenEmbedded builds we should be checking something like
+OLDEST_KERNEL instead of `uname -r`, but this is good enough for now.
+
+Building on 4.x* currently fails with:
+ configure:5556: checking for the kernel version
+ configure:5579: result: unsupported (4.0.0-rc3-00111-gaffb817)
+ configure:5581: error: Valgrind works on kernels 2.4, 2.6
+
+Upstream-Status: Pending
+
+--- valgrind-3.9.0/configure.ac.orig 2015-03-13 19:17:01.247310868 +0100
++++ valgrind-3.9.0/configure.ac 2015-03-13 19:19:27.388316108 +0100
+@@ -276,9 +276,9 @@
+ kernel=`uname -r`
+
+ case "${kernel}" in
+- 2.6.*|3.*)
+- AC_MSG_RESULT([2.6.x/3.x family (${kernel})])
+- AC_DEFINE([KERNEL_2_6], 1, [Define to 1 if you're using Linux 2.6.x or Linux 3.x])
++ 2.6.*|3.*|4.*)
++ AC_MSG_RESULT([2.6.x/3.x/4.x family (${kernel})])
++ AC_DEFINE([KERNEL_2_6], 1, [Define to 1 if you're using Linux 2.6.x or Linux 3.x or Linux 4.x])
+ ;;
+
+ 2.4.*)
+@@ -288,7 +288,7 @@
+
+ *)
+ AC_MSG_RESULT([unsupported (${kernel})])
+- AC_MSG_ERROR([Valgrind works on kernels 2.4, 2.6])
++ AC_MSG_ERROR([Valgrind works on kernels 2.4, 2.6, 3.x, 4.x])
+ ;;
+ esac
+
diff --git a/meta/recipes-devtools/valgrind/valgrind_3.9.0.bb b/meta/recipes-devtools/valgrind/valgrind_3.9.0.bb
index eea81a2405..9e1ab5f201 100644
--- a/meta/recipes-devtools/valgrind/valgrind_3.9.0.bb
+++ b/meta/recipes-devtools/valgrind/valgrind_3.9.0.bb
@@ -19,6 +19,7 @@ SRC_URI = "http://www.valgrind.org/downloads/valgrind-${PV}.tar.bz2 \
file://force-nostabs.patch \
file://remove-arm-variant-specific.patch \
file://remove-ppc-tests-failing-build.patch \
+ file://enable.building.on.4.x.kernel.patch \
file://add-ptest.patch \
file://pass-maltivec-only-if-it-supported.patch \
file://run-ptest \