summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openedhand.com>2008-01-07 13:38:33 +0000
committerMarcin Juszkiewicz <hrw@openedhand.com>2008-01-07 13:38:33 +0000
commitd40c8607627bb683a3a49005749934e7d241ca6b (patch)
tree9d0f26962b71d39442c60910f7220828f1600c0f
parent3e7f85e3b3c86776f0d1db3b7683fa2bfac582bf (diff)
downloadpoky-d40c8607627bb683a3a49005749934e7d241ca6b.tar.gz
poky-d40c8607627bb683a3a49005749934e7d241ca6b.tar.bz2
poky-d40c8607627bb683a3a49005749934e7d241ca6b.zip
binutils: fix 'makeinfo >= 4.10 is too old' problem (from OE) - patch is applied upstream (Poky trunk r3199)
git-svn-id: https://svn.o-hand.com/repos/poky/branches/blinky@3416 311d38ba-8fff-0310-9ca6-ca027cbcb966
-rw-r--r--meta/packages/binutils/binutils-2.17.50.0.5/binutils-configure-texinfo-version.patch22
-rw-r--r--meta/packages/binutils/binutils_2.17.50.0.5.bb3
2 files changed, 24 insertions, 1 deletions
diff --git a/meta/packages/binutils/binutils-2.17.50.0.5/binutils-configure-texinfo-version.patch b/meta/packages/binutils/binutils-2.17.50.0.5/binutils-configure-texinfo-version.patch
new file mode 100644
index 0000000000..9cc18412fd
--- /dev/null
+++ b/meta/packages/binutils/binutils-2.17.50.0.5/binutils-configure-texinfo-version.patch
@@ -0,0 +1,22 @@
+--- binutils-2.18/configure.orig 2007-10-11 21:09:27.000000000 -0700
++++ binutils-2.18/configure 2007-10-11 21:10:20.000000000 -0700
+@@ -6128,7 +6128,7 @@ case " $build_configdirs " in
+ # For an installed makeinfo, we require it to be from texinfo 4.4 or
+ # higher, else we use the "missing" dummy.
+ if ${MAKEINFO} --version \
+- | egrep 'texinfo[^0-9]*([1-3][0-9]|4\.[4-9]|[5-9])' >/dev/null 2>&1; then
++ | egrep 'texinfo[^0-9]*(4\.([6-9]|[1-9][0-9])|[5-9]|[1-9][0-9])' >/dev/null 2>&1; then
+ :
+ else
+ MAKEINFO="$MISSING makeinfo"
+--- binutils-2.18/configure.in.orig 2007-10-11 21:10:54.000000000 -0700
++++ binutils-2.18/configure.in 2007-10-11 21:11:13.000000000 -0700
+@@ -2403,7 +2403,7 @@ changequote(,)
+ # For an installed makeinfo, we require it to be from texinfo 4.4 or
+ # higher, else we use the "missing" dummy.
+ if ${MAKEINFO} --version \
+- | egrep 'texinfo[^0-9]*([1-3][0-9]|4\.[4-9]|[5-9])' >/dev/null 2>&1; then
++ | egrep 'texinfo[^0-9]*(4\.([6-9]|[1-9][0-9])|[5-9]|[1-9][0-9])' >/dev/null 2>&1; then
+ :
+ else
+ MAKEINFO="$MISSING makeinfo"
diff --git a/meta/packages/binutils/binutils_2.17.50.0.5.bb b/meta/packages/binutils/binutils_2.17.50.0.5.bb
index 63147755bc..91c79c54a8 100644
--- a/meta/packages/binutils/binutils_2.17.50.0.5.bb
+++ b/meta/packages/binutils/binutils_2.17.50.0.5.bb
@@ -1,10 +1,11 @@
require binutils.inc
-PR = "r1"
+PR = "r2"
SRC_URI = "\
http://www.kernel.org/pub/linux/devel/binutils/binutils-${PV}.tar.bz2 \
file://binutils-2.16.91.0.6-objcopy-rename-errorcode.patch;patch=1 \
+ file://binutils-configure-texinfo-version.patch;patch=1 \
file://binutils-uclibc-100-uclibc-conf.patch;patch=1 \
file://110-arm-eabi-conf.patch;patch=1 \
file://binutils-uclibc-300-001_ld_makefile_patch.patch;patch=1 \