summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2012-03-28 17:01:43 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-03-28 18:40:40 +0100
commit4d9f4d6ac25f39fe6d5491d05c7a26195bab648b (patch)
treebb80692d08a2306281208940d59ef4e012d6d278
parent016cf3fc0b34844d1a3bb1745366b5870ad1aa1c (diff)
downloadpoky-1.2_M4.rc1.zip
poky-1.2_M4.rc1.tar.gz
poky-1.2_M4.rc1.tar.bz2
rpm: Ensure we depend on file1.2_M4.rc41.2_M4.rc1
rpm links to libmagic from file so it needs to be listed in DEPENDS else we can have race conditions causing build failures such as those seen on the autobuilder recently. (From OE-Core rev: 432e36300d7231c9b01cd2c6c4b39b84cf4fddca) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/rpm/rpm_5.4.0.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-devtools/rpm/rpm_5.4.0.bb b/meta/recipes-devtools/rpm/rpm_5.4.0.bb
index 8f2c5e1..4576f67 100644
--- a/meta/recipes-devtools/rpm/rpm_5.4.0.bb
+++ b/meta/recipes-devtools/rpm/rpm_5.4.0.bb
@@ -43,7 +43,7 @@ LICENSE = "LGPLv2.1"
LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=2d5025d4aa3495befef8f17206a5b0a1"
DEPENDS = "bzip2 zlib db openssl elfutils expat libpcre attr acl popt ${extrarpmdeps}"
-extrarpmdeps = "python perl"
+extrarpmdeps = "python perl file"
extrarpmdeps_virtclass-native = "file-native"
PR = "r35"