aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-kernel/zephyr-kernel/zephyr-helloworld.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/zephyr-kernel/zephyr-helloworld.bb')
-rw-r--r--recipes-kernel/zephyr-kernel/zephyr-helloworld.bb15
1 files changed, 8 insertions, 7 deletions
diff --git a/recipes-kernel/zephyr-kernel/zephyr-helloworld.bb b/recipes-kernel/zephyr-kernel/zephyr-helloworld.bb
index 8900bfd..7c0823c 100644
--- a/recipes-kernel/zephyr-kernel/zephyr-helloworld.bb
+++ b/recipes-kernel/zephyr-kernel/zephyr-helloworld.bb
@@ -1,18 +1,19 @@
require zephyr-kernel.inc
require zephyr-kernel-common.inc
-inherit deploy
+inherit cmake pkgconfig deploy
ZEPHYR_SRC_DIR = "${S}/samples/hello_world"
ZEPHYR_BASE = "${S}"
+OECMAKE_SOURCEPATH = "${ZEPHYR_SRC_DIR}"
-do_compile () {
- cd ${ZEPHYR_SRC_DIR}
- oe_runmake ${ZEPHYR_MAKE_ARGS}
-}
+DEPENDS += "gperf-native"
+
+EXTRA_OECMAKE = " -DZEPHYR_BASE=${S} -DZEPHYR_GCC_VARIANT=yocto -DBOARD=${BOARD} -DARCH=${ARCH} -DCROSS_COMPILE=${CROSS_COMPILE} -DZEPHYR_SYSROOT=${ZEPHYR_SYSROOT} -DZEPHYR_TOOLCHAIN_VARIANT=yocto"
+export ZEPHYR_BASE="${S}"
do_deploy () {
- install -D samples/hello_world/outdir/${BOARD}/zephyr.elf ${DEPLOYDIR}/${PN}.elf
- install -D samples/hello_world/outdir/${BOARD}/zephyr.bin ${DEPLOYDIR}/${PN}.bin
+ install -D ${B}/zephyr/zephyr.elf ${DEPLOYDIR}/${PN}.elf
}
addtask deploy after do_compile
+do_install[noexec] = "1"