aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-kernel/zephyr-kernel/zephyr-hci-uart.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/zephyr-kernel/zephyr-hci-uart.bb')
-rw-r--r--recipes-kernel/zephyr-kernel/zephyr-hci-uart.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/recipes-kernel/zephyr-kernel/zephyr-hci-uart.bb b/recipes-kernel/zephyr-kernel/zephyr-hci-uart.bb
new file mode 100644
index 0000000..b70542a
--- /dev/null
+++ b/recipes-kernel/zephyr-kernel/zephyr-hci-uart.bb
@@ -0,0 +1,20 @@
+require zephyr-kernel.inc
+require zephyr-kernel-common.inc
+inherit deploy
+
+COMPATIBLE_MACHINE = "(arduino-101-ble)"
+
+ZEPHYR_SRC_DIR = "${S}/samples/bluetooth/hci_uart"
+ZEPHYR_BASE = "${S}"
+
+do_compile () {
+ cd ${ZEPHYR_SRC_DIR}
+ oe_runmake ${ZEPHYR_MAKE_ARGS}
+}
+
+do_deploy () {
+ install -D samples/bluetooth/hci_uart/outdir/${BOARD}/zephyr.elf ${DEPLOYDIR}/${PN}.elf
+ install -D samples/bluetooth/hci_uart/outdir/${BOARD}/zephyr.bin ${DEPLOYDIR}/${PN}.bin
+}
+
+addtask deploy after do_compile