aboutsummaryrefslogtreecommitdiffstats
path: root/meta-zephyr-bsp/conf/layer.conf
diff options
context:
space:
mode:
Diffstat (limited to 'meta-zephyr-bsp/conf/layer.conf')
-rw-r--r--meta-zephyr-bsp/conf/layer.conf20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta-zephyr-bsp/conf/layer.conf b/meta-zephyr-bsp/conf/layer.conf
new file mode 100644
index 0000000..d5d478c
--- /dev/null
+++ b/meta-zephyr-bsp/conf/layer.conf
@@ -0,0 +1,20 @@
+# We have a conf and classes directory, add to BBPATH
+BBPATH .= ":${LAYERDIR}"
+
+# We have recipes-* directories, add to BBFILES
+BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
+ ${LAYERDIR}/recipes-*/*/*.bbappend"
+
+BBFILE_COLLECTIONS += "zephyrbsp"
+BBFILE_PATTERN_zephyrbsp = "^${LAYERDIR}/"
+BBFILE_PRIORITY_zephyrbsp = "6"
+
+# This should only be incremented on significant changes that will
+# cause compatibility issues with other layers
+LAYERVERSION_zephyrbsp = "1"
+
+LAYERDEPENDS_zephyrbsp = "zephyrcore core meta-python"
+
+LAYERSERIES_COMPAT_zephyrbsp = "dunfell gatesgarth hardknott honister"
+
+X86_TUNE_DIR = "${@bb.utils.contains('LAYERSERIES_CORENAMES', 'honister', 'include/x86', 'include', d)}"