aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-kernel/zephyr-kernel/zephyr-openthread-echo-client.bb13
1 files changed, 13 insertions, 0 deletions
diff --git a/recipes-kernel/zephyr-kernel/zephyr-openthread-echo-client.bb b/recipes-kernel/zephyr-kernel/zephyr-openthread-echo-client.bb
new file mode 100644
index 0000000..49f5565
--- /dev/null
+++ b/recipes-kernel/zephyr-kernel/zephyr-openthread-echo-client.bb
@@ -0,0 +1,13 @@
+include zephyr-sample.inc
+
+ZEPHYR_SRC_DIR = "${S}/samples/net/sockets/echo_client"
+
+ZEPHYR_MODULES_append = "\;${S}/modules/lib/mbedtls"
+ZEPHYR_MODULES_append = "\;${S}/modules/lib/openthread"
+
+EXTRA_OECMAKE += "-DOVERLAY_CONFIG=overlay-ot.conf"
+
+# The overlay config and OpenThread itself imposes some specific requirements
+# towards the boards (e.g. flash layout and ieee802154 radio) so we need to
+# limit to known working machines here.
+COMPATIBLE_MACHINE = "(arduino-nano-33-ble)"