aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-zephyr-core/recipes-kernel/zephyr-kernel/files/0001-cmake-added-missing-file-ext-to.patch42
-rw-r--r--meta-zephyr-core/recipes-kernel/zephyr-kernel/files/arduino-nano-33-ble-storage-partition.patch49
2 files changed, 0 insertions, 91 deletions
diff --git a/meta-zephyr-core/recipes-kernel/zephyr-kernel/files/0001-cmake-added-missing-file-ext-to.patch b/meta-zephyr-core/recipes-kernel/zephyr-kernel/files/0001-cmake-added-missing-file-ext-to.patch
deleted file mode 100644
index 6aeca14..0000000
--- a/meta-zephyr-core/recipes-kernel/zephyr-kernel/files/0001-cmake-added-missing-file-ext-to.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-From 783c1f78c8e39751fe89d0883c8bce7336f55e94 Mon Sep 17 00:00:00 2001
-From: Torsten Rasmussen <Torsten.Rasmussen@nordicsemi.no>
-Date: Thu, 19 Aug 2021 08:53:00 +0200
-Subject: [PATCH] cmake: added missing file ext to
- lv_font_dejavu_16_persian_hebrew.c
-
-CMake >= 3.20 requires file extensions explicitly added to source files.
-
-See CMP0115:
-> Starting in CMake 3.20, CMake prefers all source files to have their
-> extensions explicitly listed:
-
-In the CMakeLists.txt, the file lv_font_dejavu_16_persian_hebrew.c
-was added without its .c extension, causing never CMakes ti fail
-discovering the file.
-
-This has been fixed by correctly add the file as:
-lv_font_dejavu_16_persian_hebrew.c
-
-Signed-off-by: Torsten Rasmussen <Torsten.Rasmussen@nordicsemi.no>
----
-Upstream-status: Accepted
-
- CMakeLists.txt | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 57b07c84..0f433edc 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -58,7 +58,7 @@ zephyr_library_sources(
- src/lv_misc/lv_utils.c
-
- src/lv_font/lv_font.c
-- src/lv_font/lv_font_dejavu_16_persian_hebrew
-+ src/lv_font/lv_font_dejavu_16_persian_hebrew.c
- src/lv_font/lv_font_fmt_txt.c
- src/lv_font/lv_font_loader.c
- src/lv_font/lv_font_montserrat_12.c
---
-Gitee
-
diff --git a/meta-zephyr-core/recipes-kernel/zephyr-kernel/files/arduino-nano-33-ble-storage-partition.patch b/meta-zephyr-core/recipes-kernel/zephyr-kernel/files/arduino-nano-33-ble-storage-partition.patch
deleted file mode 100644
index 4568a41..0000000
--- a/meta-zephyr-core/recipes-kernel/zephyr-kernel/files/arduino-nano-33-ble-storage-partition.patch
+++ /dev/null
@@ -1,49 +0,0 @@
-commit 6c9945aafa00c09149e2052a9c2bccad16dd1d8a
-Author: Stefan Schmidt <stefan.schmidt@huawei.com>
-Date: Fri May 7 11:47:44 2021 +0200
-
- boards/arduino_nano_33_ble: add storage partition at end of flash
-
- Change default partition table to allow for application which need
- storage. One use case is running the OpenThread integration which has
- a dependency on this.
-
- Upstream-Status: Backported [https://github.com/zephyrproject-rtos/zephyr/commit/6c9945aafa00c09149e2052a9c2bccad16dd1d8a]
-
- Signed-off-by: Stefan Schmidt <stefan.schmidt@huawei.com>
- Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com>
-
-diff --git a/boards/arm/arduino_nano_33_ble/arduino_nano_33_ble.dts b/boards/arm/arduino_nano_33_ble/arduino_nano_33_ble.dts
-index d09b66ec43..d11d800eb5 100644
---- a/boards/arm/arduino_nano_33_ble/arduino_nano_33_ble.dts
-+++ b/boards/arm/arduino_nano_33_ble/arduino_nano_33_ble.dts
-@@ -44,15 +44,27 @@
-
- boot_partition: partition@0 {
- label = "sam-ba";
-- reg = <0x0 0x10000>;
-+ reg = <0x00000000 0x00010000>;
- read-only;
- };
-
- code_partition: partition@10000 {
- label = "code";
-- reg = <0x10000 0xf0000>;
-+ reg = <0x00010000 0x000e8000>;
- read-only;
- };
-+
-+ /*
-+ * The flash starting at 0x000f8000 and ending at
-+ * 0x000fffff is reserved for use by the application.
-+ *
-+ * Storage partition will be used by FCB/LittleFS/NVS
-+ * if enabled.
-+ */
-+ storage_partition: partition@f8000 {
-+ label = "storage";
-+ reg = <0x000f8000 0x00008000>;
-+ };
- };
- };
-