aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-kernel/zephyr-kernel/zephyr-peripheral-esp.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes-kernel/zephyr-kernel/zephyr-peripheral-esp.bb b/recipes-kernel/zephyr-kernel/zephyr-peripheral-esp.bb
new file mode 100644
index 0000000..2ffe5ae
--- /dev/null
+++ b/recipes-kernel/zephyr-kernel/zephyr-peripheral-esp.bb
@@ -0,0 +1,19 @@
+require zephyr-kernel.inc
+require zephyr-kernel-common.inc
+inherit deploy
+
+ZEPHYR_SAMPLE_NAME="samples/bluetooth/peripheral_esp"
+ZEPHYR_SRC_DIR = "${S}/${ZEPHYR_SAMPLE_NAME}"
+ZEPHYR_BASE = "${S}"
+
+do_compile () {
+ cd ${ZEPHYR_SRC_DIR}
+ oe_runmake ${ZEPHYR_MAKE_ARGS}
+}
+
+do_deploy () {
+ install -D ${ZEPHYR_SAMPLE_NAME}/outdir/${BOARD}/zephyr.elf ${DEPLOYDIR}/${PN}.elf
+ install -D ${ZEPHYR_SAMPLE_NAME}/outdir/${BOARD}/zephyr.bin ${DEPLOYDIR}/${PN}.bin
+}
+
+addtask deploy after do_compile