aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-bsp/u-boot/u-boot-xlnx_2015.04.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/u-boot/u-boot-xlnx_2015.04.bb')
-rw-r--r--recipes-bsp/u-boot/u-boot-xlnx_2015.04.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot/u-boot-xlnx_2015.04.bb b/recipes-bsp/u-boot/u-boot-xlnx_2015.04.bb
new file mode 100644
index 00000000..fd28fbee
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot-xlnx_2015.04.bb
@@ -0,0 +1,17 @@
+include u-boot-xlnx.inc
+include u-boot-xlnx-2015.04.inc
+include u-boot-extra.inc
+
+UBOOT_ENV_zc702-zynq7 = "uEnv"
+UBOOT_ENV_zedboard-zynq7 = "uEnv"
+
+SRC_URI_append_zc702-zynq7 += "file://uEnv.txt"
+SRC_URI_append_zedboard-zynq7 += "file://uEnv.txt"
+
+do_compile_append() {
+ # link u-boot-dtb.img to u-boot.img.
+ if [ ! -e ${B}/u-boot-dtb.img ]; then
+ ln -sf u-boot.img ${B}/u-boot-dtb.img
+ fi
+}
+