aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-graphics/xorg-xserver/xserver-xf86-config/zynqmp/xorg.conf27
-rw-r--r--recipes-graphics/xorg-xserver/xserver-xf86-config_%.bbappend1
2 files changed, 28 insertions, 0 deletions
diff --git a/recipes-graphics/xorg-xserver/xserver-xf86-config/zynqmp/xorg.conf b/recipes-graphics/xorg-xserver/xserver-xf86-config/zynqmp/xorg.conf
new file mode 100644
index 00000000..9ef39462
--- /dev/null
+++ b/recipes-graphics/xorg-xserver/xserver-xf86-config/zynqmp/xorg.conf
@@ -0,0 +1,27 @@
+Section "InputDevice"
+ Identifier "System Mouse"
+ Driver "mouse"
+ Option "Device" "/dev/input/mouse0"
+EndSection
+
+Section "InputDevice"
+ Identifier "System Keyboard"
+ Driver "kbd"
+ Option "Device" "/dev/input/event0"
+EndSection
+
+Section "Device"
+ Identifier "ZynqMP"
+ Driver "armsoc"
+ Option "DRI2" "true"
+ Option "DRI2_PAGE_FLIP" "false"
+ Option "DRI2_WAIT_VSYNC" "true"
+ Option "SWcursorLCD" "false"
+ Option "DEBUG" "false"
+EndSection
+
+Section "Screen"
+ Identifier "DefaultScreen"
+ Device "ZynqMP"
+ DefaultDepth 16
+EndSection
diff --git a/recipes-graphics/xorg-xserver/xserver-xf86-config_%.bbappend b/recipes-graphics/xorg-xserver/xserver-xf86-config_%.bbappend
new file mode 100644
index 00000000..72d991c7
--- /dev/null
+++ b/recipes-graphics/xorg-xserver/xserver-xf86-config_%.bbappend
@@ -0,0 +1 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"