aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-kernel/linux/linux-xlnx-dev.bb1
-rw-r--r--recipes-kernel/linux/linux-xlnx.inc8
-rw-r--r--recipes-kernel/linux/linux-xlnx_3.14.bb1
-rw-r--r--recipes-kernel/linux/linux-xlnx_3.19.bb1
4 files changed, 6 insertions, 5 deletions
diff --git a/recipes-kernel/linux/linux-xlnx-dev.bb b/recipes-kernel/linux/linux-xlnx-dev.bb
index c729ee90..a1584640 100644
--- a/recipes-kernel/linux/linux-xlnx-dev.bb
+++ b/recipes-kernel/linux/linux-xlnx-dev.bb
@@ -4,6 +4,7 @@
# To enable this recipe, set PREFERRED_PROVIDER_virtual/kernel = "linux-xlnx-dev"
KBRANCH ?= "master"
+SRCBRANCH = "${KBRANCH}"
# Use the SRCREV for the last tagged revision of linux-xlnx.
SRCREV ?= '${@oe.utils.conditional("PREFERRED_PROVIDER_virtual/kernel", "linux-xlnx-dev", "${AUTOREV}", "3821a7bfdf7a4c697cac62f0157d8bf49467ea67", d)}'
diff --git a/recipes-kernel/linux/linux-xlnx.inc b/recipes-kernel/linux/linux-xlnx.inc
index b0a9c6b7..60dbacf4 100644
--- a/recipes-kernel/linux/linux-xlnx.inc
+++ b/recipes-kernel/linux/linux-xlnx.inc
@@ -3,11 +3,13 @@
LINUX_VERSION_EXTENSION ?= "-xilinx"
PV = "${LINUX_VERSION}${LINUX_VERSION_EXTENSION}+git${SRCPV}"
-# Sources
-KBRANCH ?= "master"
+# Sources, by default allow for the use of SRCREV pointing to orphaned tags/commits
+SRCBRANCH ?= ""
+SRCBRANCHARG = "${@['nobranch=1', 'branch=${SRCBRANCH}'][d.getVar('SRCBRANCH', True) != '']}"
+
FILESEXTRAPATHS_prepend := "${THISDIR}/linux-xlnx:"
SRC_URI = " \
- git://github.com/Xilinx/linux-xlnx.git;protocol=https;branch=${KBRANCH} \
+ git://github.com/Xilinx/linux-xlnx.git;protocol=https;${SRCBRANCHARG} \
file://xilinx-base;type=kmeta;destsuffix=xilinx-base \
"
diff --git a/recipes-kernel/linux/linux-xlnx_3.14.bb b/recipes-kernel/linux/linux-xlnx_3.14.bb
index 71827067..e6d96ed9 100644
--- a/recipes-kernel/linux/linux-xlnx_3.14.bb
+++ b/recipes-kernel/linux/linux-xlnx_3.14.bb
@@ -1,6 +1,5 @@
# Kernel version and SRCREV correspond to: xlnx_3.14 branch
LINUX_VERSION = "3.14"
-KBRANCH ?= "xlnx_3.14"
SRCREV ?= "2b48a8aeea7367359f9eebe55c4a09a05227f32b"
include linux-xlnx.inc
diff --git a/recipes-kernel/linux/linux-xlnx_3.19.bb b/recipes-kernel/linux/linux-xlnx_3.19.bb
index 24b10c0b..4f92a394 100644
--- a/recipes-kernel/linux/linux-xlnx_3.19.bb
+++ b/recipes-kernel/linux/linux-xlnx_3.19.bb
@@ -1,5 +1,4 @@
LINUX_VERSION = "3.19"
-KBRANCH ?= "master"
# This points at the 'xilinx-v2015.2' tag
SRCREV ?= "3f30b3337af61f1ed98f7185e37c6bf9202b3204"