aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-bsp/u-boot/u-boot-extra.inc2
1 files changed, 1 insertions, 1 deletions
diff --git a/recipes-bsp/u-boot/u-boot-extra.inc b/recipes-bsp/u-boot/u-boot-extra.inc
index 4301bb46..d5f5819a 100644
--- a/recipes-bsp/u-boot/u-boot-extra.inc
+++ b/recipes-bsp/u-boot/u-boot-extra.inc
@@ -18,7 +18,7 @@ python do_configmk_generate () {
machine_xparameters = d.getVar("UBOOT_XPARAMETERS", True)
- if d.getVar("SOC_FAMILY") == "microblaze" and machine_xparameters and os.path.exists(machine_xparameters):
+ if machine_xparameters and os.path.exists(machine_xparameters):
boardpath = os.path.join("board", "xilinx", "microblaze-generic")
configmk = os.path.join(d.getVar("S", True), boardpath, "config.mk")
xparameters = os.path.join(d.getVar("S", True), boardpath, "xparameters.h")