aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-bsp/u-boot/u-boot-xlnx-dev.bb16
1 files changed, 12 insertions, 4 deletions
diff --git a/recipes-bsp/u-boot/u-boot-xlnx-dev.bb b/recipes-bsp/u-boot/u-boot-xlnx-dev.bb
index 717a1d5c..411663d1 100644
--- a/recipes-bsp/u-boot/u-boot-xlnx-dev.bb
+++ b/recipes-bsp/u-boot/u-boot-xlnx-dev.bb
@@ -3,21 +3,29 @@
#
# To enable this recipe, set the following in your machine or local.conf
# PREFERRED_PROVIDER_virtual/bootloader ?= "u-boot-xlnx-dev"
-# PREFERRED_PROVIDER_u-boot ?= "u-boot-xlnx-dev"
-UBRANCH ?= "master-next"
+UBRANCH ?= "master"
include u-boot-xlnx.inc
include u-boot-elf.inc
include u-boot-extra.inc
+DEPENDS += "openssl-native"
+EXTRA_OEMAKE_append += 'HOSTCC="${BUILD_CC}" HOSTCFLAGS="${BUILD_CFLAGS}" HOSTLD="${BUILD_LD}" HOSTLDFLAGS="${BUILD_LDFLAGS}"'
+
LIC_FILES_CHKSUM = "file://README;beginline=1;endline=6;md5=157ab8408beab40cd8ce1dc69f702a6c"
-SRCREV="67f6167a0f808ca7051a337858e0db237ce2b972"
+SRCREV = "c0dc1a884dc3509fa3e12235c099f1e4edc24431"
python () {
d.setVar("SRCREV", "${AUTOREV}")
}
-PR = "r0"
PV = "${UBRANCH}${XILINX_EXTENSION}+git"
+
+do_compile_append() {
+ # link u-boot-dtb.img to u-boot.img.
+ if [ ! -e ${B}/u-boot-dtb.img ]; then
+ ln -sf u-boot.img ${B}/u-boot-dtb.img
+ fi
+}