aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-xilinx-standalone/recipes-bsp/embeddedsw/embeddedsw.inc26
-rw-r--r--meta-xilinx-standalone/recipes-bsp/embeddedsw/plm-firmware.inc (renamed from meta-xilinx-standalone/recipes-standalone/plm-firmware/plm-firmware_2019.2.bb)10
-rw-r--r--meta-xilinx-standalone/recipes-bsp/embeddedsw/plm-firmware_2019.2.bb1
-rw-r--r--meta-xilinx-standalone/recipes-bsp/embeddedsw/plm-firmware_2020.1.bb1
-rw-r--r--meta-xilinx-standalone/recipes-bsp/embeddedsw/plm-firmware_2020.2.bb3
-rw-r--r--meta-xilinx-standalone/recipes-bsp/embeddedsw/pmu-firmware.inc (renamed from meta-xilinx-standalone/recipes-standalone/pmu-firmware/pmu-firmware_2019.2.bb)11
-rw-r--r--meta-xilinx-standalone/recipes-bsp/embeddedsw/pmu-firmware/fix-zynqmp-assert.patch (renamed from meta-xilinx-standalone/recipes-standalone/pmu-firmware/pmu-firmware/fix-zynqmp-assert.patch)0
-rw-r--r--meta-xilinx-standalone/recipes-bsp/embeddedsw/pmu-firmware_2019.2.bb1
-rw-r--r--meta-xilinx-standalone/recipes-bsp/embeddedsw/pmu-firmware_2020.1.bb1
-rw-r--r--meta-xilinx-standalone/recipes-bsp/embeddedsw/pmu-firmware_2020.2.bb3
-rw-r--r--meta-xilinx-standalone/recipes-bsp/embeddedsw/psm-firmware.inc (renamed from meta-xilinx-standalone/recipes-standalone/psm-firmware/psm-firmware_2019.2.bb)10
-rw-r--r--meta-xilinx-standalone/recipes-bsp/embeddedsw/psm-firmware_2019.2.bb1
-rw-r--r--meta-xilinx-standalone/recipes-bsp/embeddedsw/psm-firmware_2020.1.bb1
-rw-r--r--meta-xilinx-standalone/recipes-bsp/embeddedsw/psm-firmware_2020.2.bb3
14 files changed, 48 insertions, 24 deletions
diff --git a/meta-xilinx-standalone/recipes-bsp/embeddedsw/embeddedsw.inc b/meta-xilinx-standalone/recipes-bsp/embeddedsw/embeddedsw.inc
new file mode 100644
index 00000000..79c1a5f4
--- /dev/null
+++ b/meta-xilinx-standalone/recipes-bsp/embeddedsw/embeddedsw.inc
@@ -0,0 +1,26 @@
+# Automatically determnine the version from the bb file
+SRC_VER ?= "${@bb.parse.vars_from_file(d.getVar('FILE', False),d)[1] or 'master'}"
+
+LICENSE = "Proprietary"
+LIC_FILES_CHKSUM[2019.1] = 'e9b6d01d45faccfbf05d8caea53f0a35'
+LIC_FILES_CHKSUM[2019.2] = '39ab6ab638f4d1836ba994ec6852de94'
+LIC_FILES_CHKSUM[2020.1] = '8b565227e1264d677db8f841c2948cba'
+LIC_FILES_CHKSUM[2020.2] = '3a6e22aebf6516f0f74a82e1183f74f8'
+LIC_FILES_CHKSUM[master] = '3a6e22aebf6516f0f74a82e1183f74f8'
+LIC_FILES_CHKSUM = "file://license.txt;md5=${@d.getVarFlag('LIC_FILES_CHKSUM', d.getVar('SRC_VER')) or '0'}"
+
+SRCREV[2019.1] = "26c14d9861010a0e3a55c73fb79efdb816eb42ca"
+SRCREV[2019.2] = "e8db5fb118229fdc621e0ec7848641a23bf60998"
+SRCREV[2020.1] = "338150ab3628a1ea6b06e964b16e712b131882dd"
+SRCREV[2020.2] = "2516d5ed8161e16c2813b0e8e4ceac693f23de5c"
+SRCREV ?= "${@d.getVarFlag('SRCREV', d.getVar('SRC_VER')) or '${AUTOREV}'}"
+
+PV = "${SRC_VER}+git${SRCPV}"
+
+SRC_BRANCH[2019.1] = "release-2019.1"
+SRC_BRANCH[2019.2] = "release-2019.2"
+SRC_BRANCH[2020.1] = "release-2020.1"
+SRC_BRANCH[2020.2] = "master-rel-2020.2"
+SRC_BRANCH ?= "${@d.getVarFlag('SRC_BRANCH', d.getVar('SRC_VER')) or '${SRC_VER}'}"
+
+SRC_URI = "git://github.com/Xilinx/embeddedsw.git;protocol=https;branch=${SRC_BRANCH}"
diff --git a/meta-xilinx-standalone/recipes-standalone/plm-firmware/plm-firmware_2019.2.bb b/meta-xilinx-standalone/recipes-bsp/embeddedsw/plm-firmware.inc
index 2c28a1f4..5a77e3de 100644
--- a/meta-xilinx-standalone/recipes-standalone/plm-firmware/plm-firmware_2019.2.bb
+++ b/meta-xilinx-standalone/recipes-bsp/embeddedsw/plm-firmware.inc
@@ -1,12 +1,6 @@
-inherit deploy
-
-LICENSE = "Proprietary"
-LIC_FILES_CHKSUM = "file://license.txt;md5=39ab6ab638f4d1836ba994ec6852de94"
+require embeddedsw.inc
-SRCREV = "e8db5fb118229fdc621e0ec7848641a23bf60998"
-PV = "2019.2+git${SRCPV}"
-
-SRC_URI = "git://github.com/Xilinx/embeddedsw.git;protocol=https;nobranch=1"
+inherit deploy
COMPATIBLE_HOST = "microblaze.*-elf"
COMPATIBLE_MACHINE = "versal-mb"
diff --git a/meta-xilinx-standalone/recipes-bsp/embeddedsw/plm-firmware_2019.2.bb b/meta-xilinx-standalone/recipes-bsp/embeddedsw/plm-firmware_2019.2.bb
new file mode 100644
index 00000000..782c9dc4
--- /dev/null
+++ b/meta-xilinx-standalone/recipes-bsp/embeddedsw/plm-firmware_2019.2.bb
@@ -0,0 +1 @@
+require plm-firmware.inc
diff --git a/meta-xilinx-standalone/recipes-bsp/embeddedsw/plm-firmware_2020.1.bb b/meta-xilinx-standalone/recipes-bsp/embeddedsw/plm-firmware_2020.1.bb
new file mode 100644
index 00000000..782c9dc4
--- /dev/null
+++ b/meta-xilinx-standalone/recipes-bsp/embeddedsw/plm-firmware_2020.1.bb
@@ -0,0 +1 @@
+require plm-firmware.inc
diff --git a/meta-xilinx-standalone/recipes-bsp/embeddedsw/plm-firmware_2020.2.bb b/meta-xilinx-standalone/recipes-bsp/embeddedsw/plm-firmware_2020.2.bb
new file mode 100644
index 00000000..69455dfa
--- /dev/null
+++ b/meta-xilinx-standalone/recipes-bsp/embeddedsw/plm-firmware_2020.2.bb
@@ -0,0 +1,3 @@
+require plm-firmware.inc
+
+DEFAULT_PREFERENCE = "-1"
diff --git a/meta-xilinx-standalone/recipes-standalone/pmu-firmware/pmu-firmware_2019.2.bb b/meta-xilinx-standalone/recipes-bsp/embeddedsw/pmu-firmware.inc
index 7ecf64e5..584809da 100644
--- a/meta-xilinx-standalone/recipes-standalone/pmu-firmware/pmu-firmware_2019.2.bb
+++ b/meta-xilinx-standalone/recipes-bsp/embeddedsw/pmu-firmware.inc
@@ -1,13 +1,8 @@
-inherit deploy
-
-LICENSE = "Proprietary"
-LIC_FILES_CHKSUM = "file://license.txt;md5=39ab6ab638f4d1836ba994ec6852de94"
+require embeddedsw.inc
-SRCREV = "e8db5fb118229fdc621e0ec7848641a23bf60998"
-PV = "2019.2+git${SRCPV}"
+SRC_URI += "file://fix-zynqmp-assert.patch"
-SRC_URI = "git://github.com/Xilinx/embeddedsw.git;protocol=https;nobranch=1 \
- file://fix-zynqmp-assert.patch"
+inherit deploy
COMPATIBLE_HOST = "microblaze.*-elf"
COMPATIBLE_MACHINE = "microblaze-pmu"
diff --git a/meta-xilinx-standalone/recipes-standalone/pmu-firmware/pmu-firmware/fix-zynqmp-assert.patch b/meta-xilinx-standalone/recipes-bsp/embeddedsw/pmu-firmware/fix-zynqmp-assert.patch
index 87e1b111..87e1b111 100644
--- a/meta-xilinx-standalone/recipes-standalone/pmu-firmware/pmu-firmware/fix-zynqmp-assert.patch
+++ b/meta-xilinx-standalone/recipes-bsp/embeddedsw/pmu-firmware/fix-zynqmp-assert.patch
diff --git a/meta-xilinx-standalone/recipes-bsp/embeddedsw/pmu-firmware_2019.2.bb b/meta-xilinx-standalone/recipes-bsp/embeddedsw/pmu-firmware_2019.2.bb
new file mode 100644
index 00000000..88b10b31
--- /dev/null
+++ b/meta-xilinx-standalone/recipes-bsp/embeddedsw/pmu-firmware_2019.2.bb
@@ -0,0 +1 @@
+require pmu-firmware.inc
diff --git a/meta-xilinx-standalone/recipes-bsp/embeddedsw/pmu-firmware_2020.1.bb b/meta-xilinx-standalone/recipes-bsp/embeddedsw/pmu-firmware_2020.1.bb
new file mode 100644
index 00000000..88b10b31
--- /dev/null
+++ b/meta-xilinx-standalone/recipes-bsp/embeddedsw/pmu-firmware_2020.1.bb
@@ -0,0 +1 @@
+require pmu-firmware.inc
diff --git a/meta-xilinx-standalone/recipes-bsp/embeddedsw/pmu-firmware_2020.2.bb b/meta-xilinx-standalone/recipes-bsp/embeddedsw/pmu-firmware_2020.2.bb
new file mode 100644
index 00000000..e2eca1b7
--- /dev/null
+++ b/meta-xilinx-standalone/recipes-bsp/embeddedsw/pmu-firmware_2020.2.bb
@@ -0,0 +1,3 @@
+require pmu-firmware.inc
+
+DEFAULT_PREFERENCE = "-1"
diff --git a/meta-xilinx-standalone/recipes-standalone/psm-firmware/psm-firmware_2019.2.bb b/meta-xilinx-standalone/recipes-bsp/embeddedsw/psm-firmware.inc
index a3ddb227..344bfca0 100644
--- a/meta-xilinx-standalone/recipes-standalone/psm-firmware/psm-firmware_2019.2.bb
+++ b/meta-xilinx-standalone/recipes-bsp/embeddedsw/psm-firmware.inc
@@ -1,12 +1,6 @@
-inherit deploy
-
-LICENSE = "Proprietary"
-LIC_FILES_CHKSUM = "file://license.txt;md5=39ab6ab638f4d1836ba994ec6852de94"
+require embeddedsw.inc
-SRCREV = "e8db5fb118229fdc621e0ec7848641a23bf60998"
-PV = "2019.2+git${SRCPV}"
-
-SRC_URI = "git://github.com/Xilinx/embeddedsw.git;protocol=https;nobranch=1"
+inherit deploy
COMPATIBLE_HOST = "microblaze.*-elf"
COMPATIBLE_MACHINE = "versal-mb"
diff --git a/meta-xilinx-standalone/recipes-bsp/embeddedsw/psm-firmware_2019.2.bb b/meta-xilinx-standalone/recipes-bsp/embeddedsw/psm-firmware_2019.2.bb
new file mode 100644
index 00000000..61509c7a
--- /dev/null
+++ b/meta-xilinx-standalone/recipes-bsp/embeddedsw/psm-firmware_2019.2.bb
@@ -0,0 +1 @@
+require psm-firmware.inc
diff --git a/meta-xilinx-standalone/recipes-bsp/embeddedsw/psm-firmware_2020.1.bb b/meta-xilinx-standalone/recipes-bsp/embeddedsw/psm-firmware_2020.1.bb
new file mode 100644
index 00000000..61509c7a
--- /dev/null
+++ b/meta-xilinx-standalone/recipes-bsp/embeddedsw/psm-firmware_2020.1.bb
@@ -0,0 +1 @@
+require psm-firmware.inc
diff --git a/meta-xilinx-standalone/recipes-bsp/embeddedsw/psm-firmware_2020.2.bb b/meta-xilinx-standalone/recipes-bsp/embeddedsw/psm-firmware_2020.2.bb
new file mode 100644
index 00000000..11ef4038
--- /dev/null
+++ b/meta-xilinx-standalone/recipes-bsp/embeddedsw/psm-firmware_2020.2.bb
@@ -0,0 +1,3 @@
+require psm-firmware.inc
+
+DEFAULT_PREFERENCE = "-1"