aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-xilinx-standalone/recipes-bsp/embeddedsw/embeddedsw.inc13
-rw-r--r--meta-xilinx-standalone/recipes-bsp/embeddedsw/plm-firmware_git.bb56
-rw-r--r--meta-xilinx-standalone/recipes-bsp/embeddedsw/pmu-firmware_git.bb48
-rw-r--r--meta-xilinx-standalone/recipes-bsp/embeddedsw/psm-firmware_git.bb56
4 files changed, 167 insertions, 6 deletions
diff --git a/meta-xilinx-standalone/recipes-bsp/embeddedsw/embeddedsw.inc b/meta-xilinx-standalone/recipes-bsp/embeddedsw/embeddedsw.inc
index 49bbcae9..008dfef7 100644
--- a/meta-xilinx-standalone/recipes-bsp/embeddedsw/embeddedsw.inc
+++ b/meta-xilinx-standalone/recipes-bsp/embeddedsw/embeddedsw.inc
@@ -7,6 +7,7 @@ ESW_BRANCH[2019.1] = "release-2019.1"
ESW_BRANCH[2019.2] = "release-2019.2"
ESW_BRANCH[2020.1] = "release-2020.1"
ESW_BRANCH[2020.2] = "master-rel-2020.2"
+ESW_BRANCH[git] = "master"
BRANCH ??= "${@d.getVarFlag('ESW_BRANCH', d.getVar('ESW_VER')) or '${ESW_VER}'}"
ESW_REV[2019.1] = "26c14d9861010a0e3a55c73fb79efdb816eb42ca"
@@ -19,12 +20,12 @@ EMBEDDEDSW_BRANCHARG ?= "${@['nobranch=1', 'branch=${BRANCH}'][d.getVar('BRANCH'
EMBEDDEDSW_SRCURI ?= "${REPO};${EMBEDDEDSW_BRANCHARG}"
LICENSE = "MIT"
-LIC_FILES_CHKSUM[2019.1] = 'e9b6d01d45faccfbf05d8caea53f0a35'
-LIC_FILES_CHKSUM[2019.2] = '39ab6ab638f4d1836ba994ec6852de94'
-LIC_FILES_CHKSUM[2020.1] = '8b565227e1264d677db8f841c2948cba'
-LIC_FILES_CHKSUM[2020.2] = '3a6e22aebf6516f0f74a82e1183f74f8'
-LIC_FILES_CHKSUM[master] = '3a6e22aebf6516f0f74a82e1183f74f8'
-LIC_FILES_CHKSUM ??= "file://license.txt;md5=${@d.getVarFlag('LIC_FILES_CHKSUM', d.getVar('ESW_VER')) or '0'}"
+LIC_FILES_CHKSUM[release-2019.1] = 'e9b6d01d45faccfbf05d8caea53f0a35'
+LIC_FILES_CHKSUM[release-2019.2] = '39ab6ab638f4d1836ba994ec6852de94'
+LIC_FILES_CHKSUM[release-2020.1] = '8b565227e1264d677db8f841c2948cba'
+LIC_FILES_CHKSUM[master-rel-2020.2] = '3a6e22aebf6516f0f74a82e1183f74f8'
+LIC_FILES_CHKSUM[master] = '3a6e22aebf6516f0f74a82e1183f74f8'
+LIC_FILES_CHKSUM ??= "file://license.txt;md5=${@d.getVarFlag('LIC_FILES_CHKSUM', d.getVar('BRANCH')) or '0'}"
SRC_URI = "${EMBEDDEDSW_SRCURI}"
PV = "${ESW_VER}+git${SRCPV}"
diff --git a/meta-xilinx-standalone/recipes-bsp/embeddedsw/plm-firmware_git.bb b/meta-xilinx-standalone/recipes-bsp/embeddedsw/plm-firmware_git.bb
new file mode 100644
index 00000000..e1c2873c
--- /dev/null
+++ b/meta-xilinx-standalone/recipes-bsp/embeddedsw/plm-firmware_git.bb
@@ -0,0 +1,56 @@
+# Only should be used for development
+DEFAULT_PREFERENCE = "-1"
+
+require plm-firmware.inc
+
+SRC_URI += " \
+ file://0001-zynqmp_pmufw-Fix-reset-ops-for-assert.patch \
+ file://0001-zynqmp_pmufw-Correct-structure-header-of-PmResetOps.patch \
+ file://0001-sw_apps-versal_plm-Changes-to-ensure-versionless-bui.patch \
+ file://0001-versal_psmfw-misc-Update-makefile-for-version-less-b.patch \
+ file://zynqmp_pmufw-fixup.patch \
+ file://makefile-skip-copy_bsp.sh.patch \
+ "
+
+do_configure() {
+ # manually do the copy_bsp step first, so as to be able to fix up use of
+ # mb-* commands
+ . ${B}/../misc/copy_bsp.sh
+ echo "$BSP_SEQUENTIAL_MAKEFILES" > ${B}/seq.mak
+}
+
+do_compile() {
+ # First process the sequential items
+ for i in $(cat seq.mak); do
+ echo Include Seq: $i
+ if [ ! -d $i ]; then
+ echo "Skipping...."
+ continue
+ fi
+ oe_runmake -C $(dirname $i) -s include ${@bsp_make_vars(d)}
+ done
+ for i in $(cat seq.mak); do
+ echo Libs Seq: $i
+ if [ ! -d $i ]; then
+ echo "Skipping...."
+ continue
+ fi
+ oe_runmake -C $(dirname $i) -s libs ${@bsp_make_vars(d)}
+ done
+
+ # the Makefile in ${B}/../misc/Makefile, does not handle CC, AR, AS, etc
+ # properly. So do its job manually. Preparing the includes first, then libs.
+ for i in $(ls ${BSP_TARGETS_DIR}/*/src/Makefile); do
+ echo Include: $i
+ oe_runmake -C $(dirname $i) -s include ${@bsp_make_vars(d)}
+ done
+ for i in $(ls ${BSP_TARGETS_DIR}/*/src/Makefile); do
+ echo Libs: $i
+ oe_runmake -C $(dirname $i) -s libs ${@bsp_make_vars(d)}
+ done
+
+ # --build-id=none is required due to linker script not defining a location for it.
+ # Again, recipe-systoot include is necessary
+ echo Construct: executable
+ oe_runmake plm.elf ${@bsp_make_vars(d)} CC_FLAGS="-MMD -MP -Wl,--build-id=none -I${STAGING_DIR_TARGET}/usr/include"
+}
diff --git a/meta-xilinx-standalone/recipes-bsp/embeddedsw/pmu-firmware_git.bb b/meta-xilinx-standalone/recipes-bsp/embeddedsw/pmu-firmware_git.bb
new file mode 100644
index 00000000..f8975141
--- /dev/null
+++ b/meta-xilinx-standalone/recipes-bsp/embeddedsw/pmu-firmware_git.bb
@@ -0,0 +1,48 @@
+# Only should be used for development
+DEFAULT_PREFERENCE = "-1"
+
+require pmu-firmware.inc
+
+SRC_URI += " \
+ file://0001-zynqmp_pmufw-Fix-reset-ops-for-assert.patch \
+ file://0001-zynqmp_pmufw-Correct-structure-header-of-PmResetOps.patch \
+ file://0001-sw_apps-versal_plm-Changes-to-ensure-versionless-bui.patch \
+ file://0001-versal_psmfw-misc-Update-makefile-for-version-less-b.patch \
+ file://zynqmp_pmufw-fixup.patch \
+ file://makefile-skip-copy_bsp.sh.patch \
+ "
+
+do_configure() {
+ # manually do the copy_bsp step first, so as to be able to fix up use of
+ # mb-* commands
+ . ${B}/../misc/copy_bsp.sh
+ echo "$BSP_SEQUENTIAL_MAKEFILES" > ${B}/seq.mak
+}
+
+do_compile() {
+ # First process the sequential items
+ for i in $(cat seq.mak); do
+ echo Include Seq: $i
+ oe_runmake -C $(dirname $i) -s include ${@bsp_make_vars(d)}
+ done
+ for i in $(cat seq.mak); do
+ echo Libs Seq: $i
+ oe_runmake -C $(dirname $i) -s libs ${@bsp_make_vars(d)}
+ done
+
+ # the Makefile in ${B}/../misc/Makefile, does not handle CC, AR, AS, etc
+ # properly. So do its job manually. Preparing the includes first, then libs.
+ for i in $(ls ${BSP_TARGETS_DIR}/*/src/Makefile); do
+ echo Include: $i
+ oe_runmake -C $(dirname $i) -s include ${@bsp_make_vars(d)}
+ done
+ for i in $(ls ${BSP_TARGETS_DIR}/*/src/Makefile); do
+ echo Libs: $i
+ oe_runmake -C $(dirname $i) -s libs ${@bsp_make_vars(d)}
+ done
+
+ # --build-id=none is required due to linker script not defining a location for it.
+ # Again, recipe-systoot include is necessary
+ echo Construct: executable
+ oe_runmake executable.elf ${@bsp_make_vars(d)} CC_FLAGS="-MMD -MP -Wl,--build-id=none -I${STAGING_DIR_TARGET}/usr/include"
+}
diff --git a/meta-xilinx-standalone/recipes-bsp/embeddedsw/psm-firmware_git.bb b/meta-xilinx-standalone/recipes-bsp/embeddedsw/psm-firmware_git.bb
new file mode 100644
index 00000000..21ef13b5
--- /dev/null
+++ b/meta-xilinx-standalone/recipes-bsp/embeddedsw/psm-firmware_git.bb
@@ -0,0 +1,56 @@
+# Only should be used for development
+DEFAULT_PREFERENCE = "-1"
+
+require psm-firmware.inc
+
+SRC_URI += " \
+ file://0001-zynqmp_pmufw-Fix-reset-ops-for-assert.patch \
+ file://0001-zynqmp_pmufw-Correct-structure-header-of-PmResetOps.patch \
+ file://0001-sw_apps-versal_plm-Changes-to-ensure-versionless-bui.patch \
+ file://0001-versal_psmfw-misc-Update-makefile-for-version-less-b.patch \
+ file://zynqmp_pmufw-fixup.patch \
+ file://makefile-skip-copy_bsp.sh.patch \
+ "
+
+do_configure() {
+ # manually do the copy_bsp step first, so as to be able to fix up use of
+ # mb-* commands
+ . ${B}/../misc/copy_bsp.sh
+ echo "$BSP_SEQUENTIAL_MAKEFILES" > ${B}/seq.mak
+}
+
+do_compile() {
+ # First process the sequential items
+ for i in $(cat seq.mak); do
+ echo Include Seq: $i
+ if [ ! -d $i ]; then
+ echo "Skipping...."
+ continue
+ fi
+ oe_runmake -C $(dirname $i) -s include ${@bsp_make_vars(d)}
+ done
+ for i in $(cat seq.mak); do
+ echo Libs Seq: $i
+ if [ ! -d $i ]; then
+ echo "Skipping...."
+ continue
+ fi
+ oe_runmake -C $(dirname $i) -s libs ${@bsp_make_vars(d)}
+ done
+
+ # the Makefile in ${B}/../misc/Makefile, does not handle CC, AR, AS, etc
+ # properly. So do its job manually. Preparing the includes first, then libs.
+ for i in $(ls ${BSP_TARGETS_DIR}/*/src/Makefile); do
+ echo Include: $i
+ oe_runmake -C $(dirname $i) -s include ${@bsp_make_vars(d)}
+ done
+ for i in $(ls ${BSP_TARGETS_DIR}/*/src/Makefile); do
+ echo Libs: $i
+ oe_runmake -C $(dirname $i) -s libs ${@bsp_make_vars(d)}
+ done
+
+ # --build-id=none is required due to linker script not defining a location for it.
+ # Again, recipe-systoot include is necessary
+ echo Construct: executable
+ oe_runmake psmfw.elf ${@bsp_make_vars(d)} CC_FLAGS="-MMD -MP -Wl,--build-id=none -I${STAGING_DIR_TARGET}/usr/include"
+}